Operating System - NonStop OS
cancel
Showing results for 
Search instead for 
Did you mean: 

safecom problem

TomaszSerwanski
Occasional Advisor

safecom problem

Hello,

 

Trying to add new user; as result I see:

 

=====

=delete user kurs.user1
* ERROR * CANNOT OPEN $ZSMP : FILE ERROR = 201

=====

 

process $zsmp in fact does not exist; could anybody advice what could be the reason:

- $zsmp disappeared

- how to restart it?

 

regards

Tomasz

4 REPLIES
Paul Kurtz
Valued Contributor

Re: safecom problem

From Tacl you need to run  SCF and assume $zzkrn and then run status process $ZZKRN.#* and see if #ZSMP is running.

 

IF not you can run start process $zzkrn.#ZSMP from SCF.

 

Make sure you are super.super

TomaszSerwanski
Occasional Advisor

Re: safecom problem

Hello Paul,

 

Thank you for your answer; I did what you suggested, problem is that $ZSMP was in started status for a while, and got back to stopped:

 

======

3-> start process $zzkrn.#ZSMP
KERNEL W00030 Process \PKP.$ZSMP started successfully.
4-> status process $ZZKRN.#ZSMP

NONSTOP KERNEL - Status PROCESS \PKP.$ZZKRN.#ZSMP

Symbolic Name Name State Sub Primary Backup Owner
PID PID ID
ZSMP $ZSMP STARTED 0 ,1167 None 255,255
5-> status process $ZZKRN.#ZSMP

NONSTOP KERNEL - Status PROCESS \PKP.$ZZKRN.#ZSMP

Symbolic Name Name State Sub Primary Backup Owner
PID PID ID
ZSMP $ZSMP STARTED 0 ,1167 None 255,255
6-> status process $ZZKRN.#ZSMP

NONSTOP KERNEL - Status PROCESS \PKP.$ZZKRN.#ZSMP

Symbolic Name Name State Sub Primary Backup Owner
PID PID ID
ZSMP $ZSMP STOPPED None None
7->

======

 

I've opened case to HP already, but maybe you are aware what may be the problem?

 

regards

Tomasz

barkath
Occasional Advisor

Re: safecom problem

Hi Tomasz,

 

Error 201 indicates that path to the device is down. Can you please check the EMS logs while starting the $ZSMP process and see you get any clues.

 

0201 The current path to the device is down, an attempt was made to write to a
     non-existent process, the message-system request was incorrectly
     formatted, or an error was found in the message system interface.

 

 

TomaszSerwanski
Occasional Advisor

Re: safecom problem

Hello,

 

Seems root cause was entry in config; 'startup message' entry was as abowe:

 

*StartupMessage............Starting process $ZSMP

 

While fixed is:

 

*StartupMessage............"<BCKP-CPU>"

 

At the moment it works fine.

 

regards

Tomasz