Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

AUTO Neg on Itanium blades running OpenVMS + Flex10

 
The Brit
Honored Contributor

AUTO Neg on Itanium blades running OpenVMS + Flex10

This is not a question. This is actually just a piece of information in response to a comment that was made in a thread on a different forum.

http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1439155

regarding the old practice of disabling AutoNegotiate on VMS systems, vis.

"Very outdated! It might have been relevant last century with a limited set of very old adapters, but for at least the last 10 years, autonegotiate has worked correctly on all OpenVMS systems." (John Gittings)

Well sad to say, this is no longer a true statement. In particular, if you are running OpenVMS on bl860c or bl870c Itanium blades, AND you are using Flex10 VC modules, then AutoNegotiate MUST be disabled in LANCP in order to get the links to come up.

Specifically, In the Virtual Connect (VC) profile, the links must be set to "Custom 1G", and on the OS the LAN devices must be set to NOAUTO.

(Note: Auto is OK with the older VC Modules, it only fails with the Flex10 VC Modules.)

Hope this saves someone some time

Dave.
5 REPLIES 5
John Gillings
Honored Contributor

Re: AUTO Neg on Itanium blades running OpenVMS + Flex10

Dave,

Is this documented? Is it a recommendation by HP to get around a bug? What is the failure symptom?

Note that if it's GB ethernet, and autonegotiation is disabled, then so is flow control - could be an issue for high throughput applications.

(and in future, if you're going to quote me, please spell my name correctly ;-)
A crucible of informative mistakes
The Brit
Honored Contributor

Re: AUTO Neg on Itanium blades running OpenVMS + Flex10

John,
My sincere apologies (in all of these years I never noticed that the "tt"s were actually "ll"s).

Regarding the "Autonegotiate" issue. It came to light when we were trying to upgrade from the older 1/10G VC Modules to the new Flex10 VC modules. With the old modules, the EW devices were all set to AUTO in LANCP, and the ports were also set to AUTO in the VC profile.

We did not expect any issues with the upgrade, however! After the upgrade we discovered that it was impossible to get the network links to come up. We actually had to roll back the upgrade on our first attempt.

After about 6-8 weeks of trials and hair tearing, HP finally owned up to knowing about the issue and provided the solution (work-around??). This solution came out of a teleconference with VC Engineering. I have not seen anything official from HP to date. Not even a warning that the documented upgrade procedure from 1/10G to Flex10, does not actually work. There is no upgrade procedure, the only way to get from the old 1/10G VC modules to the Flex10 VC modules is to dump the existing VC domain, swap the hardware, and then rebuild the whole domain again from scratch.

Although much of this can be achieved by scripting, you still have to write the scripts (which are quite complex, and take significant thought.)

Since I heard nothing from HP officially in the way of an alert or a bulletin, I thought I would throw it out as information for people considering the upgrade.

Dave,

(Sorry again for the mis-spelling)
Michal Kapalka (mikap)
Honored Contributor

Re: AUTO Neg on Itanium blades running OpenVMS + Flex10

hi dave,

thank you, for this information.

mikap

Hoff
Honored Contributor

Re: AUTO Neg on Itanium blades running OpenVMS + Flex10

There's something ever so slightly humorous about FLEX10 requiring FIXED1000.
The Brit
Honored Contributor

Re: AUTO Neg on Itanium blades running OpenVMS + Flex10

Just intended for information.