Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Accounting Utility Problem - output conversion error

 
Rick Dyson
Valued Contributor

Accounting Utility Problem - output conversion error

Alpha/OpenVMS v7.3-2

I applied some ECOs on 12 Dec 2010 and I find now that any attempt to use the Accounting utility to search for records fails with this error: %OTS-F-OUTCONERR, output conversion error. I have one accounting log file that was opened on 2 Dec and runs through 3 Feb 2011. If I submit a search, it has results until 12 Dec, and then I get the above error.

On the live accounting file, I always get the error after a few records.

Anyone else see this problem on their system or is it just me?

I applied the following ECOs on 12 Dec 2010:

$ product show history /sin=1-dec-2010
------------------------------------ ----------- ----------- --- -----------
PRODUCT KIT TYPE OPERATION VAL DATE
------------------------------------ ----------- ----------- --- -----------
DEC AXPVMS VMS732_TDF V5.0 Patch Install 12-DEC-2010
DEC AXPVMS VMS732_MANAGE V8.0 Patch Install 12-DEC-2010
DEC AXPVMS VMS732_UPDATE V22.0 Patch Install 12-DEC-2010
DEC AXPVMS VMS732_SYS V21.0 Patch Install 12-DEC-2010
DEC AXPVMS VMS732_PCSI V6.0 Patch Install 12-DEC-2010
------------------------------------ ----------- ----------- --- -----------
5 items found
4 REPLIES 4
John Gillings
Honored Contributor

Re: Accounting Utility Problem - output conversion error

Rick,

Could you please post your exact ACCOUNTING command?

Do you get any output? Any fields filled with asterisks?

>Anyone else see this problem

I've run lots of systems on V7.3-2 for a lot of years, and used ACCOUNTING extensively. I've never seen a problem like this.

It may be worth checking the image. Here's what my V7.3-2 system looks like:

$ ANALYZE/IMAGE/INTERACTIVE SYS$SYSTEM:ACC.EXE
...
Image Identification Information

image name: "ACC"
image file identification: "X-18"
image file build identification: "XBOX-0060110000"
link date/time: 4-MAR-2008 09:40:58.33
linker identification: "A11-50"

The image list is:
0) "LIBRTL"
1) "LIBOTS"
2) "SCRSHR"
3) "SORTSHR"
4) "SYS$BASE_IMAGE"
5) "SYS$PUBLIC_VECTORS"


Do you have new or multiple versions of any of these images? The ACC image isn't installed, so you can switch between versions with:

$ DEFINE ACC SYS$SYSTEM:ACC.EXE;

then repeat your ACCOUNTING command.

Another possibility is your ACCOUNTNG.DAT file is corrupt.
A crucible of informative mistakes
Ian Miller.
Honored Contributor

Re: Accounting Utility Problem - output conversion error

I think this may be a known issue. Log a call.
____________________
Purely Personal Opinion
Rick Dyson
Valued Contributor

Re: Accounting Utility Problem - output conversion error

John, Just got off the phone with HP engineering who have provided me with an updated version of the Job$Controller (dated 21 Dec 2010) that fixes this problem. Apparently, The TDF v5 ECO I applied on 12 Dec introduced a bug that corrupts the records in the accounting log.

From the provided docs:

The TDF V5.0 kit on V7.3-2 was shipped with a newer version of job controller image; which refers to the latest version of accounting record, added in V8.4 for extended terminal names (ACC$K_VERSION = 4). Due to this, there were two types of records at customer site with older header and newer header formats. This is the base of the problem.
Engineering has built a special side image for OpenVMS 7.3-2 to rectify the problem:

So, I guess watch for TDF v6 or don't instal v5 if you want to read the accounting log and not just generate it!

Rick
Rick Dyson
Valued Contributor

Re: Accounting Utility Problem - output conversion error

HP Support has provided a remedial fix at present. I will assume it will be made available later as an official ECO, but of course I do not speak for HP.