Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Advanced Server 7.3A ECO2

Enemy
Advisor

Advanced Server 7.3A ECO2

Hi, please give me advice.

One of my co-workers from other region wrote me a letter with recomendation to install AS7.3A ECO2. "Problem with access to last versions of files. PWRK$LMSRV holds previous version and shows its to client instead of new one".

Anybody have such problems?
If it is true, will be better to install ECO1 instead ECO2 or do not install ECOs at all?

P.S. Sorry for my language :-(
9 REPLIES
Uwe Zessin
Honored Contributor

Re: Advanced Server 7.3A ECO2

That sounds like the new version is created from the VMS side, correct? Well, I am afraid that the PC client will have to close his version of the file first. If I recall correctly the Advanced Server will keep that file open for some time so he will also have to wait for that period.

You _might_ get around this if you set a version limit of 1 - the VMS side may not be able to create a new file while the old one is open and locked. If you want to try this: please test it out very thorough!! With file versioning you can easily loose valueable data!
.
Martin P.J. Zinser
Honored Contributor

Re: Advanced Server 7.3A ECO2

Hello Enemy,

this specific problem is not mentioned in the release notes for ECO2. These list:

Brief Description of Problems Fixed in V7.3A ECO2
------------------------------------------------------------------------
- MCP running Out of Pipe Instances
- Printing Sometimes Fails with the File Lock Error
- Network Problems Cause OPLOCK Timeouts
- ADMINISTER SET PASSWORD Resulted in ACCVIO
- "Sharedb" file growing to an Unreasonable Size
- Crashes or Hangs Caused by OPLOFC Threads
- Browser Service Stays in PENDING State
- Excessive Pipes Consumption and File Lock Problems Due to invalidated Sessions
- Memory Leak When RPC Throws an Exception
- Cannot Establish Trust with Windows 2003 Domain
- "Access Denied" Error While Accessing Non-stream Files On ODS-2 Disks
- Advanced Server Does Not Bind to the Correct Device on a Multihomed System
- Several PWRK$LMSRV crashes.



Having said that, Advanced server is one of these products where it is generally advisable to be on the latest patch level (after previous testing).

Greetings, Martin
Enemy
Advisor

Re: Advanced Server 7.3A ECO2

Here the scenario:
1.Serverside program create file with version 1.
2.Client opens and closes this file thru Pathworks.
3.Serverside program create file with version 2.
2.Client want to see new version of file, but Pathworks give him old version.

P.S. $Set File/version_limit=1 is not solution of my problem. I need to track file versions.
Enemy
Advisor

Re: Advanced Server 7.3A ECO2

One more thing - clients rights for shared files is read only. His unable to change/delete them.
Karl Rohwedder
Honored Contributor

Re: Advanced Server 7.3A ECO2

I have just tested this szenario and encountered no problems (with a single textfile). Perhaps you file caching interval timer is extraordinary high, Check ADMIN/CONF -> ADVANCED
Enemy
Advisor

Re: Advanced Server 7.3A ECO2

Thanx, Karl.
I don't test it by myself, just hear about. No time and hardware to do this.
Brad McCusker
Respected Contributor

Re: Advanced Server 7.3A ECO2

You don't say what version of Advanced Server you are running. If it is V7.3A, you absolutely should upgrade to ECO2. And my recommendation has nothing to do with the problem you describe, it has everything to do with the overall stability of the product.

As to you problem, you don't say how the file is opened on the PC. If its opened from a .bat file or some similar mechanism as DOS would use, then, the Open File Cache on the Advanced Server is indeed keeping it open, and, you need to turn that down. I'm not aware of any problems fixed in ECO2 in this area - your collegue should be able to test that with current version.

It could also be opportunistic locking. Your collegue could try turning off oplocks to see if that helps (It might come at a performance cost). To turn off oplocks:

$ edit pwrk$common:pwrk.ini ! Add the following lines:

[PLM]
ENABLE_OPLOCKING = 0

and restart Advanced Server.


Brad McCusker
Software Concepts International
Enemy
Advisor

Re: Advanced Server 7.3A ECO2

Our software using couple of shares on AS with 3000+ files and up to 300 clients, connected to them. Who knows, may be with small workload (on test server) it works fine.
Enemy
Advisor

Re: Advanced Server 7.3A ECO2

The Bug with locking files by PWRK$LMSRV is present :(
Thanks Brad, ENABLE_OPLOCKING = 0 helps.