Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Advanced Server (Pathwork) V7.3ECO3 fails installation.

Antoniov.
Honored Contributor

Advanced Server (Pathwork) V7.3ECO3 fails installation.

Environment:
Alpha Server 400;
OpenVms V7.3-2 fresh installed;
A/S V7.3 fresh installed from layered products CD;
By http://www4.itrc.hp.com/service/patch/search.do?pageContextName=openvms::&searchContextName=openvms:alpha:7.3-2&searchType=patch.text.searchTypeBrowse&pageNumberStr=1&pageSizeStr=25&BC=patch.breadcrumb.main|
downloaded A/S V7.3ECO3;

Stopped A/S server (@SYS$STARTUP:PWRK$SHUTDOWN)
$ PRODUCT INSTALL ADVANCEDSERVER/SOURCE=
Install complete Advanced Server (license+authentication)
Delay reboot as long possible
Execution starting ...
0% 10% 20% 30% 40% 50% 60% 70% 80% 90%
%PCSI-I-PRCOUTPUT, output from subprocess follows ...
%DCL-W-ACTIMAGE, error activating image NCL
-CLI-E-IMAGEFNF, image file not found A12SHS$DKA100:[SYS0.SYSCOMMON.][SYSEXE]NC;
%DCL-W-MAXPARM, too many parameters - reenter command with fewer parameters
%DCL-W-ABKEYW, ambiguous qualifier or keyword - supply more characters

%PCSI-E-EXEPSTFAIL, product supplied EXECUTE POSTINSTALL procedure failed
-CLI-W-ABKEYW, ambiguous qualifier or keyword - supply more characters
%PCSI-E-OPFAILED, operation failed
Terminating is strongly recommended. Do you want to terminate? [YES]

After of this installation abort even I ask to continue.
Pathwork seems to work fine (previous version).

Supplemental info:
I use CA07.02 license and I enabled it updating PWRK$LICENSE_R_START.COM

Can somebody help me?

Antonio Vigliotti
Antonio Maria Vigliotti
18 REPLIES
Jan van den Ende
Honored Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Antonio,

usually the FIRST error is the important one,
and all following are generated by some function not performed because of the first.

So, NOT having DECnet V is fatal!!!

Someone in engeneering should be REALLY ashamed, this is NOT in the VMS tradition!!!

Antonio, I guess you will have to install DECnet V just to get this done, or wait until HP repairs this UGLY BUG.

Sorry, no better help available.

Wim has a stream active asking for problems with patches. You should enter this one to it! (knowing your activity in this forum, maybe you alrewady did??)


Jan
Don't rust yours pelled jacker to fine doll missed aches.
Antoniov.
Honored Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Jan,
I'm with you on that. I guess I have to install decnet-plus before this. I have most used vms license because I'm a DSPP partner and in theese days I'm installaing the new version of various products.
I don't know decnet-plus, so I thougth still remain with decnet IV but now I have to kwnow this version of decnet.

Thanks for your answer.
Antonio Vigliotti
Antonio Maria Vigliotti
Willem Grooters
Honored Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Antonio,

Contact HP on this. Jan is definitely right, someone has gone mad with HP. DECNet (either version) is by no means a requirement for Advanced Server (as you undoubtably know), and the installation should allow DECNet to be not installed.
Even if VMS 7.3-2 comes with DecNet-Plus by default, it will even start it in SYS$STARTUP, but as long as DECNET is not configured and fully up and running, the installation should _ignore_ it.
(Have you choosen NOT to install DECNet (IV or V) during installation? that _might_ be your problem. It's no problem to INSTALL - just don't configure it. (I found TCPIP requires it, after I de-installed DECNet - which may have been the cause of problems)

Willem
Willem Grooters
OpenVMS Developer & System Manager
faris_3
Valued Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Hi,
The installation can be contined :

"customers running DECnet phase IV (on VMS 7.3-1 and VMS 7.3-2) should say
"NO" to "do you wish to terminate?" message and continue with the installation.
Installation of AS V7.3A-ECO3 on systems running DECnet phase V would
not report any error.

To say it in a few words, those error messages would not affect the
installation or working of the product in any way. We request the users to
ignore the error messages (with DECnet phase IV) and complete the installation.
The problem would be fixed with the next release of Advanced Server."

hth,
HF
Dave Gudewicz
Valued Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=655297

I posted this a few weeks ago on this forum.

Same subject. Engineering knows about this.
Antoniov.
Honored Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Faris,
I continued after error but installation didn't work.
Dave,
thank for your (moral) support. I installed decnet plus (decnet V) but after this I don't see any NCL command.
Next day I'll repeat installation of A/S.

Antonio Vigliotti

Antonio Maria Vigliotti
Martin Vorlaender
Honored Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Antonio,

>>>
I installed decnet plus (decnet V) but after this I don't see any NCL command.
<<<

NCL isn't installed into the DCL tables. You have to call it via $RUN SYS$SYSTEM:NCL (or $MCR NCL for short).

cu,
Martin
Willem Grooters
Honored Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Nevertheless, no matter what the outcome will be: Dave is right. The problem shouldn't have occurred in the first place.

What if a site has NO DECNet installed at all(like Antionio's), runs AS. They will not be able to install ECO3. Or it should be mentioned in the releasenotes taet, from this ECO on, DECnetPlus is a REQUIREMENT. DecNet IV is possible, but than say NO.

I doubt this is acceptable.
Engineering has to solve the problem. ASAP.

Willem
Willem Grooters
OpenVMS Developer & System Manager
Jan van den Ende
Honored Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Willem,

you really mean this to read as:
ONLY tcpip, NO DECnet (4 or 5), then NO AS??

Well, we would not (yet, but coming to this theater soon, I guess) be hurt, be this INDEED is ABSOLUTELY not acceptable!!

ip-only sites are not so scarse any more, and you may expect their number to be increasing.

Jan
Don't rust yours pelled jacker to fine doll missed aches.
Brad McCusker
Respected Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Everyone,

I agree this is an ugly and embarrassing error. But, it is just that, an error. It is not part of some larger plan to require DECnet.

Engineering is aware of the problem. It will be fixed in the next ECO or next release.

There is no requirement for any flavor of DECnet to run Advanced Server. There is not a requirement today, and there is no reason to make it a requirement in the future.

Antonio stated that the installation still failed. This is unusual, and, might be indicative of another problem. If you continue the installation, it should succeed. If Antonio wants to pursue this further, he needs to tell us more about how the installation failed, after electing to continue.

Regards,

Brad McCusker

Brad McCusker
Software Concepts International
Anton van Ruitenbeek
Trusted Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Antonio,

A quick answer: I don't use DECnet at home (IP-only) and using VMS 7.3-2 (incl. latest patches), IP 5.4 and AS 7.3. So I'm sure this can not be you're problem.

AvR
NL: Meten is weten, maar je moet weten hoe te meten! - UK: Measuremets is knowledge, but you need to know how to measure !
Anton van Ruitenbeek
Trusted Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Antonio,

I have installed this evening on my machine AS 7.3 eco 3 without any problems. Only I upgraded from eco 2 to 3. So maybe this is why I don't have the problem you are facing.
The installation went: OK
The pwrk$config went: OK
The reboot and startup: OK

So I think maybe there went something wrong in previous installation ?

AvR
NL: Meten is weten, maar je moet weten hoe te meten! - UK: Measuremets is knowledge, but you need to know how to measure !
Antoniov.
Honored Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Anton,
just for curiosity
what is your exactly configuration to compare?

Description.....: My Value | Your Value
VMS version.....: V.3-2
Adv.Server vers.: V7.3 noeco
DecNet..........: IV
A/S license lev.: CA07.02

I've not installed ECO2 of A/S and I don't upgrade licence from CA07.02 to CA07.03

TIA
Antonio Vigliotti
Antonio Maria Vigliotti
Anton van Ruitenbeek
Trusted Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Antonio,

Al the versions are stated before, the license I use is CA07.03.
- OpenVMS 7.3-2
- Previous AS 7.3 eco 2
- Current AS 7.3 eco 3
- TCP/IP 5.4 eco 2
- No Decnet.
(On an AlphaStation DS20E, 1 Gb and a lot of disks)

AvR
NL: Meten is weten, maar je moet weten hoe te meten! - UK: Measuremets is knowledge, but you need to know how to measure !
Antoniov.
Honored Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Mhm, interesting ...
may be you have eco2 or license not stated.

Thank you Anton for your response.
Antonio Vigliotti

Antonio Maria Vigliotti
Brad McCusker
Respected Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

The root cause of the problem is a modification in ECO3 to correctly register the network object, PCX$SERVER,
during product installation. This object is required for "eXcursion" users.

Is it possible that Anton already has that object for some reason?

I still would like to know more about Antonio's failure.
Brad McCusker
Software Concepts International
Antoniov.
Honored Contributor

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Brad,
I removed Decnet IV and installed Decnet plus. Then I've gone to my summer holydays and this week I'm running for my customers. I guess I'll repeat installation next week.

Thank you
Antonio Vigliotti
Antonio Maria Vigliotti

Re: Advanced Server (Pathwork) V7.3ECO3 fails installation.

Hi guys!

I had a similar problem, log text is below.

Advanced Server appeared to look for DECnet-plus being installed and logged an error with NCL.EXE not being found. However the installation continued and seemed to complete successfully, although a problem on the TCPIP side caused some grief.

Here is the appropriate log text:

The following product will be installed to destination:
CPQ AXPVMS ADVANCEDSERVER V7.3-A3 DISK$AXPVMSSYS:[VMS$COMMON.]

Portion done: 0%...10%...20%...30%...60%...70%...90%
To automatically start Advanced Server V7.3A for OpenVMS at
system startup, you should add the following line to the
SYS$MANAGER:SYSTARTUP_VMS.COM file.
$ @SYS$STARTUP:PWRK$STARTUP
Note: Add this line after the lines that start all the network
transports, such as DECnet.
To automatically stop Advanced Server V7.3A for OpenVMS at
system shutdown, you should add the following line to the
SYS$MANAGER:SYSHUTDWN.COM file.
$ @SYS$STARTUP:PWRK$SHUTDOWN
Note: Add this line before the lines that stop any of the
network transports, such as DECnet.
Before starting Advanced Server V7.3A for OpenVMS on this node,
be sure to configure the product (@SYS$UPDATE:PWRK$CONFIG) on
each node in the cluster where the product will run.

%PCSI-I-PRCOUTPUT, output from subprocess follows ...
%DCL-W-ACTIMAGE, error activating image NCL
-CLI-E-IMAGEFNF, image file not found TEST1$DKA0:[SYS0.SYSCOMMON.][SYSEXE]NCL.EX
E;
%DCL-W-MAXPARM, too many parameters - reenter command with fewer parameters
%DCL-W-ABKEYW, ambiguous qualifier or keyword - supply more characters

%PCSI-E-EXEPSTFAIL, product supplied EXECUTE POSTINSTALL procedure failed
-CLI-W-ABKEYW, ambiguous qualifier or keyword - supply more characters
%PCSI-E-OPFAILED, operation failed
Terminating is strongly recommended. Do you want to terminate? [YES] n
Portion done: 100%

The following product has been installed:
CPQ AXPVMS ADVANCEDSERVER V7.3-A3 Layered Product

%PCSI-I-IVPEXECUTE, executing test procedure for CPQ AXPVMS ADVANCEDSERVER V7.3-
A3 ...

Copyright 2002 Compaq Computer Corporation.

Starting Installation Verification Procedure
for Advanced Server V7.3A for OpenVMS

%PWRK-I-NORMAL, IVP completed successfully
%PCSI-I-IVPSUCCESS, test procedure completed successfully
%PCSIUI-I-COMPWERR, operation completed after explicit continuation from errors
TEST1_SYSTEM$ di sys$sysdevice:[*...]ncl.exe
%DIRECT-W-NOFILES, no files found

We have DECnet phase IV installed and had just upgraded VMS to 7.3-2 prior to this.

Following the workaround of the TCPIP problem, Advanced Server seemed to run up OK, although I've not got a network to test everything on yet.

I agree that problems such as this are not what we expect from Open VMS and I hope it's an isolated occurrence, although the TCPIP problem suggests otherwise (bug in v5.4 ECO2 to be fixed in ECO3 apparently...)