Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Anybody have CSWS2.1-1 , CSWS_PHP1.3 work well with Oracle10g on OpenVMS v8.3?

 
Z.K.
Frequent Advisor

Anybody have CSWS2.1-1 , CSWS_PHP1.3 work well with Oracle10g on OpenVMS v8.3?

Hi all!
Have anybody got CSWS v2.1-1 (patch1), CSWS_PHP v1.3 (patch1) work well with Oracle10g(for Itanium VMS)?
I've tried several times but the php script couldn't connect to Oracle database!

I've the following informations in the attachment:
1. information of user: apache$www
2. login.com in apache root directory
3. httpd.conf
4. php.ini
5. tnsnames.ora
6. My php script for test
7. Execution result of the php script.
8 REPLIES 8
Willem Grooters
Honored Contributor

Re: Anybody have CSWS2.1-1 , CSWS_PHP1.3 work well with Oracle10g on OpenVMS v8.3?

Haven't you asked before?

http://forums12.itrc.hp.com/service/forums/questionanswer.do?threadId=1198622

As I sated there, it might well be a problem with the PHP_OCI8 extension, that is incompatible with Oracle10g, and ask you to check things if possible - but no answer on these yet.
Willem Grooters
OpenVMS Developer & System Manager
Z.K.
Frequent Advisor

Re: Anybody have CSWS2.1-1 , CSWS_PHP1.3 work well with Oracle10g on OpenVMS v8.3?

Willem.
Yes, I asked this question.
Since I'm studying this myself now, I don't have a metallink account or something like this. So I can only refer to google or forums like this for help. :(
But I haven't found any usefull information which could help me solve this problem or let me know this system won't work.
I just don't want to give up, so I'm asking again with more information to see if anyone could help now.
Rick Retterer
Respected Contributor

Re: Anybody have CSWS2.1-1 , CSWS_PHP1.3 work well with Oracle10g on OpenVMS v8.3?

I like this recommendation from the previous forum entry:

To check this, access the Alpha-based database from the Itanium: It should encounter the same problem.

Accessing the Itanium database from the Alpha however, would succced (in this matter).

If so, the problem is located in the interaction between PHPSHR/PHPOCI8 and the Oracle lxhcsn routine.

Did you have a chance to try this out?

Rick

- Rick Retterer



Rick Retterer
Respected Contributor

Re: Anybody have CSWS2.1-1 , CSWS_PHP1.3 work well with Oracle10g on OpenVMS v8.3?

Did you also find this pointer on the Web from Oracle? :

http://www.oracle.com/technology/tech/php/htdocs/php_troubleshooting_faq.html#conmgt

The error message you are getting is definately no help at all is it?

Cheers,
Rick
- Rick Retterer



Z.K.
Frequent Advisor

Re: Anybody have CSWS2.1-1 , CSWS_PHP1.3 work well with Oracle10g on OpenVMS v8.3?

Rick,
> To check this, access the Alpha-based database from the Itanium: It should encounter the same problem.
I can't test this, but I can access the Itanium database from my personal computer without any problem.
Willem Grooters
Honored Contributor

Re: Anybody have CSWS2.1-1 , CSWS_PHP1.3 work well with Oracle10g on OpenVMS v8.3?

[quote]
... but I can access the Itanium database from my personal computer without any problem.
[/quote]
The site Rick mentions tells you why:
[quote]
If you use PHP's oci8 extension, I strongly recommend upgrading to the re-factored version. Although first shipped with PHP 5.1.2, the new code was designed to work with PHP 4 onwards and is available as source code in PECL for use with existing PHP installations. Windows binaries for various PHP versions are at php_oci8.dll.
[/quote]
The first sentence could well tell the story of your problem. Given the fact that the PHP_MYSQL extension in HP's kit is based on MySQL3, it can well be that the PHPOCI8 extention is an older one as well. On Alpha you won't have a problem since it seems to be compatible with Oracle9, but reading between the lines the conclusion would be it's not with Oracle10.
You could try to rebuild the extension using the MOD_PHP and this extension's sourcecode, but be prepared for some research since the sourcekit form HP lacks any file for setting up logicals and any buildfiles, and the extension kit will lack any VMS specific files. The rebuilding of the MySQL extension may hold clues on how to set things up.:
http://www.pi-net.dyndns.org/piforum/viewtopic.php?t=64

Or wait. A MOD_PHP 1.3 update is said to be released shortly, and a PHP 5 implementation end 2008 (according c.o.v. - the link is in another thread on PHP)
Willem Grooters
OpenVMS Developer & System Manager
Z.K.
Frequent Advisor

Re: Anybody have CSWS2.1-1 , CSWS_PHP1.3 work well with Oracle10g on OpenVMS v8.3?

Willem,
It seems I have to wait for the update for PHP v1.3. Another way is to build the PHP+APACHE environment on PC and access to the database on Itanium VMS.
I can't open link "http://www.pi-net.dyndns.org/piforum/viewtopic.php?t=64" but thank you all the same for your help!
Willem Grooters
Honored Contributor

Re: Anybody have CSWS2.1-1 , CSWS_PHP1.3 work well with Oracle10g on OpenVMS v8.3?

I'm afraid you'll have to.
[hint]
Hopefully, HP will reverse the decision to remove the files used in building the environment and include them in the sourcekit AFTER the patch - to be able to (re)build my own extensions.
[/hint]
I could well live with the non-supportability of such a home-built environment.
Willem Grooters
OpenVMS Developer & System Manager