Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Apache 2.1-1 , PHP 2.1 and SSL 1.4 error on OPENVMS Alpha

 
sahir K
Occasional Visitor

Apache 2.1-1 , PHP 2.1 and SSL 1.4 error on OPENVMS Alpha

Hi,
I am stuck with an error.
When I am trying to qualify PHP 2.1 and SSL 1.4 to my product in OpenVMS ALPHA, I got below error.
"Syntax error on line 36 of /apache$specific/000000/conf/httpd.conf:
Can't locate API module structure `smh_config_module' in file /smh$common/modules/mod_smh_config.exe: function not implemente
d. "
But the same code works well with itanium versions of PHP and SSL .
I have added one line in the HTTPD.conf file, thats is "LoadModule php5_module modules/mod_php_apache-2_0.exe
".
Can someone help me.
5 REPLIES 5
Deeos
Regular Advisor

Re: Apache 2.1-1 , PHP 2.1 and SSL 1.4 error on OPENVMS Alpha

Hello Sahir,


check your apache version by doing this:
#/opt/hpws/apache/bin/apachectl -v

second thing
check entry 36 line of /apache$specific/000000/conf/httpd.conf file using this:

#cat -n /apache$specific/000000/conf/httpd.conf

third
#ll /smh$common/modules/mod_smh_config.exe

check permission for execute


and if possible, post output of /apache$specific/000000/conf/httpd.conf file



Regards
Deeos




Deepak
Hoff
Honored Contributor

Re: Apache 2.1-1 , PHP 2.1 and SSL 1.4 error on OPENVMS Alpha

deeos appears to have provided an answer for HP-UX or some other Unix box, and not the commands and syntax for VMS.

As for the likely trigger, there's a reference to an SMH update in the following thread that's needed for the SSL updates:

http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1367008

Given other issues with the VMS version of SMH, I generally don't have that package installed on VMS.
Rick Retterer
Respected Contributor

Re: Apache 2.1-1 , PHP 2.1 and SSL 1.4 error on OPENVMS Alpha

Sahir,
You need to follow the installation instructions carefully... and read carefully... SMH does NOT support PHP v2.1.

YOu have to use PHP v1.3.

PHP 2.1, brings along the "php5_module" which SMH doesn't support. This will be fixed in a future version of SMH.

When SMH starts up , it creates a customized version of httpd.conf that is specific only to the SMH software... Inside the customized version of SMH's httpd.conf file which is located in:

device:-[SYS0.SYSCOMMON.HP.HPSMH.yourhostname.conf]httpd.conf

you will find that PHP5 has been replaced with "PHP4" by the SMH startup procedure.

What you can do to work around this problem other than remove PHP v2.1 and install PHP v1.3, is to:

1) Edit the SMH specific version of httpd.conf, shown in the directory above.

2) Locate the directive that loads the "PHP4" module...

LoadModule php4_module modules/mod_php_apache-2_0.exe

and manually change it to "PHP5"...

LoadModule php5_module modules/mod_php_apache-2_0.exe

3) Save the file, and change the httpd.conf file so that it's version number is ;32767. By doing this, SMH cannot write out a new version because it's at the version limit, and the changes in the httpd.conf file will used in place of creating a new file.

Give that a try and let us know how it works out for you.

REF: http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1409830

Cheers,
Rick Retterer
- Rick Retterer



Rick Retterer
Respected Contributor

Re: Apache 2.1-1 , PHP 2.1 and SSL 1.4 error on OPENVMS Alpha

One more thing,I just learned that,
SMH Engineering has released a new patch to support PHP 2.1 and SSL 1.4. Patch name is SMH V2.0-21

Which can be obtained from here:


http://h71000.www7.hp.com/openvms/products/smh/


The following are the new features in HP SMH Patch Release V2.0-21:

Improved performance by fixing memory leak occurred in SMH$HMMODISCOV.
HP SMH V2.0-21 supports SSL V1.4 and CSWS_PHP V2.1.

Cheers,
Rick
- Rick Retterer



sahir K
Occasional Visitor

Re: Apache 2.1-1 , PHP 2.1 and SSL 1.4 error on OPENVMS Alpha

Hi,
Problem resolved. Issue is resolved by using the proper shareable image, while re-linking to the exe. I was wrongly using a SSL1.3 library image to make my exe. I corrected it by using the proper Library.
Thanks everyone to support.
Regards
Sahir K