Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Applications that require ODS5

 
Dave Gudewicz
Valued Contributor

Applications that require ODS5

My guess is that over time, ODS5 will probably become more of a requirement than it is today.

That said, might there be a listing of today's applications that do require ODS5 floating around somewhere?
18 REPLIES
Martin P.J. Zinser
Honored Contributor

Re: Applications that require ODS5

Hello Dave,

I am not aware of such a list. Examples that come to mind immediatly are Oracle (classic) and GNV. Others certainly will be able to supply more.

Greetings, Martin

P.S. You might want to check out how to assign points to the replies ;-)
John Eerenberg
Valued Contributor

Re: Applications that require ODS5

Apache requires ODS-5 on the Apache disk (though other disks can still use ODS-2).

Pack cluster sizes are more efficient on ODS-5 but that is available on ODS-2 disks too with restrictions. Read $ help init /cluster very carefully.

ODS-5 is not available on systems prior to VMS V7.2.

I think ODS-2 is easier to manage. Given the reasonableness of $init/cluster functionality on ODS-2, I will stay with ODS-2 for quite some time and use ODS-5 as needed. Of cource I'll probably change my mind next week when I see all the responses in this thread. :-)

john
It is better to STQ then LDQ
labadie_1
Honored Contributor

Re: Applications that require ODS5

Java, Python, Mysql...
Dave Gudewicz
Valued Contributor

Re: Applications that require ODS5

I see we are creating a list. ;-)

Thanks.
Uwe Zessin
Honored Contributor

Re: Applications that require ODS5

I think the major driving force for ODS-5 was/is Advanced Server V7.

It is great that you have agreed to compile a list ;-)
.
Jan van den Ende
Honored Contributor

Re: Applications that require ODS5

John


Apache requires ODS-5 on the Apache disk


Isn't it so that Apache >>> 2.0 <<< requires ODS-5, but Apache 1.x is quite happy with ODS-2?

And there are other reasons as well to NOT upgrade Apache 1.3 to 2.0 (the Stream_LF issue for example)
Jan
Don't rust yours pelled jacker to fine doll missed aches.
Dieter Rossbach
Regular Advisor

Re: Applications that require ODS5

Apache 1.3.x is fine with ODS-2.

Regards

Dieter
Dima Bessonov
Frequent Advisor

Re: Applications that require ODS5

It's not that simple with Oracle. Before Database Server 9 (i.e. for Oracle versions up to 8.1.7.x), ODS5 was NOT supported at all. From version 9 on, ODS5 is REQUIRED for the disk were Oracle puts its executables but is optional for database disks. The funny result of that is, if one upgrades Oracle from 8.1.7 to, say, 9.2 he MUST use both an ODS5 disk for the new Oracle "system" disk and an ODS2 disk for the existing one. You can't do the upgrade in place.
Brad McCusker
Respected Contributor

Re: Applications that require ODS5

>I think the major driving force for
>ODS-5 was/is Advanced Server V7.

No, not really. The driver was "NT affinity", remember that? Advanced Server V7 was part of on of the "Affinity Waves". Advanced Server V7* is very happy to serve ODS-2 disks as well as ODS-5.

Generally speaking, UNIX originated programs are more likely to need ODS-5. Certainly the underlying C-RTL is only adding UNIX file name support when on ODS-5 disks. New features tend to be ODS-5 specific as well.

Brad
Brad McCusker
Software Concepts International
Uwe Zessin
Honored Contributor

Re: Applications that require ODS5

Oh! NO! Brad, you have ruined my day ;-)
Please, never again mention 'affinity'...
.
Brad McCusker
Respected Contributor

Re: Applications that require ODS5

>Oh! NO! Brad, you have ruined my day ;-)
>Please, never again mention 'affinity'...

When we were talking about the work that became the UNIX Portability effort, we were trying to decide what to call it. Some one suggested "UNIX Affinity". If I recall correctly, I went screaming from the room... ;^)

Brad (who as one of the Project Leaders for Advanced Server was firmly entrenched in the "NT A-word" waves)
Brad McCusker
Software Concepts International
John Eerenberg
Valued Contributor

Re: Applications that require ODS5

Jan,
> "And there are other reasons as well to NOT upgrade Apache 1.3 to 2.0 (the Stream_LF issue for example)"
We are quite happy with v2 and developing new apps (imagine that!).
Could you elaborate on the stream_lf issue?
It is better to STQ then LDQ
Uwe Zessin
Honored Contributor

Re: Applications that require ODS5

Well done, Brad!!

I recall that the Tru64 people at that time had a similar program to hand their users over to NT as well, but I don't remember its name.
.
Martin P.J. Zinser
Honored Contributor

Re: Applications that require ODS5

Hi,

well, now there is a list at ;-)

http://zinser.no-ip.info/eng/vms/qaa/ods5app.htmlx


A few notes:

- I added Netbeans
- Java and MySQL are not on the list since to the best of my knowledge they do not require ODS-5. If you have sources showing otherwise please get in touch with me.

Greetings, Martin
Craig A Berry
Honored Contributor

Re: Applications that require ODS5

Martin,

I think the Java run-time works on ODS-2 but the SDK requires ODS-5.
Martin P.J. Zinser
Honored Contributor

Re: Applications that require ODS5

Hello Craig,

I looked at the installation instructions for the SDK and I did not see it mention ODS-5 as a requirement. Any specific quotes?

Greetings, Martin

Jan van den Ende
Honored Contributor

Re: Applications that require ODS5

John,

The quickest demo of the STREAM_LF issue in Apache 2.0 is perhaps also the easiest to do:
Display any existing HTML page, then EDIT it minimally (replace a space by a space eg), and do a Refresh on your browser.
I'm not sure if there are any browser dependencies, but over here 'everybody' has to use Billy's Exploder, and the results are terrific (as in totally useless): most of the display consists of small squares.
Really the only way to get things displayed as they used to be with Apache 1.3 is to have ALL files CONVERTed to STREAM_LF. Any program that delivers webpages has to be modified to have ALL generated or modified pages CONVERTed.
_WE_ definitely won't be upgrading to Apache 2.x before this is settled!


Jan
Don't rust yours pelled jacker to fine doll missed aches.
Willem Grooters
Honored Contributor

Re: Applications that require ODS5

It's a bit besides the topic - but this is just THE BIG POINT that a lot of people seem to forget.
Usage of OpenSource (read - UNIX-based) software seems to be designed and written without ANY idea of how other OS's may react. A lot of these programs can be VERY useful - when they only could co-operate with native (read non-Unix) programs. As long as the requirement of STREAM_LF format is not lifted, they cannot easily be used.

Same applies to ODS-5 and ODS-2. I wouldn't mind if the program itself required ODS-5 (Martin: JAVA 1.4.x does!), but I would mind the datafiles to require ODS-5 because of multiple dots, spaces and all kind of characters in the filename, or even very long filenames. No-one has ever convinced me of the usability of a filename + extension over 2 * 39 characters, let alone over 255 for the whole; nor have I been convinced about case-sensitivity in filenames (The only advantage is readability, sometimes).

There's a LOT of education to be done. Not only in just getting things running on VMS, the's easy enough. Point is to educate co-operation!

Willem
Willem Grooters
OpenVMS Developer & System Manager