HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Autogen not getting correct number of processes

 
SOLVED
Go to solution
Clark Powell
Frequent Advisor

Autogen not getting correct number of processes

Actual process count is almost 1500 but autogen says the highest is 325.

MAXPROCESSCNT parameter information:
Feedback information.
Old value was 3000, New value is 3000
Maximum Observed Processes: 325
- AUTOGEN parameter calculation has been overridden.
The calculated value was 2400. The value 3000
will be used in accordance with the following requirements:
MAXPROCESSCNT has been specified by a hard-coded value of 3000.
9 REPLIES
Clark Powell
Frequent Advisor

Re: Autogen not getting correct number of processes

Sorry, I'm tired today. We're using OpenVMS 8.3 with ECO Update 12.
Ian Miller.
Honored Contributor
Solution

Re: Autogen not getting correct number of processes

Have you collected feedback information during a peak time when there are 1500 processes?

SYS$SYSTEM:AGEN$FEEEDBACK.EXE writes a text file SYS$SYSTEM:AGEN$FEEDBACK.DAT

which you can search

$ sear sys$system:agen$feedback.dat proc
PROCESSES_PEAK = 78
MAXPROCESSCNT_CUR = 227

____________________
Purely Personal Opinion
labadie_1
Honored Contributor

Re: Autogen not getting correct number of processes

If you do

$ mc agen$feedback

$ sea sys$system:agen$feedback.dat processcnt_cur

do you see the correct value or not ?


Clark Powell
Frequent Advisor

Re: Autogen not getting correct number of processes

That is exactly the problem but somehow I thought that autogen feedback data was collected automatically. What's the actual method and time?
Volker Halle
Honored Contributor

Re: Autogen not getting correct number of processes

Clark,

AUTOGEN collects and uses feedback data, if you tell it to.

Autogen saves the feedback data in the SAVPARAMS phase or during SHUTDOWN with SAVE_FEEDBACK.

Autogen uses the feedback data in the GENPARAMS phase unless you specify P3 as NOFEEDBACK or there is some problem with the feedback data.

Check for messages in SYS$SYSTEM:AGEN$PARAMS.REPORT.

If you want AUTOGEN to save the feedback data and use it, specify:

$ @SYS$UPDATE:AUTOGEN SAVPARAMS GENPARAMS

Then check SYS$SYSTEM:AGEN$PARAMS.REPORT. If everything looks o.k., invoke AUTOGEN again with:

$ @SYS$UPDATE:AUTOGEN GETDATA SETPARAMS

and then reboot.

Volker.
Ian Miller.
Honored Contributor

Re: Autogen not getting correct number of processes

Note doing
@SYS$UPDATE:AUTOGEN SAVPARAMS SAVPARAMS
at a time of peak load is a good idea. Some of the collected data is a snapshot of current data.

You can do

@SYS$UPDATE:AUTOGEN GETDATA TESTFILES

to use the collected feedback to generate a report at another time.
____________________
Purely Personal Opinion
Clark Powell
Frequent Advisor

Re: Autogen not getting correct number of processes

Speaking for the few people with whom I've discussed AUTOGEN, this might be one of the big misconceptions in OpenVMS. I think it's possible that many people assume that the feed back data is being collected automatically, all the time. I like the idea of running at a peak time,
@SYS$UPDATE:AUTOGEN SAVPARAMS SAVPARAMS
and then running AUTOGEN to use the data at a later date.

But even if you collect feedback at a high period, what if you run AUTOGEN at a low useage time and it collects the low useage feedback? Won't that distort the result as well?
Volker Halle
Honored Contributor

Re: Autogen not getting correct number of processes

Clark,

the PEAK values will still be preserved as long as you don't reboot the system. If you have to reboot after a phase of high usage and before willing to run AUTOGEN, use the SAVE_FEEDBACK option during shutdown.

Volker.
RBrown_1
Trusted Contributor

Re: Autogen not getting correct number of processes

If you do @AUTOGEN SAVPARAMS SAVPARAMS at a busy time and then do the rest of the autogen later then you have to start the second autogen AFTER SAVPARAMS so that you don't collect new feedback data. So

$ @AUTOGEN GETDATA TESTFILES

or

$ @AUTOGEN GETDATA SETPARAMS

etc.