Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Beware of VMS83A_RMS V8.0 Patch

 
Karl Rohwedder
Honored Contributor

Beware of VMS83A_RMS V8.0 Patch

This patch contains a new SYS$BASE_IMAGE.EXE and tries to set the correct VMS Version string in PCSI_POSTINSTALL.COM using SYSVER.EXE.
It uses an undefined DCL Symbol resulting in an emtpy VMS version string after reboot, which may lead to interesting effects... :-)

So if you install this patch, be sure to set the correct VMS version before rebooting, e.g.:

Excerpt from PCSI_POSTINSTALl.COM:

$ os_version = "V8.3"
$ Current_default = F$ENVIRONMENT ("DEFAULT")
$ ww1 = "write work_1"
$ open/write work_1 post_setsysver.com
$ ww1 "$ set default SYS$COMMON:[SYS$LDR]"
$ ww1 "$ run sysver"
$! ww1 "REPLACE ""''new_version'""
$! replace new_version with os_version
$ ww1 "REPLACE ""''os_version'""
$ ww1 "write"
$ ww1 "exit"
$ ww1 "$ exit"

regards Kalle
4 REPLIES 4
Ian Miller.
Honored Contributor

Re: Beware of VMS83A_RMS V8.0 Patch

Has this been reported formally to HP?

Thanks for reporting this here and hopefully a new RMS patch will be along shortly. Makes me wonder about the testing of this patch kit :-(
____________________
Purely Personal Opinion
Karl Rohwedder
Honored Contributor

Re: Beware of VMS83A_RMS V8.0 Patch

I started the Servicerequest before posting here. It has been reported to VMS engeneering, so stay tuned for a new patch...

regards Kalle
Karl Rohwedder
Honored Contributor

Re: Beware of VMS83A_RMS V8.0 Patch

Since this was only an info, I close this thread.
Highlighted
Karl Rohwedder
Honored Contributor

Re: Beware of VMS83A_RMS V8.0 Patch

Here's the answer from HP:

The VMS83A_RMS-V0800 release that was done earlier today has been cancelled.
The kit has been pulled back so that we can include one more change. The kit will be re-released later next week.

regards Kalle