Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

CSWS PHP 2.2-1

 
Gregg Parmentier
Frequent Advisor

CSWS PHP 2.2-1

 

Under PHP 2.2 the following code bit worked:

 

$dirs = array('|src/.*|', '|plugins/.*|', '|functions/.*|');

$repl = array('', '', '');

$base_url = preg_replace($dirs, $repl, $PHP_SELF);

 

under PHP 2.2-1, it gives the following error:

 

Warning: preg_replace() [function.preg-replace]: Internal pcre_fullinfo() error -3

 

any ideas what's up?

 

6 REPLIES 6
Maurizio De Tommaso_
Valued Contributor

Re: CSWS PHP 2.2-1

Please, contact the Hp support. It seems to be definitely a problem of the new PHP code V2.2-1.

 

Best regards,

/Maurizio

Gregg Parmentier
Frequent Advisor

Re: CSWS PHP 2.2-1

 

How would I go about using HP support w/o a paid license?  I'm in the hobbyist program.

 

Craig A Berry
Honored Contributor

Re: CSWS PHP 2.2-1

Note that by default, the pcre regular expression library is built with dependencies on zlib and bzip2 (this from a quick Google on "pcre prerequisites").  I have no idea whether HP built it with those features, but suppose for a moment that they did.

 

Then look at what PHP extensions you get loaded with the default initialization file:

 

$ search apache$common:[php]php.ini pcre,bz2,zlib
;extension=php_bz2.exe
extension=php_pcre.exe
;extension=php_zlib.exe

 

So the pcre extension is uncommented and available.  But if it depends on other extensions that are commented out (such as php_bz2 and php_zlib), that would be trouble.

 

It won't cost you much to uncomment the bz2 and zlib lines and see what happens.  It's just a wild guess, though; there could be many other things wrong here.

Gregg Parmentier
Frequent Advisor

Re: CSWS PHP 2.2-1

I wish it were that easy.  I enabled everything hoping that might be the case:-(

 

Jeremy Begg
Trusted Contributor

Re: CSWS PHP 2.2-1

Gregg, suggest you change to Mark Berryman's PHP port.
http://www.theberrymans.com/php_kits/

More complete than the HP implementation and Mark will accept problem reports from hobbyists.

Regards,
Jeremy Begg
Maurizio De Tommaso_
Valued Contributor

Re: CSWS PHP 2.2-1

HP released the CSWS_PHP kit version 5.2-17. It runs with HP Secure Web Server Versions 1.3-1 and 2.1 and later for OpenVMS Alpha and Integrity servers. It does not work with Secure Web Server Version 2.0.

 

http://h71000.www7.hp.com/openvms/products/ips/apache/csws_php.html

 

As you can note, starting from this release the version number of the Hp PHP kits will be aligned to the open source version.

 

This kit is stable and it runs well.

 

New features included in CSWS_PHP Version 5.2-17 are as follows:

 

  • CSWS_PHP based on PHP 5.2.17

     

    The following changes are included in this release:

     

    • Fix for critical vulnerability associated to floating point.
    • Updated time zone database to version 2010.5.
    • Upgraded bundled PCRE to version 8.02.
    • Rewrote var_export() to use smart_str rather than output buffering, prevents data disclosure if a fatal error occurs.
    • Resolved a critical issue, reported as PHP bug #53632.
    • Built PHP MYSQL extension with MYSQL V5.1.23-rc client API.

The following security fixes are included in this release:

 

A complete list is available at the PHP website http://www.php.net/.

 

Note: CVE-2011-4566 is applicable to PHP V5.2.17, but only 32-bit PHP binaries are affected by this CVE. The 64-bit PHP binaries are ported to OpenVMS.