Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Communicating through serial port

SOLVED
Go to solution
Ivan_118
Occasional Contributor

Communicating through serial port

I am trying to communicate with a serial device through one of the serial port. Somehow it doesn't establish a connection

here is what I entered and return a message number. It used to work before.

$ set host/dte txa1:

%REM-I-NOMSG, Message number 01FEE00B

Any thought
Thanks.
Ivan
7 REPLIES
Dale A. Marcy
Trusted Contributor

Re: Communicating through serial port

Are you running from a privileged account? If not, please post the output from a SHOW DEV/FULL TXA1: command. I entered HELP SET HOST /DTE and found the following:

You must also have the ability to assign a channel to the
terminal port specified. Your system manager can set the device
protection on the terminal port to allow you access.
Ivan_118
Occasional Contributor

Re: Communicating through serial port

Yes I am running from a privileged account.

$ show dev/full txa1:

Terminal TXA1:, device type unknown, is online, record-oriented device, carriage
control.

Error count 0 Operations completed 15
Owner process "" Owner UIC [SYSTEM]
Owner process ID 00000000 Dev Prot S:RWPL,O:RWPL,G,W
Reference count 0 Default buffer size 80

I tested the port with other terminal with following command. It works OK.

$ copy test.txt txa1:

My question is:
How do I get into command mode after $ set host/dte txa1 ?

Thanks again:)
Phil.Howell
Honored Contributor

Re: Communicating through serial port

It should pick up the error message from
NETWRKMSG.EXE

_TNA42:show dev lta1500 /full

Terminal LTA1500:, device type unknown, is online, record-oriented device, carriage control.
Error count 0 Operations completed 36
Owner process ""
Owner UIC [SYSTEM]
Owner process ID 00000000
Dev Prot S:RWPL,O:RWPL,G:RWPL,W:RWPL
Reference count 0
Default buffer size 80

My G: and W: values differ from yours,
but this may be irrelevant.

_TNA42:set host/dte lta1500:

%REM-I-TOQUIT, connection established

Press Ctrl/\ to quit, Ctrl/@ for command mode

Phil
Joseph Huber_1
Honored Contributor

Re: Communicating through serial port

> How do I get into command mode after $ set host/dte txa1 ?

What do You mean with "command mode" ?
After set host, Your terminal(window) is speaking with the serial port, i.e. whatever You type is sent out to the port, and whatever the port send is displayed on Your screen.

What is connected to the port (txa1:) ? What do You expect from it ?

If it should respond with printable characters but does not, check:

Are the port settings (speed,sync,etc.) matching ? (SHOW TERM txa1:).

Is txa1: set type-ahead and got XOFF ? (set term txa1:/notype_ahead) and try to send control+Q to see if it unblocks.
http://www.mpp.mpg.de/~huber
Volker Halle
Honored Contributor

Re: Communicating through serial port

Ivan,

you can define a control-character to enter command mode:

$ set host/dte/command=d tta0:

%REM-I-TOQUIT, connection established

Press Ctrl/\ to quit, Ctrl/D for command mode

DTEPAD> quit

%REM-S-END, control returned to node nodenm

Volker.
Volker Halle
Honored Contributor
Solution

Re: Communicating through serial port

Ivan,

the text for message number 01FEE00B is the standard %REM-I-TOQUIT message.

Volker.
Ivan_118
Occasional Contributor

Re: Communicating through serial port

Volker,

Thanks! I can talk to the serial device.

Ivan