Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Compaq Secure Web Server 2.1-1 ECO 1 on OpenVMS 8.3

Adam Bunn
Occasional Contributor

Compaq Secure Web Server 2.1-1 ECO 1 on OpenVMS 8.3

Has anyone managed to get Compaq Secure Web Server (Apache) version 2.1-1 ECO 1 running on OpenVMS Alpha Version 8.3. We have recently upgraded a test system and I have been unable to get CSWS 2.1-1 to run. The following error occurs during the startup:

%DCL-W-ACTIMAGE, error activating image APACHE$HTTPD_SHR
-CLI-E-IMGNAME, image file $1$DRA0:[SYS0.SYSCOMMON.APACHE.][000000]APACHE$HTTPD_SHR.EXE
-SYSTEM-F-SHRIDMISMAT, ident mismatch with shareable image

It looks like the APACHE$HTTPD_SHR.EXE needs to be relinked on an OpenVMS Alpha 8.3 system, but this is not really an option with the CSWS 2.1-1 install kit provided by HP.
Thanks.
Adam.
5 REPLIES
Craig A Berry
Honored Contributor

Re: Compaq Secure Web Server 2.1-1 ECO 1 on OpenVMS 8.3

Actually it looks more like APACHE$HTTPD_SHR.EXE *was* relinked, and you probably have something else that needs to be relinked against it. Do you have any add-ons, mod_xxx extensions, etc?
Willem Grooters
Honored Contributor

Re: Compaq Secure Web Server 2.1-1 ECO 1 on OpenVMS 8.3

IIRC: on each update of apachem, you'll need:

$ @SYS$STARTUP:APACHE$SHUTDOWN
$ @SYS$MANAGER:APACHE$CONFIG
$ @SYS$STARTUP:APACHE$STARTUP

that way, you're sure the installed images will be installed.

The CONFIG part might not be needed but will have to stop and start Apache.
Willem Grooters
OpenVMS Developer & System Manager
Willem Grooters
Honored Contributor

Re: Compaq Secure Web Server 2.1-1 ECO 1 on OpenVMS 8.3

Forgot: Are you running Tomcat as well? You'll have to stop that as well, and start it before apache.
Willem Grooters
OpenVMS Developer & System Manager
Adam Bunn
Occasional Contributor

Re: Compaq Secure Web Server 2.1-1 ECO 1 on OpenVMS 8.3

Thanks for your replies. Yes the link problem was not with the HTTPD_SHR.EXE shareable image executable, but with some part of APACHE that was linked against it. I had tried numerous times to restart APACHE using APACHE$SHUTDOWN and APACHE$STARTUP but this did not resolve the issue. In the end a server reboot resolved the problem. I suspect that the cause was that the installed HTTPD_SHR.EXE image was from an older Apache release and was not being correctly uninstalled by APACHE$SHUTDOWN.
Adam Bunn
Occasional Contributor

Re: Compaq Secure Web Server 2.1-1 ECO 1 on OpenVMS 8.3

Server reboot resolved this.