Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Connect to OpenSSH

 
SOLVED
Go to solution

Connect to OpenSSH

I would like to use SCP to connect to OpenSSH (Solaris 9) servers using public key without password. The public/private keys uses separate formatting (in addition to differences with authorized_keys vs AUTHORIZATION. etc). However, I cannot get it working.
Connecting from OpenSSH to OpenVMS is also not working, but this is not as important.

Anyone got it working?
Is it just my formatting?

TCPIP Services 5.4 ECO 4
Tried keys (DSS) generated in both Solaris and OpenVMS.
SSH is not stable yet. The bug with max one key in IDENTIFICATION. gave me a brain melt.
"scp -p" would be nice too.

Gerhard
4 REPLIES
Robert_Boyd
Respected Contributor

Re: Connect to OpenSSH

Could you provide some specific error messages that you get when attempting to connect to/from your OpenVMS system?

Also, have you looked in your log files in TCPIP$SSH_HOME: directory?

Robert
Master you were right about 1 thing -- the negotiations were SHORT!
Martin Vorlaender
Honored Contributor
Solution

Re: Connect to OpenSSH

Gerhard,

TCP/IP Services' SSH is based on ssh.com's implementation, so it uses the SECSH key file format. I.e., when transfering key files from/to the OpenSSH system, you have to export/import them (ssh-keygen -e/-i - no idea whether the Solaris implementation has these).

authorized_keys vs. authorization is *not* an issue of VMS vs. OpenSSH, but SSHv1 vs. SSHv2.

cu,
Martin

Re: Connect to OpenSSH

Thanks, this solved the problem. Converting keys are described for instance here:

http://www.cs.berkeley.edu/~dtliu/sshinterop.html

However, I still had a few problems. Some findings:
* Solaris 10 has switches -i/-e but uses -X/-x in Solaris 9.
* With Solaris 9, keys must be generated in OpenVMS, because there is a problem converting (public only) openssh->ssh.com.
ssh_keygen "-D" does not work in OpenVMS (tries to convert public-> private, then writes "just kidding").
ssh-keygen -x in Solaris 9 do not work for public keys. Workaround: Convert files in Solaris 10.
* OpenSSH is sensitive for file permissions. For instance, my home dir had permission 0770 (with dummy group) and sshd did not allow public keys then. (Enabled sshd debug to find out)

Re: Connect to OpenSSH

Problem solved