HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Controlling TELNET remote listener on DECserver 90TL

 
Jeremy Begg
Trusted Contributor

Controlling TELNET remote listener on DECserver 90TL

Hi,

I am trying to set up a DECserver 90TL to provide remote access to my AlphaServer's console port via TCP/IP. I have set up the Internet address of the DECserver and made the following TELNET LISTENER settings:

change telnet listener 2008
change telnet listener 2008 port 8
change telnet listener 2008 ident "Alpha console"
change telnet listener 2008 conn enable
change port 8 telnet server char 8

So far so good: I can telnet to port 2008 on the DECserver and connect through to the Alpha's console.

However, whatever I type is immediately echoed by TELNET, i.e. "local echo". And I can't find a way to disable it. The DECserver 90TL doesn't seem to offer a way to disable it for the TELNET server. (It does for the TELNET client but changing that made no difference, which isn't a surprise.)

Testing various TELNET options with my Mac suggests that the problem might be that the DECserver sets up the telnet session in LINE mode by default, but I can't see a way to change this.

Just to make sure I didn't have something odd in my serial cable or the Alpha's console port, I also created an equivalent LAT service on the DECserver, and that seems to work fine.

Does anyone know if this can be fixed?

Thanks,
Jeremy Begg
8 REPLIES
Jon Pinkley
Honored Contributor

Re: Controlling TELNET remote listener on DECserver 90TL

Jeremy,

It has been a while since I used a DECserver for console access, but I think we used the 2000 ports for printers, and the 3000 ports for consoles. In other words, try telneting to 3008. I don't remember ever setting up the telnet listener, this was a DSV900 not a 90, but I think they are similar.

I could be mis-remembering, but it is easy to try. (Cisco does something similar with ports 40xx (for printers) and 20xx for console (noecho).

Jon
it depends
Hoff
Honored Contributor

Re: Controlling TELNET remote listener on DECserver 90TL

Establish a connection, and then post the output from:

^]
status

I'd probably look at the following, as a start:

^]
mode character
Hein van den Heuvel
Honored Contributor

Re: Controlling TELNET remote listener on DECserver 90TL

Just fwiw,

for my DECserver90M, on a private lan, I just use the default port 23 for the console connection and use network ports 2001 - 2008 for the terminal server ports 1 - 8.
I don't recall any glitches with that usage.

Hein.
Bill Hall
Honored Contributor

Re: Controlling TELNET remote listener on DECserver 90TL

Jeremy,

I don't know which telnet setting is causing the "local echo". I've not seen that problem and we still use many DECservers for remote console access (90m, 700 and 900 models though).

I've attached a Terminal Server MAnager script that is supposed to take a DECserver back to factory defaults. I would look at the current telnet server characteristics for the port you are seeing the echo on and compare to the "factory defaults" set by this script. I believe the factory defaults work. Then make the specific port change.

Bill
Bill Hall
Jeremy Begg
Trusted Contributor

Re: Controlling TELNET remote listener on DECserver 90TL

Hi all,

It looks like the DECserver 90TL doesn't negotiate echo for the telnet server (or doesn't allow it to be configured from whatever it is doing now).

Jon's suggestion unfortunately doesn't work because the DECserver will only use ports 2001-2016.

The TSM commands were interesting but this one does not work on the 90TL:

DEFINE PORT ALL TELNET SERVER ECHO NEGOTIATE

(it complains about "ECHO" not being a recognised keyword).

My solution (for use from my Mac) is to use Kermit's "SET TELNET ECHO REMOTE" command prior to connecting to the DECserver, or (if using the standard Unix TELNET utility), use 'mode char' after establishing the connection.

Regards,
Jeremy Begg
Steve Reece_3
Trusted Contributor

Re: Controlling TELNET remote listener on DECserver 90TL

I'm willing to be contradicted on this, but I think the behaviour that you're seeing is all that the 90TL can do. Though it works fine if you're connecting from a terminal into a host traditionally, it doesn't like reverse telnet and doesn't suppress the echo.
In the time that I was using a 90TL for console access, I never found a method to alter the hardware so that it wouldn't echo what I typed.

Steve
Jon Stanley
Advisor

Re: Controlling TELNET remote listener on DECserver 90TL

Jeremy

I still support the DECservers and can confirm that the 90TL only supported TCP ports in the 2001-2008 range. The DECserver software was modified in the wweng2 and mneng4 (maybe mneng3) to support TCP ports from 0-65535.

When the client (alpha) established a connection to the DECserver (server), the connection negotiated a series of characteristics. I believe you can change the telnet client on the alpha to not negotiate the server-will-echo parameter. I am not positive about this but I believe this can be done.

Thanks, Jon
Vnetek support
Jeremy Begg
Trusted Contributor

Re: Controlling TELNET remote listener on DECserver 90TL

Jon, the DECserver ports in question are connected to the AlphaServers' console ports. It's not impossible I'd telnet from one AlphaServer to the other's console, it's not likely. The behaviour I'm seeing is from my Mac.

Using QVT/Term under Windows I don't see this problem.

I think at this point I'll close this thread because I have a solution for my Mac and the problem doesn't exist in my Windows telnet client.

Thanks,
Jeremy Begg