Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

DBI installation problem

Cfabio
Frequent Advisor

DBI installation problem

Hi

I need for some advices about how I can proceed to solve my problems.
I'm trying to install the perl module DBI-1.611. I have an Alpha Operating System, Version V8.3 and perl v5.8.6 built for VMS_AXP installed.

During the perl Makefile.pl execution I obtain the warning:
Checking if your kit is complete...
Looks good
Warning: prerequisite Test::Simple 0.84 not found. We have 0.47.

So I've tried to install Test-Simple-0.94 from CPAN but during the mmk test execution I obtain an error (in the attachment).

In spite of this I've tried to make test also with DBI-1.611. I've obtain some warning with mmk and after I've got some tests fail with mmk test (in the attachment).

Regards
3 REPLIES
Craig A Berry
Honored Contributor

Re: DBI installation problem

I suggest getting Perl 5.10.1 or later (5.12.1 is current) and just doing:

$ cpanp install "DBI"
Cfabio
Frequent Advisor

Re: DBI installation problem

I have a question about the installation of perl. I work in a production environment and I have a series of modules installed. If I upgrade my perl version to 5.10.1 or later I suppose that I won't have to install the modules again. Is it true?


My modules obtained with ExtUtils::Installed are:

my $inst = ExtUtils::Installed->new();
my @moduli = $inst->modules();

::perl_root::lib::VMS_AXP::5_8_6::.packlist
Digest::HMAC
Digest::MD4
Digest::MD5
Digest::SHA1
Module::CoreList
Net::SSLeay
Perl
radius


Thanks.Regards.
Craig A Berry
Honored Contributor

Re: DBI installation problem

Pure-Perl modules (no XS code) would likely still work across Perl versions, though extracting the correct pieces from an old installation and moving them to a new one would likely be more difficult than simply re-installing them.

XS extensions use the public API of the Perl interpreter, which is not guaranteed to be binary compatible across major versions, e.g. 5.8.x to 5.10.x or 5.10.x to 5.12.x. So you do have to rebuild the extensions that are not included with the core (well over a hundred are included).

The situation on VMS is a bit worse because we do not use GSMATCH to maintain upward compatibility for extensions even where it's theoretically possible to do so (I'm speaking of the authoritative sources, not of the HP-supplied 5.8.6 kit, which may or may not have GSMATCH included).

You do have a couple of alternatives. It looks like DBI wants Test::Simple 0.84 or later, so you're not necessarily bound to use 0.94. Also, since you're not really interested in Test::Simple per se but rather DBI, you could try simply ignoring the Test::Simple test failures and see if it's good enough to make DBI happy.