HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

DECServer 90M: TCD works on LAT, not on TCP/IP

 
SOLVED
Go to solution
Stephen Eickhoff_1
Frequent Advisor

DECServer 90M: TCD works on LAT, not on TCP/IP

We have a 90M that works with a Diebold teller cash dispenser perfectly through LAT, but when we switch to TCP/IP it does not. I see a console message that the telnet connection has been made, but we get either no error message or a connection error message from the TCD. There is a Diebold cash machine (like a local ATM) on another port which works just fine with TCP/IP. The fact that the TCD works fine on LAT tells me that the 90M serial port settings are right. Here's how I set it up:

CHANGE TELNET LISTENER 2002 PORT 2 ENABLE
CHANGE TELNET LISTENER 2002 CONNECTIONS ENABLE
CHANGE PORT 2 TELNET SERVER NEWLINE TO HOST
CHANGE PORT 2 TELNET SERVER NEWLINE TO TERM

On the Alpha VMS 7.3-1 host (we use TTxxx logicals in our application):

$ TELNET /CREATE /NOTIMEOUT 10.15.3.60 2002 110
$ ASSIGN/SYSTEM TNA110: TT110:
$ SET TER/PER/DEV=UNK/SPEED=1200/WID=132 -
/NOTYPE/NOBRO/PAR=EVEN/WRAP TT110:
$ SET TER/PER/NOTTSYNC/HARDCOPY/FORM -
/HANGUP/PRINTER/PASTHRU/NOECHO TT110:

* The 90M serial port settings:
Port 2: (Remote) Server: DSV10

Character Size: 7 Input Speed: 1200
Flow Control: None Output Speed: 1200
Parity: Even Signal Control: Disabled
Stop Bits: 2

Access: Remote Local Switch: None
Backwards Switch: None Name: PORT_2
Break: Disabled Session Limit: 1
Forwards Switch: None Type: Hard
Default Protocol: LAT Default Menu: None
Autolink Timer One:10 Two:10 Dialer Script: None

Preferred Service: None
Authorized Groups: 0
(Current) Groups: 0

Enabled Characteristics:
Autoconnect, Loss Notification, Message Codes, Verification

* SHOW PORT 2 TELNET

Port 2

Profile: Character
Echo: Remote Newline From Term:
Toggle Echo: ^E Newline From Host:
Binary: Disabled Newline To Term:
Xmit Char Size: 8 Newline To Host:
Rcv Char Size: 8 Input Flow Control: Enabled
Signal Req: Enabled Output Flow Control: Enabled
IP: +s +f ^Y Verification: Enabled
SYNCH: +s -f ^X Switch Character: Enabled
AYT: -s -f ^T Quote: None
AO: -s +f ^O Terminal Type: UNKNOWN
EOR: -s -f None
BRK: -s -f None

* SHOW PORT 2 TELNET SERVER
Port 2

Xmit Char Size: 8 Newline From Term:
Rcv Char Size: 8 Newline From Host:
IP: None Newline To Term:
AYT: None Newline To Host:
AO: None EC: None
EOR: None EL: None
NOP: None BRK: Break
PPP Hot Key: None SLIP Hot Key: None
Echo Negotiation: Initiate

Local>

In case you're curious, we must switch to TCP/IP because MPLS does not support LAT.
8 REPLIES
Stephen Eickhoff_1
Frequent Advisor

Re: DECServer 90M: TCD works on LAT, not on TCP/IP

This is a 1M flash 90M.

V2.2 BL29-52
Ian Miller.
Honored Contributor

Re: DECServer 90M: TCD works on LAT, not on TCP/IP

What are the symptoms of it not working?

Could it be affected by differences in timing?
____________________
Purely Personal Opinion
Stephen Eickhoff_1
Frequent Advisor

Re: DECServer 90M: TCD works on LAT, not on TCP/IP

Our application does not receive the appropriate response to its commands. That's the best I can tell you, since it is simply impossible to perform any kind of trace.

I don't know whether timing is affecting anything, but we routinely use Lantronix UDS100, 10, and 1100 device servers with Diebold TCDs and they work fine.
EdgarZamora
Trusted Contributor
Solution

Re: DECServer 90M: TCD works on LAT, not on TCP/IP

Maybe you need to tinker with the telnet listener type. On the terminal server, do:

Local> show telnet listen 2002

check the listener type, if it's set to "RAW TCP" change it to "TELNET". You may need to disable the connection first to be able to change it, then re-enable the connection.
Stephen Eickhoff_1
Frequent Advisor

Re: DECServer 90M: TCD works on LAT, not on TCP/IP

EdgarZamora, a perfect 10 for you. It was actually the opposite situation: changing the listener type from TELNET to RAW resolved the problem. Thank you!
Stephen Eickhoff_1
Frequent Advisor

Re: DECServer 90M: TCD works on LAT, not on TCP/IP

Solution was:

Local> SET TELNET LISTENER 2001 TYPE RAW
EdgarZamora
Trusted Contributor

Re: DECServer 90M: TCD works on LAT, not on TCP/IP

I was gonna say what the heck if it's telnet switch it to raw. lol. glad it's working.
Colin Butcher
Esteemed Contributor

Re: DECServer 90M: TCD works on LAT, not on TCP/IP

Don't forget the equivalent DEFINE as well so that it's saved over a DECserver reboot.

Cheers, Colin (http://www.xdelta.co.uk).
Entia non sunt multiplicanda praeter necessitatem (Occam's razor).