Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

DECW screen saver blanking on dual-head workstation

Colin Butcher
Esteemed Contributor

DECW screen saver blanking on dual-head workstation

Hi,

I have a PWS 500au with 2x ELSA Gloria cards. running dual-head with the Xinerama extension. OpenVMS V8.3 (patched up to end May 20007), DECW-Motif V1.6-ECO02.

When the screen saver cuts in Screen 0 loses the video output (good), but Screen 1 does not (bad). I've tried setting the decw$server_screen_saver_prefer_blanking logical name to "true" and that makes no difference.

The output from "mcr decw$utils:xset q" shows that blanking is enabled.

This has actually been around with previous versions of OpenVMS and Motif (V7.3-2, V8.2), so it's not a new problem. I'd just like to fix it so that my LCD monitors shut down rather than stay active.

Anyone know what needs to be done?

Cheers, Colin (http://www.xdelta.co.uk).
Entia non sunt multiplicanda praeter necessitatem (Occam's razor).
8 REPLIES
Dean McGorrill
Valued Contributor

Re: DECW screen saver blanking on dual-head workstation

Hi Colin,
I think the support for decwindows
went over seas along with decnet. I've kept
in touch with a couple of engineers there
and will see who to contact. Dean
Wim Van den Wyngaert
Honored Contributor

Re: DECW screen saver blanking on dual-head workstation

Colin,

If you select another screen saver, does it show up on both screens ? And if you lock the station ?

As I understand it, the screensaver (even blank) is dtscreen but locking it (and blanking ???) is done by dtsession.

Wim
Wim
Dean McGorrill
Valued Contributor

Re: DECW screen saver blanking on dual-head workstation

Colin,
Sorry for the delay, heres the response
I got from the decwindows project leader..

****************
Hello Dean,
Sorry for the delayed reply. I have tested the multi head configuration
here and I don't see any issue. In my testing the screen blanking was
observed
on both screens.

My configuration is:

OpenVMS 8.3 with Elsa Gloria cards.

Send me your configuration as well.
********************

So theres a mystery since you are at 8.3
and running the same cards. Dean
Colin Butcher
Esteemed Contributor

Re: DECW screen saver blanking on dual-head workstation

Hello Dean,

Thanks for that. My best guess as to why it's different here is that I'm using the Xinerama extension to get a single logical screen rather than 2 separate screens.

Otherwise it's basically the same. I might get around to trying it without Xinerama, but not for a week or two as I'm travelling a lot at the moment.

Cheers, Colin (http://www.xdelta.co.uk).
Entia non sunt multiplicanda praeter necessitatem (Occam's razor).
John Gillings
Honored Contributor

Re: DECW screen saver blanking on dual-head workstation

Colin,

I've used DECwindows dual head for many years, but not yet experimented with Xinerama (might try it though, it sounds like OpenVMS has finally caught up with the rest of the multi head world, at last! ;-)

> I've tried setting the
> decw$server_screen_saver_prefer_blanking
> logical name to "true" and that makes no
> difference.

WAG: If this works the same as most of the other display oriented logical names, try:

$ DEFINE/table=wherever decw$server_screen_saver_prefer_blanking TRUE,TRUE

ie: define a search list with one entry per display.
A crucible of informative mistakes
Dean McGorrill
Valued Contributor

Re: DECW screen saver blanking on dual-head workstation

Hi Colin,
heres a reply after I told him what
you are using.. Dean

***********
Hello Dean,
I have tested with multi head, after your reply tested with Xinerama as
well. Once you set up Xinerama the what you see is single desktop
spread
over multiple monitors. Hence no question of getting the screen saver
on
one monitor and not getting it on the other. Please try with screen
saver
which is displayed randomly at different corners of the monitor.
***********************
Colin Butcher
Esteemed Contributor

Re: DECW screen saver blanking on dual-head workstation

Hello,

Nice guess John - but no difference I'm afraid.

Thanks for the help too Dean.

Testing here shows that having Xinerama enabled or disabled makes no difference.

I consistently have screen 0 go blank (no video output) and screen 1 remain active once the screen saver timeout period has expired.

Applying the recent patches to the OS have made no difference either (as you'd expect really).

I wonder if there's some resource setting somewhere in a Motif style config file?

Any idea what else might help?

Cheers, Colin (http://www.xdelta.co.uk).

Entia non sunt multiplicanda praeter necessitatem (Occam's razor).
Colin Butcher
Esteemed Contributor

Re: DECW screen saver blanking on dual-head workstation

As part of bringing a dual-head DS10 to life I've recently figured this out and got it to work.

- the logical names (decw$server_screen_saver_prefer_blanking, decw$server_screen_saver_timeout) need to be defined /system, not /system/exec.

- decw$private_server_setup.com is called twice, for server init and device init. I gave up and just did everything on both calls :)

- the timeout is in minutes, not seconds.

Cheers, Colin (http://www.xdelta.co.uk).
Entia non sunt multiplicanda praeter necessitatem (Occam's razor).