Online Expert Day - HPE Data Storage - Live Now
April 24/25 - Online Expert Day - HPE Data Storage - Live Now
Read more
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

DECnet installation

SOLVED
Go to solution
geir_2
Super Advisor

DECnet installation

Hi,

I have installed DECnet on a workstation, but I have trouble to access other nodes/hosts. I can use " $ set host 0" command with success, but if I use set host command to a different node, I got following error:

%SYSTEM-F-Unreachable, remote node is not currently reachable"

I assume that I have som trouble with device name ewa-0. Any ideas?

7 REPLIES
Karl Rohwedder
Honored Contributor

Re: DECnet installation

Geir,

did you use DECnet IV or V? Have you run the configuration utility (NETCONFIG or NET$CONFIGURE), any error messages?
Have you tried SET HOST with an address to exclude errors with node registration?

regards Kalle
geir_2
Super Advisor

Re: DECnet installation

Hi,

It's DECnet IV. I have run netconfig-utility, and it's no error message.

If I reboot the system, the system have some trouble to recognize the ewa-0 device.

Geir
geir_2
Super Advisor

Re: DECnet installation

Hi,

More informations. If I run netconfig.com, everything seems to work. But if I use the startnet.com, I got following error message:

%NCP-W-invpva, Invalid parameter value, Physical Ethernet address Line = EWA-0

%NCP-W-UNRCMP, Unrecognized component, Circuit Circuit = EWA-0

$ show device e
ewa-0
ewa-1
ewa-2

Geir


PS:
The workstation is also running TCP/IP without trouble.
geir_2
Super Advisor

Re: DECnet installation

Hi,

If I start DECnet before IP, the problem was solved. Thanks.

Geir
Karl Rohwedder
Honored Contributor
Solution

Re: DECnet installation

DECnet 'writes' its own address to the MAC address of the interface. If it is in use by another protocol (e.g. LAT), this fails.
So you have to start DECnet before any other protocols.

regards Kalle
Martin Vorlaender
Honored Contributor

Re: DECnet installation

Geir,

>>>
The workstation is also running TCP/IP without trouble.
<<<

Please note that DECnet Ph IV must be the first protocol to start (because it tries to mangle the MAC address).

Place the call to STARTNET.COM before any other starts (e.g. TCPIP$STARTUP.COM).

cu,
Martin
Colin Butcher
Esteemed Contributor

Re: DECnet installation

You might find this useful for some of the background: http://h71000.www7.hp.com/openvms/journal/v5/decnet.pdf

Cheers, Colin.
Entia non sunt multiplicanda praeter necessitatem (Occam's razor).