Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

DLT8000 Tapes with Itaniums

 
rbarlow
Occasional Advisor

DLT8000 Tapes with Itaniums

I'm trying to design the next evolution of our OpenVMS environment, specifically upgrading from Alpha to Itanium and would like some advice regarding tapes for offsite backups.

Our current environment consists of DS20e Alphas with SCSI attached DLT8000 tape drive shelves. Since there is a business requirement to retain the offsite tapes for 7 years, the new environment will need to be able to read the old tapes somehow. The new backups will be using LTO4 tapes, most likely in a MSL tape library or something similar.

The easiest solution I can think of is finding a SCSI HBA card for one of the Integrity servers and use the existing tape shelf, but I don't even know if this is an option.

I know my company can't be the only one facing this issue during an Alpha to Itanium upgrade, so what would be the best solution based on the experiences of all of you?

Any advice and/or recommendations would be great appreciated!
8 REPLIES 8
Steven Schweda
Honored Contributor

Re: DLT8000 Tapes with Itaniums

> [...] I don't even know if this is an
> option.

I'd expect the VMS SPD to say which options
are (supported) options. Many things seem to
work, whether supported or not. A quick tour
of SYS$SYSTEM:SYS$CONFIG.DAT should suggest
some hardware possibilities.

I can't recall if I ever attached a tape
drive to my rx2600 system, but I certainly
attached an external SCSI DVD-ROM drive to
it. That's how I installed the operating
system(s), including VMS.

If you have SCSI disks, then installing a
separate SCSI card only for tape would let
you avoid having a tape drive slow down the
SCSI bus for the disks.


Ok. The temptation was too great. Using an
unsupported SCSI card:

[...]
%PKC0, Copyright (c) 1998 LSI Logic PKW V3.2.20 ROM 4.19
%PKC0, SCSI Chip is SYM53C1010/33, Operating mode is SE Ultra SCSI
[...]

(Note: "/33". Only the 66MHz variant appears
in SYS$CONFIG.DAT, but I added the 33MHz
variant to SYS$USER_CONFIG.DAT.)

REX $ show devi /full rex$mk

Magtape REX$MKC400:, device type QUANTUM DLT7000, is online, file-oriented
device, available to cluster, error logging is enabled, controller supports
compaction (compaction disabled), device supports fastskip (per_io).

Error count 0 Operations completed 0
Owner process "" Owner UIC [SYSTEM]
Owner process ID 00000000 Dev Prot S:RWPL,O:RWPL,G:R,W
Reference count 0 Default buffer size 2048
Density default Format Normal-11

Volume status: no-unload on dismount, position lost, odd parity.


I haven't actually tested it, but what could
go wrong? I assume that it'd do at least as
well with a supported card. (The dirt-cheap
33MHz card has one large external connector,
while the dirt-cheap 66MHz card has two tiny
external connectors. I have more cables with
the big connector. Someone with more than
dirt in his budget probably wouldn't bother
with the 33MHz card.)
Jeremy Begg
Trusted Contributor

Re: DLT8000 Tapes with Itaniums

You are right, a SCSI HBA card is the way to go.

We did this a couple of years ago when faced with the same problem. In our case the AlphaServer was a DS20E with two DLT8000 tape drives. The Itanium server is an rx2660. We installed an Ultra320 SCSI HBA in the rx2660 and the DLT drives fired up straight away without any problems.

Regards,
Jeremy Begg
Bob Blunt
Respected Contributor

Re: DLT8000 Tapes with Itaniums

Historically speaking most of the tape drives that were supported on a platform are "sorta grandfathered-in" on future releases. If, however, the drive never appeared as supported in an SPD it is generally considered "officially unsupported." It might work like a champ but if it ever stops working correctly you don't have as much leverage to get it working again.

I just looked at the V8.4 SPD for OpenVMS on Alpha and Integrity. Only a couple DLT drives were listed configured in tape libraries for Alpha and none for Integrity. This doesn't mean that you're dead in the water but the sharks are definitely circling. For the most important functions the DLT family is pretty simple especially if you're talking about the tabletop models. If they're in a library, depending on the configuration, the differences can be small or daunting.

The biggest issue that I would worry about is finding a SCSI interface for your Integrity system(s) that can work with the drives you will need to use. Another alternative would be to move the tape to a SAN/Fiber appliance that "talks" the right version of SCSI for the tape drive. That should improve your flexibilty since you're not dependent on finding a SCSI interface that works in one of the busses on the Integrity or blade. Another potential problem could be security devices that go between the system or fiber appliance and the tape drive for encryption. If you haven't used those in the past for your tapes that cycle to off-site storage now isn't the time to start. Put those on your NEW tape drives and leave the old ones as they are until the seven year itch can be scratched, so to speak.

But to start I'd definitely check any of the OpenVMS V8.x SPDs available online. Check to see when and if the DLT8000 was supported and on what platforms. Support for the drive in a library should imply that the basic tape operation should be working fine since a library, even a very simple one, is a superset of what a standalone tape drive does. I would hope that it goes without saying that if your tape drives have either the Digital, Compaq or HP logo on them should help your cause. Third party drives, even those that seem like someone just glued a different logo on them, are going to make life difficult if the unit doesn't work as expected. Everybody likes to tweak so don't plan that tape drives are like paint because it all comes in cans it'll all be the same color.

There are a LOT of varied configurations you could use so there should be a viable solution that could be assembled. Always test writing tapes in your old environment and then move your test tapes to your new one and try to restore and compare the resulting data for compliance.

bob
Steven Schweda
Honored Contributor

Re: DLT8000 Tapes with Itaniums

> I haven't actually tested it, [...]

A small BACKUP job seemed to work. That's
with VMS V8.4, by the way.

> [...] SCSI attached DLT8000 tape drive
> shelves.

Not a very detailed description of anything.
rbarlow
Occasional Advisor

Re: DLT8000 Tapes with Itaniums

Wow thanks for all the great responses! I'm glad to know that I'm not the only one running into this issue.

Sorry I don't details about the rack mounted tape shelves we have, but I do know they are labeled "HP StorageWorks" and use a 68pin SCSI interface. When I'm in the office tomorrow I'll check them out more thoroughly.

The Integrity servers I've been testing with are rx2660 so hopefully I can find a SCSI HBA that will work. This is probably a really stupid question but the cards I have in the DS20e now wont work in the rx2660 right? I guess that would make this way too easy for me...
abrsvc
Respected Contributor

Re: DLT8000 Tapes with Itaniums

We currently use a DS10L for this purpose. It consumes 1U for the machine itself. This gives use the availability of hte tape drives without worrying about connection to the Itanium directly. We currently backup to the DS10L drives then to tape.

Dan
Ian Miller.
Honored Contributor

Re: DLT8000 Tapes with Itaniums

For a rx2660 there are

PCI 2 channel Ultra320 SCSI - A7173A

PCI-X 2 port 1000Base T/2 port Ultra320 SCSI Multi function Adapter - AB290A

According to
http://h71000.www7.hp.com/openvms/storage/smstape_matrix.html

Integrity servers do not support direct attachment of any tape library. There is the 1X8 Autoloader which is supported. Do check the SPD
____________________
Purely Personal Opinion
Steven Schweda
Honored Contributor

Re: DLT8000 Tapes with Itaniums

> [...] This is probably a really stupid
> question but the cards I have in the DS20e
> now wont work in the rx2660 right? [...]

Sadly, my psychic powers are too weak to tell
me what's in your Alpha systems. Again, I
tend to employ cheap junk rather than
officially supported hardware, but I wouldn't
be amazed if there were some overlap between
devices tolerated on the two systems,
especially if you're not trying to boot from
the thing. I've been trying to find the
newest/fastest cheap junk for my IA64
systems, while my Alpha systems (XP1000) are
stuck with old firmware, so I tend to avoid
trying more modern cards in them.

If the card you have fits into an available
PCI slot, then it should be relatively easy
to run the experiment. Does the thing
appear in SYS$CONFIG.DAT on the IA64 system?
What could go wrong?