cancel
Showing results for 
Search instead for 
Did you mean: 

DNS issue

 
SOLVED
Go to solution
JustinDoss
Advisor

DNS issue

I am trying to do:

$set host servername

I get %SYSTEM-F-NOSUCHNODE, remote node is unknown

but if i do....

$set host servername.fqdn.com

it works.

 

My BIND settings seem to be correct I can ping servername and get responses.  So how do I get the SET HOST command to know it's fully qualified domain name?

 

FYI:  I am a VMS newbie, please explain it to me like I am 4 years old.  Thanks!

8 REPLIES 8
KIP
Advisor

Re: DNS issue

Greetings,   Just Add the /TELNET qualifier and the SET HOST should connect fine with a login prompt  -- Username:

Here's a snippit from Set Host Help:

{ IPhostname }
SET HOST/TELNET { IPaddress }
{ }

NOTE

You can specify the IPhostname or the IPaddress

JustinDoss
Advisor

Re: DNS issue

That works, but for our scripts to run properly we need just set host servername to work.

KIP
Advisor

Re: DNS issue

Presuming you are running a fairly recent Version of the OpenVMS native TCPIP stack...

Please Post the results of the following:

$ TCPIP SH HOSTS

$ TCPIP SH NAME_SERV

Regards

Kip

JustinDoss
Advisor

Re: DNS issue

Due to the nature of my network I can't post exact results.  But I can say the only difference between my working machine and my non working one w/ those two commands is of course it's own hostname and the working one has stuff in Path: when executing the tcpip sh name_serv but the non working one does not.  I have attempted to remedy that, assuming it was the problem but I have had no luck.  The TCPIP> Set name_service/system/path=(xxx) will set it there but if I go to @sys$manager:tcpip$config and look at the the Bind Resolver Configuration it is not there.  So I know I am doing something wrong...

KIP
Advisor

Re: DNS issue

Okay, I get that you shoul not post those exact results -  After-all we run vital and secure systems with OpenVMS.    Look at option (3) below (a snippet from TCPIP help on set host) (different context from os level set host)) and adjust it for your site - be sure to do on all nodes of the cluster and that set host should work fine:

 

1.TCPIP> SET HOST MOA /ADDRESS=11.33.33.8 -
_TCPIP> /ALIAS=("moa","bigbrd","nofly")

Sets the IP address of host MOA to 11.33.33.8 and establishes
moa, bigbrd, and nofly as aliases for host MOA.

2.TCPIP> SET HOST MOA /ALIAS="MOA_2"

Establishes MOA_2 as an alias for host MOA.

3.TCPIP> SET HOST MOA /ADDRESS = 128.33.33.9        <-------- name it as to what you want to do the $ Set Host to...

Establishes a second IP address for host MOA.

4.TCPIP> SET HOST MOA /ADDRESS = 128.33.33.9 /ALIAS="MOA_3"

 

Regards,

Kip

 

KIP
Advisor

Re: DNS issue

Actually just focus on deploying Option 1.   I was thinking of somethingelse for using Option 3.

Regards

Kip

 

Bill Hall
Honored Contributor

Re: DNS issue

Justin,

You only changed the active systemwide name resolution.  TPCIP$CONFIG is probably showing you the permanent name service configuration.  To make your name resolver changes permanent:

$ tcpip set configuration name_serivce /path=(xxx)

That still may not resolve your name resolution problem though.  Most of us associate the usage of "set host" with DECnet, not TCP/IP.  Are you using DECnet over IP by chance?  If you aren't sure, try the following:

$ show network

Product:  TCP/IP        Node:  host.subdomain.domain.com Address(es):  xxx.xxx.xxx.xxx
Product:  DECNET        Node:  HOST               Address(es):  yy.yyyy

if you see DECnet then:

$ mcr ncl show implementation

If the ncl command completes successfully, you are running some version of DECnet phase V (aka DECnet PLus, DECnet/OSI), which can be configured to use TCPIP for routing DECnet.

$ mcr ncl show osi transport template osit$rfc1006*

If it returns something like the following you have DECnet over IP configured:

Node 0 OSI Transport Template osit$rfc1006
at 2016-01-26-17:39:21.344-06:00Iinf

Identifiers

    Name                              = osit$rfc1006


Node 0 OSI Transport Template osit$rfc1006plus
at 2016-01-26-17:39:21.344-06:00Iinf

Identifiers

    Name                              = osit$rfc1006plus

And you should have the PWIP driver configured in TCPIP$CONFIG and running if expecting DECnet over IP to work:

$show system/process=TCPIP$PWIP_ACP

Unfortunately, DECnet Phase V grabs the TCPIP name resolver configuration at boottime and will not recognize your changes to the name resolver until you reboot.

An alternative to rebooting is to change  DECnet Plus's "NAMING SEARCH PATH".  Have a look at the NCL procedure SYS$MANAGER:NET$SEARCHPATH_STARTUP.NCL.  Add another directory service entry to add your subdomain that is not being resolved.

[DIRECTORY SERVICE = DOMAIN, TEMPLATE = "*.subdomain.domain.com"]

Then excute it with $mcr ncl @sys$MANAGER:NET$SEARCHPATH_STARTUP.NCL

 

Bill Hall
JustinDoss
Advisor
Solution

Re: DNS issue

Co-Worker found a fix.  We had to disable BIND do @sys$MANAGER:NET$CONFIGURE BASIC and then set our fully qualified host name for DNS/BIND.  Then re-enable BIND.