Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

DecNet V connectivity with DecNet IV

Highlighted
Dushyant_2
Occasional Contributor

DecNet V connectivity with DecNet IV

I have server running (Open VMS 7-31)Decnet V connected to DecNet IV (Open VMS 6.2-1)workstation. After I reboot workstation with Decnet IV server running Decnet V takes long time to connect workstation first time. So I am thinking it learning path to that workstation.

Same kind of result I am experience when I register any Decnet IV node to server with Decnet V after registration I have to Flush cache, I use below command

> mcr ncl FLUSH SESSION CONTROL NAMING CACHE ENTRY "*"

Once I flush cache first-time server takes long time to connect to workstation, which I just register.

I am new to VMS and DECnet so can I get any information why this is happing when I reboot DecNet IV workstation.

Thanks,
7 REPLIES
Ian Miller.
Honored Contributor

Re: DecNet V connectivity with DecNet IV

What name resolution are you using? If you post the result of doing the following command on your DECnet V system.

mcr ncl show SESSION CONTROL NAMING SEARCH PATH

If Directory Service Domain shows up in the result of the above then the result of
TCPIP SHOW NAME
would also be interesting.

Is the workstation name defined in the local namespace on the server ?
____________________
Purely Personal Opinion
Dushyant_2
Occasional Contributor

Re: DecNet V connectivity with DecNet IV

Search Path has Directory service Domain but workstation name is defined in the local namespace on the server.

What kind of result you are looking for TCPIP show name I did get domain name with domain server name.
Lokesh_2
Esteemed Contributor

Re: DecNet V connectivity with DecNet IV

Hi ,

after flusing the cache on phase V system, run cdi$trace on one window ( $run sys$system:cdi$trace ) and try to connect the phase IV system from another window and see what appears in cdi$trace . This will give you idea from where node will be looked up.

HTH,
Best regards,
Lokesh
What would you do with your life if you knew you could not fail?
Ian Miller.
Honored Contributor

Re: DecNet V connectivity with DecNet IV

your naming search path should have local first then domain so the entry in the local namespace is found first.
____________________
Purely Personal Opinion
Dushyant_2
Occasional Contributor

Re: DecNet V connectivity with DecNet IV

Yes in Naming Search Path Local is first and Domain is last.
Ian Miller.
Honored Contributor

Re: DecNet V connectivity with DecNet IV

what are the results of the CDI$TRACE ?
____________________
Purely Personal Opinion
Veli Körkkö
Trusted Contributor

Re: DecNet V connectivity with DecNet IV

Well, since you apparently have both LOCAL and DOMAIN enabled in your naming setup on the DECnet V node and it just might be that your nodes have SAME name for both DECnet and TCPIP...

Lets say, your phase IV node is named same way on both TCPIP and DECnet, i.e. one would expect

$ telnet TARGET
$ set host TARGET

both work. Now your Phase V node will prefer OSI TRANSPORT so it will actually try DECNET OVER IP to TARGET first.

Try

$ mcr ncl set session control transport precedence (nsp,tp4)

whether this would make any difference.

_veli