Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Disallow logins

 

Disallow logins

It seems as though there is a setting in the back end to disallow logins. It looks like it (the user login) works and then there is a message that "operator logged out automatically

Where would one look to check this for all users?

We are running VMS 7.3.2


Thank You

Bruce
6 REPLIES 6
Richard Whalen
Honored Contributor

Re: Disallow logins

try $ help set logins

Sets the interactive limit (number of interactive users allowed
on the system), or displays the interactive limit and the current
number of interactive users.

Requires OPER (operator) privilege to set the login limit.
Hein van den Heuvel
Honored Contributor

Re: Disallow logins

I suspect an application controled flag/setting.

"operator logged out automatically"

That is not a text originating from OpenVMS itself.
You may want to the search .COM files, scripts and applications sources on the box to find out where exactly it is generated to get to the source of it all.

You may also want to use
$ACCOU/FULL/SINCE=.../BEFORE... around such failure to see what OpenVMS thinks happened.

Please explain what you mean with "back end"
Is this a 3-tier implemenation or a simpe "Username" prompt

Hope this helps a little,
Hein.


Walter Miller_1
Valued Contributor

Re: Disallow logins

Look at the command procedure pointed to by the logical SYS$SYLOGIN. There may be a check in that procedure to see if logins are currently allowed.
Robert Gezelter
Honored Contributor

Re: Disallow logins

Bruce,

As has been observed by others, that is not an obvious OpenVMS message.

There are two ways to search for this, top-down and bottom-up. From the top, the suggestion to check the login path for the affected user(s), and the System wide login file (SYS$MANAGER:SYLOGIN.COM or the SYS$SYLOGIN) and then work from there.

The other way is to search for the message string (and then find how it is being invoked).

There is unfortunately no generic easy way to locate it (although after doing it for a while, you tend to pick up on some hints).

- Bob Gezelter, http://www.rlgsc.com
Peter Zeiszler
Trusted Contributor

Re: Disallow logins

When you first connect try doing it with the /nocomm after the username.
Jan van den Ende
Honored Contributor

Re: Disallow logins

Bruce,


to many variables with to few constraints as it stands!

Can you elabate on "Backend"? On "user logs in"? What is the "EXACT" message?

To start debugging,

WHAT does ACCOUNTNG report on these "sessions"?
If necessary, turn ON accounting for LOGINs.
See
$ HELP SET ACCO
for details.

Supply that info, and we will look what direction to take from there.

Good luch in your bug hunt!

Proost.

Have one on me.

jpe

Don't rust yours pelled jacker to fine doll missed aches.