Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Distributed NetBeans 5.0 FT2 server fails to start in I64

SOLVED
Go to solution
Barney Kwok
Occasional Advisor

Distributed NetBeans 5.0 FT2 server fails to start in I64

I have installed Java 1.5 and NetBeans 5.0 Field Test 2 in I64 running OpenVMS 8.3. When I run IDE$STARTUP.COM from system account, the IDE server process does not start. There is no file created in IDE$LOGS directory. Here are the messages from IDE$STARTUP.COM:

archer_system$ @sys$startup:ide$startup.com
Defining TZ as EST5EDT
JDK_VERSION = "150"
P1 = "FAST"
Checking sys$manager:java$150_setup.com...
Calling Java setup procedure SYS$COMMON:[SYSMGR]JAVA$150_SETUP.COM;1 HOTSPOT JOB
%INSTALL-W-NOPREV, no previous entry exists - new entry created for ARCHER$DKA0:
[SYS0.SYSCOMMON.][IDE$SERVER.SYSLIB]IDE$VMS_AUTH_MOD.EXE;1
Starting the IDE Server process...
%RUN-S-PROC_ID, identification of created process is 000032AE
archer_system$

Process 32AE does not exist in the system. It seems to me that IDE$IDESTARTUP.COM is not able to create the detach process for IDE$SERVER user. IDE$SERVER user is created by the product installation. According to AUTHOIRZE, the default login directory is [USER]. There is no [USER] directory in my machine.

Any idea/suggestion ?

Many thanks in advance.

Barney Kwok
12 REPLIES
labadie_1
Honored Contributor

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

Whats says the accounting ?

$ acc/fu/id=000032AE
or
$ acc/fu/id=000032AE accountng
if you use the logical name accountng fro the accounting.

I suppose that
$ sh acc
shows that accounting is enabled.

If not, enable it
$ set acc/enable/new

and start again ide$idestartup.

Barney Kwok
Occasional Advisor

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

I reset the account file and the accounting info shows ACP file creation error. I have tried to set IDE$SERVER directory to W:RWED but the problem remains.

DETACHED Process Termination
----------------------------
Username: SYSTEM UIC: [IDE$SERVER]
Account: SYSTEM Finish time: 7-JUN-2007 15:53:49.04
Process ID: 00003306 Start time: 7-JUN-2007 15:53:48.99
Owner ID: Elapsed time: 0 00:00:00.05
Terminal name: Processor time: 0 00:00:00.01
Remote node addr: Priority: 4
Remote node name: Privilege <31-00>: 00108808
Remote ID: Privilege <63-32>: 00000000
Remote full name:
Posix UID: -2 Posix GID: -2 (%XFFFFFFFE)
Queue entry: Final status code: 0001C00A
Queue name:
Job name:
Final status text: %RMS-E-CRE, ACP file create failed
Page faults: 99 Direct IO: 5
Page fault reads: 5 Buffered IO: 12
Peak working set: 1840 Volumes mounted: 0
Peak page file: 176944 Images executed: 2
Meg Watson
Advisor

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

Hi Barney,

Usually when the IDE Server will not start it is due to a quota problem. (Usually JTQuota, but there can be other problems as well)

Please look in sys$common:[ide$server.logs] and see if there are any log files there.

Thanks!
Meg Watson
Distributed NetBeans Engineering
Barney Kwok
Occasional Advisor

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

There is no file created in IDE$LOGS (SYS$COMMON:[IDE$SERVER.LOG]) directory.
The error message from ACCOUNT utility indicates ACP file creation error. So I guess the problem is probably not VMS process quota related.
John Gillings
Honored Contributor

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

Barney,

> ACP file creation error

Try using auditing to catch the name of the file it's trying to create.

The big hammer approach is:

$ SET AUDIT/ALARM/ENABLE=CREATE

(but be prepared for lots of output)
A crucible of informative mistakes
Meg Watson
Advisor

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

That's a good idea John.

One question Barney....are you attempting to run the sys$startup:ide$startup command procedure from an account other than the SYSTEM account?

On this end, I will check the PCSI procedure to see how/why the IDESERVER account has a default dir of [USER], that sounds like a bug.

If you change the IDESERVER account default dir does it then start correctly?
Karl Rohwedder
Honored Contributor

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

On Alpha the dev:[dir] is also just a copy from the DEFAULT account. The PCSI description does not specify a directory.

regards Kalle
Meg Watson
Advisor

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

I haven't researched this thoroughly yet, but at first glance it appears that when a default directory is not specified during the PCSI ACCOUNT command, [USER] is chosen. I will change the PCSI description file to specify a valid device and directory.

Interestingly, there is no [USER] directory on my I64 machine either, but the IDE Server starts without incident.
Meg Watson
Advisor
Solution

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

Hi Barney,

I can't recommend adding BYPASS priv to the IDE$SERVER account. The IDE$SERVER process that is started by the IDE$STARTUP command procedure is a daemon that employs a user written system service to check the authorization information provided by the remote user. The user-written system service is installed with the required privs, but the rest of the IDE$SERVER process is purposefully lacking in privs in order to adhere to the vms security policy.

I would suggest you change the privs back to what they were before and instead change the device and directory for the IDE$SERVER account to IDE$ROOT: for the device, and [IDE$SERVER.LOGS] for the directory.

I have changed the PCSI description file to create the IDE$SERVER account with the above default directory.

Thanks for reporting this problem.

Best Regards,
Meg
Barney Kwok
Occasional Advisor

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

Hi Meg,

I followed your instruction to change directory [USER] to [IDE$SERVER] and removed BYPASS privilege. However the problem remains.
I have to do the following to make the IDE server running without BYPASS privilege.
1. Add "/DEVICE=SYS$COMMON" to IDE$SERVER user because [IDE$SERVER] directory is created under SYS$COMMON and the default device is SYS$DISK.
2. Assign disk quota to IDE$SERVER because the drive has disk quota enabled.

I hope that your product install procedure will include those setup.

Best Regards,
Barney
Meg Watson
Advisor

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

Hi Barney,

In my product installation, I am setting the device to IDE$ROOT: (rather than SYS$COMMON) because the IDE Server could be installed somewhere other than SYS$COMMON. IDE$ROOT is a logical device which is created during IDE$startup.com before the IDE$SERVER process is created. So it is valid when the IDE$SERVER process is created.

Ah, disk quotas, that is something I had not thought of adding. I will do some testing with disk quotas enabled and see if I can add that during the installation.

I'm curious, how much disk quota did you allow?

Best Regards,
Meg

P.S. You can also continue this conversation with me in email at netbeans@hp.com.

Barney Kwok
Occasional Advisor

Re: Distributed NetBeans 5.0 FT2 server fails to start in I64

Use SYSMAN utility to assign disk quota to IDE$SERVER if IDE$ROOT drive has quota enabled.