Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Duplex printing issue

 
Willem Grooters
Honored Contributor

Duplex printing issue

Node A: Charon VAX running OpenVMS 7.2, TCPIP 5.0 ECO5
Node B: VAX 3100-95, running OpenVMS 7.1, TCPIP 5.0A.
Kyocera printer (KC1650), said to emulate HP PCL6. The printer is served from a Windows box (uing the LPD symbiont). LPD-confuguration is equal on both systems. On NodeB this prinetr can also be used using the TELNET symbiont.

We would like to use the duplex facility of this printer.
On both nodes, I added a form to SYSDEVCTL that holds the code for duplex printing, and defined a form to be used. On NodeA, these forms already existsed but in another stock than default (stock=HP4_HL). On NodeB, I added them in stock DEFAULT.

It doesn't work as intended, but differently on these nodes.

On NodeA, I explicitly have to load the form, and mention it in the PRINT statement, to prevent a "Stock mismatch" error. Once set, it does work fine, both portrait and landscape. But once set to duplex, I cannot make 1-sided prints, unless I do so from a Windows box...

On NodeB, it doen't work at all. I always get a one-sided print, though when DUPLEX is specified, it looks like it's printing on the back side. No matter what I doe here, it remains in this state unless the queue has explicitly been set to another form, or when set so by some other system.
It doesn't make a difference in using the LPD or TELNET symbionts: same result.

I created a separate queue for this type of prints but that doesn't help.

SHOW QUEUE shows the last used form.

The queues have SEPARATE=(RESET=HP4_RESET)) because otherwise, the last (or only) page of a print will not be ejected, because known shortcomings in the PCL6-emulation.

Suggestions to solve the problem are welcome.
Willem Grooters
OpenVMS Developer & System Manager