Operating System - OpenVMS
Showing results for 
Search instead for 
Did you mean: 

Re: Ericom Powerterm 8.7 SSH terminal emulator

Frequent Advisor

Ericom Powerterm 8.7 SSH terminal emulator

I am using Powerterm 8.7 SSH terminal emulator to connect to an OpenVMS 8.3 system running HP TCPIP V5.6 - ECO 5. The normal behaviour of this software when using telnet is that after one logs out, the terminal emulator disappears.

After switching from telnet to SSH, I have found that logging out will kill my OpenVMS process and the tcp port device on the OpenVMS machine but, it will not cause the Ericom Powertern session to end. In SSH, I am forced to take an extra step when I log out to disconnect the session in the menu. I log out and then if I want the Ericom Powertern to end I must select "Communication" and "Disconnect" to make the emulator disappear.

Has anybody else experienced this behaviour with Powerterm? Or might someone know how to make the Powerterm terminal emulator session disappear when the SSH session is done?

Clark Powell
Honored Contributor

Re: Ericom Powerterm 8.7 SSH terminal emulator

Consider contacting Ericom directly; the Microsoft Windows product vendor that appears to be the central party here.

Tried using the PuTTY terminal emulator?

Tried a newer version of what looks to be 2001-vintage Ericom PowerTerm software? (They have trial downloads.)

Tried an ssh connection into a server other than OpenVMS, try replicating this behavior with another server box?
Respected Contributor

Re: Ericom Powerterm 8.7 SSH terminal emulator

Clark, I have to agree with Hoff. Try your connection to another server running either another O/S or different IP stack. This doesn't sound like a VMS- or TCPIP Services-specific type issue but trying a different host should prove that. Did a previous version of Powerterm SSH work any differently? SSH, if I understand correctly, is NOT TELNET and works differently so a direct comparison between the two flavors of Powerterm may not be pertinent.

And, as Hoff recommended, check with the vendor or in the documentation to see if this behavior is expected.

Occasional Advisor

Re: Ericom Powerterm 8.7 SSH terminal emulator

Clark, Did you try Clicking Terminal, Setup, Preferences Tab, place a check in "Auto Exit Powerterm" on Sessions Exit.
Save permanent if you have admin rights on the Windows PC, by clicking File, Save Terminal Setup. Works for version 7.1 and up I believe, and should work for SSH.
Spend more time working toward your dreams then preserving memories.
Frequent Advisor

Re: Ericom Powerterm 8.7 SSH terminal emulator

Ok, looks like I have to work it out with Ericom. I was hoping, since HP used to market Powerterm with Pathworks that someone on the forum had encountered the problem and knew the fix. It's definately a Powerterm problem as putty works fine. I did try "autoexit on session exit" but it works only for telnet and not ssh.

Occasional Advisor

Re: Ericom Powerterm 8.7 SSH terminal emulator

Hi Clark,

I'm with Ericom. Thanks for using our product.

Please note that the version of PowerTerm which was bundled with PATHWORKS is an old version. I suggest that you try PowerTerm 9.2 from Ericom's download site -
and select PowerTerm Lite from the left hand dropdown box.