Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Error : Xlib: connection to "_WSA8:" refused by server

berlioz
Regular Advisor

Error : Xlib: connection to "_WSA8:" refused by server

hello,
i'm actually installing a new apha ds25 server to replace an alpha server 1000

On my new machine, when I launch, under “DECwindows motif” (old desktop), my Dataviews application I have the following error message :

Xlib: connection to "_WSA8:" refused by server
Xlib: client is not authorized to connect to server
DDopen/set: can't open dispaly _WSA8: (dataviews message)

I need help to solve or workaround this problem :
is there a DECwindows modif security problem ?
a TCPIP SSH problem ?
something else ?

thanks in advance for all
Philippe

current versions:
alpha ds25 server
Openvms 7.3-2
tcpip 5.4-15
dwmotif 1.3-1 (old desktop)
11 REPLIES
labadie_1
Honored Contributor

Re: Error : Xlib: connection to "_WSA8:" refused by server

Usually

mc decw$examples:ico has the good idea to be more verbose and so helps solving.

What gives
$ sea sys$manager:decw$startserver.com transports

What transport do you use ? (Tcpip, Decnet, Local, Lat)

berlioz
Regular Advisor

Re: Error : Xlib: connection to "_WSA8:" refused by server

labadie :
> i will try your sample today

> i let the default configuration for decwindows :
(no modification in decw$startserver.com)
sea sys$manager:decw$startserver.com transports
$ decw$server_transports == "decnet,local''tcpip'"
$ decw$define_server_term decw$server_transports 'decw$server_transports'

(no modification in sys$manager:decw$private_server_setup.com also for decw$server_transports)


Here's part of script used to launch my application (invoked by run/detach) :
$ set display/create
$ Set def $disk_dv:[include]
$ rrr == "$$diskloc:[valerie.po.supervision.processus]supervision.exe"
$
$ rrr VUE_ACCUEIL.VUE -M

Edwin Gersbach_2
Valued Contributor

Re: Error : Xlib: connection to "_WSA8:" refused by server

Xlib: client is not authorized to connect to server

Is not too bad a message.

If you are using CDE (the default desktop) open the style manager (the icon to the right of the printer icon) and there open the security window. Click users... and see whats in there. A fully open desktop would contain "* * *" which means access for everyone. Notice that for transport TCPIP the user has to be an asterisk because TCPIP does not supply this information.

Edwin
berlioz
Regular Advisor

Re: Error : Xlib: connection to "_WSA8:" refused by server

edwin

as i said in my first message, i don't used CDE but 'traditional' DECwindows desktop.
Joseph Huber_1
Honored Contributor

Re: Error : Xlib: connection to "_WSA8:" refused by server

In the old DECW desktop, there is a security entry in one of the pulldown menus, I think in SESSION MGR.

If the display is to the server where the session is running , then access is automatically enabled.
You did not indicate the display setting: is it to the local display, or to a remote server/Xterminal ?
http://www.mpp.mpg.de/~huber

Re: Error : Xlib: connection to "_WSA8:" refused by server

Hello Philippe
how about you security settings in sys$manager:DECW$SMB_SECURITY.DAT?
Is there an entry like:

sm.host_list: tcpip client-node *

more details about X Server security options
http://h71000.www7.hp.com/DOC/82final/6300/6300pro.html
Chap. 3.3

cu
Thomas

berlioz
Regular Advisor

Re: Error : Xlib: connection to "_WSA8:" refused by server

labadie :
> i've tried mc decw$examples:ico and it work's fine (ico, clock) without error messages.

joseph :
> it's a local display (server screen)

for the connected user, in DECwindows menu, under "option", i don't have "Decterm", "Menus" and "Security" options (only "screen background", "windows colors" and "save session manager").

I've also looking for an error in sys$manager:decw$server_0_error.log, and i have the following lines :

19-JUN-2006 15:08:14.5 Calling the dispatcher...
19-JUN-2006 15:08:22.5 Invalid access from transport: DECNET
node: PC5CA1
user: BERTIN
19-JUN-2006 15:08:22.5 Local client 6 rejected.
19-JUN-2006 15:08:22.5 Family 1, Transport DECNET, Node PC5CA1, User BERTIN
19-JUN-2006 15:08:22.5 AUDIT: client 6 rejected from PC5CA1
19-JUN-2006 15:08:22.5 Connection eac690 is closed by Txport (status = 20e4)

It seems to be a security problem, but i'm still looking for the right configuration file...

I need help (lol)
labadie_1
Honored Contributor

Re: Error : Xlib: connection to "_WSA8:" refused by server

exit %X20E4
%SYSTEM-F-LINKABORT, network partner aborted logical link

But you were guessing it !
berlioz
Regular Advisor

Re: Error : Xlib: connection to "_WSA8:" refused by server

Is there a way to allow/deny acces to "security", "menu".. options in decwindows option menu for users ?
Joseph Huber_1
Honored Contributor

Re: Error : Xlib: connection to "_WSA8:" refused by server

If the error log entry is for the application/user in question, then this is in opposition to the application running on the local session/screen: a local application would not use the DECNET transport !
So check with SHOW DISPLAY if it specifies DECNET transport: in this case a security entry for this user/node must be present.

(I have no DECWindows available to check, but in an unmodified setup, there should be one. If not, there is something like a customize menu entry, which allows to add menu entries to the session manager. It's too many years I last saw a DECWindows (old style) session :-)
http://www.mpp.mpg.de/~huber
Dale A. Marcy
Trusted Contributor

Re: Error : Xlib: connection to "_WSA8:" refused by server

In one of your responses, you indicate:

Here's part of script used to launch my application (invoked by run/detach) :
$ set display/create


By default, set display/create uses the DECnet transport. If you want to use TCPIP, you must add /transport=TCPIP to the command.
To check security settings, click on Options in your Session Manager box and then select Security. To use DECnet, you should have an entry that starts with DECnet and then lists the remote node and an * or specific user. For TCPIP, it would start with tcpip followed by the IP address and an *.

Hope this helps.