Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Error when running T4$SYS:T4$CONFIG

Paul Janssen
Advisor

Error when running T4$SYS:T4$CONFIG

When I run this, I get:

$ @t4$sys:t4$config

Copyright 2000-2005 Hewlett-Packard Development Company, L.P.

T4 Version 4.0

Executing T4$CONFIG.COM on node V3400 - Date/Time is now 19-MAR-2007 17:48:59.88
T4$SYS defined as SYS$SYSDEVICE:[VMS$COMMON.T4$SYS]
T4$DATA defined as DKF0:[000000.T4$DATA]

T4$CONFIG-F-Insufficient sub-process limit for user SYSTEM - cannot contin
ue ...
Please ensure that PRCLM for user SYSTEM is at least 20.
$

However the settings are:

$ mc authorize
UAF> sho system

Username: SYSTEM Owner: SYSTEM MANAGER
Account: SYSTEM UIC: [1,4] ([SYSTEM])
CLI: DCL Tables: DCLTABLES
Default: SYS$SYSROOT:[SYSMGR]
LGICMD: LOGIN.COM
Flags:
Primary days: Mon Tue Wed Thu Fri
Secondary days: Sat Sun
No access restrictions
Expiration: (none) Pwdminimum: 8 Login Fails: 0
Pwdlifetime: (none) Pwdchange: 21-JUL-2006 12:51
Last Login: 19-MAR-2007 16:03 (interactive), 19-MAR-2007 17:18 (non-interactive)
Maxjobs: 0 Fillm: 128 Bytlm: 256000
Maxacctjobs: 0 Shrfillm: 0 Pbytlm: 0
Maxdetach: 0 BIOlm: 150 JTquota: 4096
Prclm: 30 DIOlm: 150 WSdef: 4096
Prio: 4 ASTlm: 300 WSquo: 8192
Queprio: 0 TQElm: 100 WSextent: 16384
CPU: (none) Enqlm: 4000 Pgflquo: 700000
Authorized Privileges:
ACNT ALLSPOOL ALTPRI AUDIT BUGCHK BYPASS
CMEXEC CMKRNL DIAGNOSE DOWNGRADE EXQUOTA GROUP
GRPNAM GRPPRV IMPERSONATE IMPORT LOG_IO MOUNT
NETMBX OPER PFNMAP PHY_IO PRMCEB PRMGBL
PRMMBX PSWAPM READALL SECURITY SETPRV SHARE
SHMEM SYSGBL SYSLCK SYSNAM SYSPRV TMPMBX
UPGRADE VOLPRO WORLD
Default Privileges:
ACNT ALLSPOOL ALTPRI AUDIT BUGCHK BYPASS
CMEXEC CMKRNL DIAGNOSE DOWNGRADE EXQUOTA GROUP
GRPNAM GRPPRV IMPERSONATE IMPORT LOG_IO MOUNT
NETMBX OPER PFNMAP PHY_IO PRMCEB PRMGBL
PRMMBX PSWAPM READALL SECURITY SETPRV SHARE
SHMEM SYSGBL SYSLCK SYSNAM SYSPRV TMPMBX
UPGRADE VOLPRO WORLD

UAF> sho t4_user

Username: T4_USER Owner:
Account: UIC: [200,201] ([DESIGN,DEFAULT])
CLI: DCL Tables: DCLTABLES
Default: [USER]
LGICMD:
Flags:
Primary days: Mon Tue Wed Thu Fri
Secondary days: Sat Sun
No access restrictions
Expiration: (none) Pwdminimum: 6 Login Fails: 0
Pwdlifetime: (none) Pwdchange: (pre-expired)
Last Login: (none) (interactive), (none) (non-interactive)
Maxjobs: 0 Fillm: 128 Bytlm: 128000
Maxacctjobs: 0 Shrfillm: 0 Pbytlm: 0
Maxdetach: 0 BIOlm: 150 JTquota: 4096
Prclm: 20 DIOlm: 150 WSdef: 4096
Prio: 4 ASTlm: 300 WSquo: 8192
Queprio: 4 TQElm: 100 WSextent: 16384
CPU: (none) Enqlm: 4000 Pgflquo: 500000
Authorized Privileges:
ALTPRI NETMBX TMPMBX
Default Privileges:
ALTPRI NETMBX TMPMBX
UAF>

Does anyone knows the magic answer to this?

Thx
6 REPLIES
labadie_1
Honored Contributor

Re: Error when running T4$SYS:T4$CONFIG

What is the PQL for prclm ?

$ mc sysgen sh pql_dprclm
$ mc sysgen sh pql_mprclm
EdgarZamora
Trusted Contributor

Re: Error when running T4$SYS:T4$CONFIG


You are interactively invoking the T4$CONFIG from an account that was logged in before you changed the PRCLM. Log out and log back in then execute the procedure.
John Gillings
Honored Contributor

Re: Error when running T4$SYS:T4$CONFIG

Paul,

As Edgar suggests, I suspect you have a process that was logged in before the UAF change. To check the actual PRCLM of your process use:

$ WRITE SYS$OUTPUT F$GETJPI("","PRCLM")

Logout and log back in again to get the current UAF value.
A crucible of informative mistakes
Paul Janssen
Advisor

Re: Error when running T4$SYS:T4$CONFIG

Here are the settings:

$ mc sysgen sh pql_dprclm
Parameter Name Current Default Min. Max. Unit Dynamic
-------------- ------- ------- ------- ------- ---- -------
PQL_DPRCLM 32 32 0 -1 Processes D
$ mc sysgen sh pql_mprclm
Parameter Name Current Default Min. Max. Unit Dynamic
-------------- ------- ------- ------- ------- ---- -------
PQL_MPRCLM 10 0 0 -1 Processes D
$ WRITE SYS$OUTPUT F$GETJPI("","PRCLM")
30

I logged out and logged in again and it worked fine.
Should I do anything with the PQL parameters?
EdgarZamora
Trusted Contributor

Re: Error when running T4$SYS:T4$CONFIG

No. You don't need to change your PQL params for T4 to work.
Paul Janssen
Advisor

Re: Error when running T4$SYS:T4$CONFIG

Excellent help