Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

F$GETDVI() Allocated Is Node Specific

Robert Atkinson
Respected Contributor

F$GETDVI() Allocated Is Node Specific

The F$GETDVI() 'ALL' argument does not work if you're on a different node (VMS 8.3-1H1). Short of hacking a SH DEV output, anyone else found a decent workaround for this limitation?

 

I can't serve TMSCP by the way.

 

Rob.

 

3 REPLIES
Steven Schweda
Honored Contributor

Re: F$GETDVI() Allocated Is Node Specific

 
Hoff
Honored Contributor

Re: F$GETDVI() Allocated Is Node Specific

That's been the requirement since eons.

 

https://groups.google.com/d/topic/comp.os.vms/Q4qFIDXUt4w/discussion

 

Alternatives: use some task-to-task DCL to poke around in the cluster.

 

Or use the ALLOCATE and see if it works, or if it errors. 

 

Here's some old code

 

https://groups.google.com/group/comp.os.vms/msg/69cc46d2648fa4f2

 

There was a bug here an eon or two ago (since fixed), where you could get dangling allocations.

 

:I can't serve TMSCP by the way.

 

You can't (errors, problems getting the commands to work) or you can't (administrative or policy restrictions)? 

abrsvc
Respected Contributor

Re: F$GETDVI() Allocated Is Node Specific

Realize that TMSCP supports tape drives.  Without more specifics about the issue, we can't respond with anything useful. 

 

Can you please elaborate on the configuration and exactly what you are trying to accomplish.  Priovide as much detail as you can.  This will allow us to understand the isue and perhaps reproduce the conditions so further investigation will be possible.

 

Thanks,

Dan