Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

FC2354 Installation on ES40 running OpenVMS V7-2.1

 
Nidal Ali
Advisor

FC2354 Installation on ES40 running OpenVMS V7-2.1

Dear Sirs
I installed the FC2354 card on ES40 machine running VMS 7-2.1 but the wwidmgr -sh adap command does not display the FC2354 port WWN.

kindly advice where is the problem and how can I fix it. so I can see the WWN on the conole.

regards

nidal ali
Nidal Qashou
13 REPLIES 13
Jan van den Ende
Honored Contributor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

Ali,

Support for SAN was introduced (very limited) with a special patch in VMS 7.2-2; and extended only in 7.3-2 and beyond (every next step with new patches).

So, you REALLY can only get it to work by upgrading VMS. At least to 7.3-2 fully patched, but then, if upgrading anyway, it is probably best to get current at 8.4. (or, if you are wary of too-new versions, 8.3-patched).

Sorry if this is not what you want to hear, but V7.2 really dates from the previous century...

hth

Proost.

Have one on me.

jpe
Don't rust yours pelled jacker to fine doll missed aches.
Nidal Ali
Advisor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

Thx for your concern and help, but is there any way to solve it either by upgrading FM only without upgrading the VMS OS as this will be reflected to the current applications running on ES40.

regards

Nidal Ali
Nidal Qashou
Andy Bustamante
Honored Contributor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

I'll disagree slightly with Jan. OpenVMS 7.2-1 was capable of addressing fibre channel storage with patches applied the operating system. I installed more than fibre channel array on 7.2-1 Alphaservers. As 7.2-1 was dropped from support, later documentation reflected supported operating systems.

First step, is the FC2354 card a supported version? Check the actual part number, there were Windows Server 2xxx versions and OpenVMS Unix version, same "part number" with a suffix for different o/s if I recall. If you have a Windows/Intel version in your Alpha it may or may not be recognized, may or may not see your storage, and may or may not corrupt your data.

Apply the latest firmware to your ES-40 and hba. You may need to power down the system after this step.

Once you can see the card from console with wwidmgr, you'll need to ensure appropriate patches are installed in your VMS boot disk. Install the latest update, and fibre scsi patches. I recall multiple patches being required but the final version of these patches should do.

You'll need a support contract to access patches, even unsupported versions of OpenVMS.

You are running an operating system that's long out of support. The upgrade to OpenVMS 7.3-2 is easy install and brings additional performance gains.
If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
Volker Halle
Honored Contributor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

Nidal Ali,

may I suggest, that you check the ES40 systems and options page for FC adapters:

http://h18002.www1.hp.com/alphaserver/options/ases40/ases40_15_72_options_sorted.html#OptListHead

This page lists all SUPPORTED FC adapters for the ES40 and it also shows the prerequisites like OpenVMS versions.

Volker.
Nidal Ali
Advisor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

thx fo your concern & support I check the FC2354 card HP slaes P/N its 261329-B21 where the ES40 data sheet state that it's supporting OpenVMS OS. I'll update ES40 FM to V7.2 and see if I can see the WWN using wwidmgr command from console.

regards

Nidal Ali
Nidal Qashou
Volker Halle
Honored Contributor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

Nidal Ali,

the DS-KGPSA-DA (261329-B21) requires V7.2-2 and V722_FIBRE_SCSI-V0100 (according to the systems & options list), so don't expect this adapter to work with OpenVMS V7.2-1 !

If you can see the SAN disks from WWIDMGR and the Alpha SRM console, it's just half of the 'story'.

Volker.
Nidal Ali
Advisor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

I try to find a link to download the TIMA Kit: DEC-AXPVMS-V722_FIBRE_SCSI-V0100--4.PCSI but I could not find that link, kindly can you show me from where I can download ou or if y.

regards

Nidal Ali
Nidal Qashou
Andy Bustamante
Honored Contributor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

The link above is for OpenVMS 7.2-2. Unless you ugprade the o/s it won't suit your system. This link http://h18002.www1.hp.com/alphaserver/options/ases40/ases40_ds-kgpsa-ca.html, followed from Volker's link shows the DS-KGPSA-CA (168794-B21)would be the supported HBA under 7.2-1 in your system and operating system version.

This is the site to download patches but you must have a support contract for access. http://www11.itrc.hp.com/service/patch/search.do?BC=main|&pageOsid=openvms will get you started.

Andy
If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
Nidal Ali
Advisor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

I upgrade the ES40 FM to V7.2 but still the wwidmgr -sh adap command from console not showing WWN # kindly advice is there any way to define FC2354 and solve this problem with the current VMS V7.2-1 without upgrading the VMS OS as the OS upgrade will effect the current running application on ES40.

regards
Nidal Qashou
Volker Halle
Honored Contributor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

Nidal,

please believe the ES40 system options WEB page. The FC2354 card (DS-KGPSA-DA or 261329-B21) is NOT supported with V7.2-1.

The most recent Firmware for the ES40 is V7.3, it does support the FC2354 adapter (since FW V7.2). So if >>> WWDIMGR -SHOW ADAPTER does not show the KGPSA in your ES40, there is something wrong with your hardware.

Volker.
Emad Omar
Regular Advisor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

Dear Nidal,

Firstly FC2354 Card is 261329-B21 (KGPSA-DA) which it is supported for ES40.
Secondly, by using command "P00>>>sho config", you can find the WWN for the pga0, pgb0,...etc
If the output of the above command did not provide the FC adapter with WWN, then these adapters are not functioning well.
To diagnose this issue, you can upgrade the Firmware of the SRM to v7.3

Find attached the wwidmgr manual for configuring the FC adapters.

Regards,
Bob Blunt
Respected Contributor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

Nidal, there isn't ANY way to *make* V7.2-1 support that adapter. No patches are available to add it's support to the O/S. Your only solution would be to upgrade to 7.2-2 or higher. The upgrade from V7.2-1 to V7.2-2 should not brake any applications, this is NOT a major release. You should test before making the upgrade permanent to be sure but normally a "dash" release doesn't break applications.

Upgrade firwmare to V7.3 in addition to upgrading OpenVMS to V7.2-2 with that required patch for full and proper support. Please test your application on the newer release plus the patch before committing.

bob
Emad Omar
Regular Advisor

Re: FC2354 Installation on ES40 running OpenVMS V7-2.1

Hi Bob,

As I understood from Nidal that his problem summarized on the visibility of the FC adapters with their WWN on the >>>
When these adapters are not appearing on the SRM, then even if he upgrades the OS, also these devices will not be appeared. So I think this is an HW issue and it is something related to the FW of these adapters.

Regards,