HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

FTP Fails to Connect (Alpha-4100)

 
SOLVED
Go to solution

FTP Fails to Connect (Alpha-4100)

I have been successfully FTP from and to
an Alpha 4100/OpenVMS6.2-1H3/UCX ver. 4.2-ECO2. Experiencing a recent problem of connecting to Alpha-4100. Seems it can copy/ftp out to other systems successfully.

UCX:
When doing a sho service ftp/full
Service: FTP
State: Enabled
Protocol: TCP
Inactivity: 6
Active: 1

Problem from perspective of each device (Windows client or other VAX/VMS
server). Error messages below:

1. Windows: ftp: connect :unknown error

2. Alpha-4100: The error below for Alpha-4100 is the server trying to be connected to. (Note: This has been successful in past, since I connect from my windows client pc to move files off of Alpha.)

UCX$FTPD.log output
%RMS-E-RNF, record not found
%UCX-E-FTP_GETHST, Error in getting host name
%UCX-I-FTP_USER, Username : SYSTEM
%UCX-I-FTP_SESDCN, FTPD: Session disconnection from at 23-JAN-2005 18:15:14.42

3. VAX-VMS Server:
%TCPWARE_FTP-E-OPENCTRL, failed to open control connection

-SYSTEM-F-TIMEOUT, device timeout

Any suggestions?
Can I just restart FTP process?
I really want to understand what seems to have "all of a sudden failed".
14 REPLIES
Ian Miller.
Honored Contributor

Re: FTP Fails to Connect (Alpha-4100)

do other services such as telnet work?

There may be a log file in SYS$SYSDEVICE:[UCX$FTP]

ftp can be stopped/started seperately
SYS$STARTUP:UCX$FTPD_STARTUP.COM
SYS$STARTUP:UCX$FTPD_SHUTDOWN.COM

____________________
Purely Personal Opinion
Wim Van den Wyngaert
Honored Contributor

Re: FTP Fails to Connect (Alpha-4100)

Re: FTP Fails to Connect (Alpha-4100)

Ian: telnet: yes works and works well.
logfile: I did check, no useful data.
startup: Thanks. I was trying to
not simply restart Alpha or process
until had understanding.
Wim: Thanks. I did see and review that
specific thread. Being that Alpha was
working, I did not believe that it
applied 100%, but will keep in mind.
Volker Halle
Honored Contributor

Re: FTP Fails to Connect (Alpha-4100)

Vince,

it clearly looks like the FTP client IP address could not be translated to a host name on the Alpha-4100.

Are there any 'older' UCX$FTPD.LOG file, which show a working FTP session ? Then you could at least find out, what the file looked like if it was still working.

What happens if you do a UCX SHOW HOST ip-address-of-FTP-client on the Alpha-4100 ?
Can you connect to itself with FTP from the Alpha-4100 with FTP alpha-4100 or FTP localhost ?

Volker.

Re: FTP Fails to Connect (Alpha-4100)

I have observed the following by doing a
sho proc/id=ftp process/full that there were 4 devices allocated to the process.
There state in UCX is:

BG1: State:Priv (appears to be ok)-Port 21
BG2: State:CANTSENDMORE CANTRECVMORE PRIV
Port 0
BG3: State:Priv RCV Buff:SEL - Port 5000
BG4: %UCX-W-NODEVSOCK, Device_socket not found

Not sure of significance of above.

Re: FTP Fails to Connect (Alpha-4100)

Volker,

Answers to your questions:
1. No older files that show a working FTP
session. (Darn)

2. If I do a UCX>sho host ip, the following
occurs:

sho host ip-client
finds in local database - host address &
host name

sho host ip-vax-vms (other L2 server)
%UCX-W-NORECORD, Information not found
-RMS-E-RNF, record not found

3. I tried three different connect schemes
per your question and all three had
same result.

FTP nodename
FTP localhost
FTP ip-address

%FTP-E-NETERR, I/O error on network device
-SYSTEM-F-TIMEOUT, device timeout

So as a result of your input (Volker, Ian,
and Wim), do I add vax-vms server ip-address and simply restart process?

It seems it does not answer why it stopped working.
Volker Halle
Honored Contributor

Re: FTP Fails to Connect (Alpha-4100)

Vince,

the results of your 3rd test clearly show, that there is a local problem with your FTP server on your Alpha-4100. You first need to solve that problem, before trying FTP accesses from other nodes.

I would suggest to first shutdown and restart the FTP service as suggested by Ian. Then test with the local FTP access. If it works, then test FTP access from the other nodes.

If local access fails, check the UCX$FTPD.LOG file. As the file is kept open, after the UCX$FTPD process has started, you need to read the .LOG file with CONVERT/SHARE sys$sysdevice:ucx$ftpd.log sys$output

Volker.
Antoniov.
Honored Contributor

Re: FTP Fails to Connect (Alpha-4100)

Vince,
with vms v6.2 and ucx v4.2 you can do ftp only from/to host recorded on vms database even you use ip adddress.
I guess, UCX SH HOST doesn't show windows client host.

Antonio Vigliotti
Antonio Maria Vigliotti

Re: FTP Fails to Connect (Alpha-4100)

Volker & Ian,
I have successfully shutdown FTP using the
command file indicated by Ian.

I in turn then used the command also indicated by Ian and it started up. However, by simply executing the startup
command from a DCL window, it is not started
up as a detached process. It appears in a
'normal' startup, that is the case. So in
this case the window, on my pc, is tied to
the FTP process currently.

Nonetheless, FTP is working and I need to
execute a few FTPs and monitor the files.
Thanks for everyone's input. This is an
absolute great resource!

Thanks again,
Vince
Ian Miller.
Honored Contributor

Re: FTP Fails to Connect (Alpha-4100)

It looks like for ucx v4.2 the ftp service is defined so that when a incoming connection to the ftp service is recived then a ftp server process is started by creating a detached process running UCX$FTPD_STARTUP.COM

I guess it should be started by the aux server normally but you are currently running it in a interactive process.
____________________
Purely Personal Opinion
Volker Halle
Honored Contributor

Re: FTP Fails to Connect (Alpha-4100)

Vince,

it looks like there is no 'startup' procedure for FTP. The FTP service will automatically execute SYS$SYSDEVICE:[UCX$FTP]UCX$FTPD_STARTUP.COM (and create the UCX$FTPD detached process), when a connect to port 21 comes in.

You're now running FTP in a non-standard way, which may also cause unexpected problems. This detached process will probably go away after 10 minutes (timeout).

Volker.

Re: FTP Fails to Connect (Alpha-4100)

I agree and have experienced the results of
starting up in dec window. Not good.

This is what I get from windows-pc ftp:
200 PORT command successful.
425-Cannot create data socket.
425 insufficient privilege or object protection violation

If I close DEC window (of ftp-startup)and check UCX, sho service, FTP is disabled. If I - enable service ftp - updates to being enabled.

If I go back to windows pc and try ftp,
> ftp: connect :Unknown error number

also cannot ftp localhost

I feel like I am in vicious circle w/o a
reboot. I am trying to avoid if possible.
Volker Halle
Honored Contributor
Solution

Re: FTP Fails to Connect (Alpha-4100)

Vince,

looks like the UCX$FTPD_SHUTDOWN.COM at least de-installed the FTP images and cleaned up other stuff. But without a real UCX$FTP startup, you're somehow stuck.

You could try to manually execute parts of UCX$SERVICE_SETUP.COM, which are related to FTP - this may work. But the cleanest way to recover is still a reboot.

More recent versions of UCX (now called TCPIP) provide correct start and stop procedures for the various TCPIP services.

Volker.

Re: FTP Fails to Connect (Alpha-4100)

Volker,

I agree. I found a reference on this website that implies, in general and not by
UCX version, that UCX itself has to be
started and stopped as a whole. Reference
and decription below:

http://www.sysworks.com.au/disk$axpdocdec972/network/dy9maa11.p142.bkb

12.1.2 Enabling and Disabling FTP
After FTP is configured during the UCX configuration procedure, activate FTP. You can:
Enable FTP during system startup (suggested).
Enable FTP interactively with a UCX management command.
Disable FTP interactively.
Disabling the FTP Server means that it does not establish any new connections.
Enable or disable FTP in the permanent Configuration Database.

- Every time UCX is started up, FTP is enabled or disabled.
- This action does not take effect until the next UCX startup.

Thanks again,
Vince