Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

FTP fails to connect

SOLVED
Go to solution
Kevin A Kirk
Occasional Visitor

FTP fails to connect

We are using a (somewhat antique) DEC Alpha running VMS 7.1-2, and are transfering files to/from it using again a(n antique) Windows NT PC. Both computers are operating on a totally isolated minihub and though the ftp prompt is always slow at appearing it eventually does.

Our new Windows 2000 PC, however, cannot connect to the Alpha. The output is:
C:\ ftp 192.9.200.70
Connected to 192.9.200.70.
Connection closed by remote host.
C:\

Numerous different ftp programs have been tried but to no avail. Our guess is that there is timeout on Windows 2000 that is different to the NT system. Does anyone know how to resolve this? Or know of a diagnostic tool we can use to find out the problem?

Thanks,
Kevin.
8 REPLIES
Martin P.J. Zinser
Honored Contributor

Re: FTP fails to connect

Hi Kevin,

the "slow prompt" is typically caused by the inability to resolve the other partners host name. In your situation it most probably is easist to just add entries for the three systems involved in the three local hosts files.

On a larger scale obviously a working DNS would be the solution.

Greetings, Martin
Volker Halle
Honored Contributor

Re: FTP fails to connect

Kevin,

to try to troubleshoot this problem, first look at the FTP service: $ UCX SHO SERV FTP/FULL
Find out the User_name under which the FTP server is running and look into it's default directory. There should be a .LOG file, possibly containing error messages.
Also do a REPLY/ENABLE and repeat the failing FTP connect from the Windows 2000 PC. Any OPCOM error messages ?

Volker.
H_Bachner
Regular Advisor

Re: FTP fails to connect

Are other network connections (e.g. telnet) faster and is just FTP slow? Or are they all slow?

If all network traffic is slow, there may be a problem for the network adapter in the Alpha negotiating speed and mode (duplex/noduplex) with the hub. Look at the error counters in

$ mc lancp show device /counters

If there are many alignment errors and/or frame check errors, this would indicate negotiation problems.

To solve these, set the NIC operation mode e.g. to Fast Full Duplex (or, depending on your hubs capabilities, to any other mode, but not Auto). It's best to define this at the Alpha (SRM) console level (e.g. ewa0_mode if your network adapter is ewa0). If shutting down the Alpha is not an option, you can also set the characteristics with
$ mc lancp set device ewa0 /speed=[10|100] /[no]full_duplex
(again assuming your network device is EWA0)

Of course, the respective port on the hub should also receive fixed settings, but minihubs usually aren't manageable...

If you have only the two nodes connected together, you could connect them with a crossover cable and set the line characteristics the same at both ends.

Hope this helps,
Han
Kevin A Kirk
Occasional Visitor

Re: FTP fails to connect

Thanks for the replies. Following all your diagnostics the telnet is fast, but none of the machines have their local hosts set and the error log UCX$FTPD.LOG is repeatedly giving:
%RMS-E-RNF, record not found
%UCX-E-FTP_GETHST, Error in getting host name

There may also be a complication here as it turns out that at one point the Alpha sat on a LAN with DNS servers. These primary and secondary server IP addresses are still set but no longer exist. Can anyone walk me though using UCX (or @UCX$config) to reconfigure it and add the local hosts?

Thanks,
Kevin.
Volker Halle
Honored Contributor
Solution

Re: FTP fails to connect

Kevin,

adding the local hosts is simple:

$ UCX SET host name/address=n.n.n.n

$ UCX SHOW CONF NAME or $ UCX SHOW NAME shows the current BIND resolver config.

$ UCX SET CONFIG NONAME should delete the name server configuration.

Volker.
Martin Vorlaender
Honored Contributor

Re: FTP fails to connect

1. To remove DNS servers:

UCX> SET CONFIG NAME /NOSERVER=ip

and

UCX> SET NAME /NOSERVER=ip /SYSTEM

2. To add host entries:

UCX> SET HOST hostname /ADDRESS=ip

cu,
Martin
Kevin A Kirk
Occasional Visitor

Re: FTP fails to connect

Thanks, that's fixed it! We've been complaining about the slow ftp access for years...

Thanks again,
Kevin.
Volker Halle
Honored Contributor

Re: FTP fails to connect

Another customer has seen this and has solved this problem by adding the IP name for the address of the Windows 2000 server in the OpenVMS UCX host database.

Using FTP.EXE from an NT system on the Windows 2000 server also made the intermittent FTP connection problems go away.

Volker.