Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

FTP service OPENVMS 8.4

 
MoisesV
Occasional Advisor

FTP service OPENVMS 8.4

I've upgraded from openvms 7.3 to openvms 8.4 and the ftp service does not go up, I checked all the settings but the ftp server does not work.
It accesses other ftp servers normally, however others can not access it, the service appears as started.

help please.

TY DKA:[TCPIP$FTP]TCPIP$FTP_RUN.LOG

******************************************************************
Certificate file not found
TCPIP$_FTP_NOSSL, FTP over SSL not supported

13 REPLIES 13
Steven Schweda
Honored Contributor

Re: FTP service OPENVMS 8.4

> I've upgraded from openvms 7.3 to openvms 8.4 and the ftp service does
> not go up, [...]

      tcpip show version

   What, exactly, does "the ftp service does not go up" mean?  As usual,
showing actual commands with their actual output can be more helpful
than vague descriptions or interpretations.  Copy+paste is your friend.

> [...] I checked all the settings but the ftp server does not work.

   With my weak psychic powers, I can't see what you "checked", I don't
know what "all the settings" means to you, and I don't know if you would
know a "bad" setting if you saw one.

> [...] It accesses other ftp servers normally, [...]

   That sounds like an FTP _client_ question.

> [...] however others can not access it,

   "can not" is not a useful problem description.  It does not say what
you did.  It does not say what happened when you did it.  As usual,
showing actual actions with their actual results (error messages, ...)
can be more helpful than vague descriptions or interpretations.

> [...] the service appears as started.

   Where?  At what are you looking?

> Message from user INTERnet on PSSRV2 INTERnet ACP Error during process
> startup Nolisten Service Disabled - FTP Server

   Is that an error message which appeared somewhere?

      tcpip show service /full ftp

Is there anything interesting in the log file
("SYS$SYSDEVICE:[TCPIP$FTP]TCPIP$FTP_RUN.LOG"?)

   Have you used AUTHORIZE to look at the TCPIP$FTP account?

      show system /process = *ftp*

   There is no "TCPIP$FTP_*" process running?


> Certificate file not found
> TCPIP$_FTP_NOSSL, FTP over SSL not supported

   That's not a fatal error.

MoisesV
Occasional Advisor

Re: FTP service OPENVMS 8.4

Hi,

Let me show you what happens.

active services are:

>>tcpip sh service

Service Port Proto Process Address State

ESNMP 705 UDP ESNMP 0.0.0.0 Disabled
FTP 21 TCP TCPIP$FTP 0.0.0.0 Enabled
LPD 515 TCP TCPIP$LPD 0.0.0.0 Enabled
RLOGIN 513 TCP not defined 0.0.0.0 Enabled
SMTP 25 TCP TCPIP$SMTP 0.0.0.0 Enabled
TELNET 23 TCP not defined 0.0.0.0 Enabled

>>show system /process = *ftp*
OpenVMS V8.4 on node PSSRV2 23-MAY-2018 17:21:41.12 Uptime 0 04:57:20
Pid Process Name State Pri I/O CPU Page flts Pages
00000291 TCPIP$FTP_1 CUR 1 8 456 0 03:03:41.07 743 514 N

tcpip sh service ftp

Service Port Proto Process Address State

FTP 21 TCP TCPIP$FTP 0.0.0.0 Enabled

>>tcpip sh service ftp/full

Service: FTP
State: Enabled
Port: 21 Protocol: TCP Address: 0.0.0.0
Inactivity: 5 User_name: TCPIP$FTP Process: TCPIP$FTP
Limit: 1000 Active: 1 Peak: 1

File: TCPIP$SYSTEM:TCPIP$FTP_RUN.COM
Flags: None

Socket Opts: Rcheck Scheck
Receive: 0 Send: 0

Log Opts: Acpt Actv Dactv Conn Error Exit Logi Logo Mdfy Rjct TimO Addr
File: SYS$SYSDEVICE:[TCPIP$FTP]TCPIP$FTP_RUN.LOG

Security
Reject msg: not defined
Accept host: 0.0.0.0
Accept netw: 0.0.0.0

 

now I will access ftp:

>>ftp
FTP> open 10.109.10.70

here it stops....

 

Steven Schweda
Honored Contributor

Re: FTP service OPENVMS 8.4

> Let me show you what happens.

   It would be nice if you started with:

      tcpip show version

> 00000291 TCPIP$FTP_1 CUR 1 8 456 0 03:03:41.07 743 514 N

   Ok.  The FTP server appears to be running.

> >>ftp
> FTP> open 10.109.10.70

   Is "10.109.10.70" the VMS system itself?

> here it stops....

   For how long?  How long did you wait?

   Is FTP the only service with this problem, or does, say, Telnet have
a similar problem?

MoisesV
Occasional Advisor

Re: FTP service OPENVMS 8.4

>>tcpip sh version

HP TCP/IP Services for OpenVMS Alpha Version V5.7
on an AlphaServer ES45 running OpenVMS V8.4

!Let's do an access test to 70 ..
sh net

Product: DECNET Node: PSSRV4 Address(es): 3.45
Product: TCP/IP Node: PSSRV4.previsul.com.br Address(es): 10.109.10.34

>>tcpip
>>tcpip ping 10.109.10.70
PING 10.109.10.70 (10.109.10.70): 56 data bytes
64 bytes from 10.109.10.70: icmp_seq=0 ttl=64 time=2 ms
64 bytes from 10.109.10.70: icmp_seq=1 ttl=64 time=1 ms
64 bytes from 10.109.10.70: icmp_seq=2 ttl=64 time=0 ms
64 bytes from 10.109.10.70: icmp_seq=3 ttl=64 time=0 ms


----10.109.10.70 PING Statistics----
4 packets transmitted, 4 packets received, 0% packet loss
round-trip (ms) min/avg/max = 0/1/2 ms

 

FTP> open 10.109.10.70

Here, it stays forever.

Is FTP the only service with this problem, or does, say, Telnet have
a similar problem?

Yes, telnet access works perfectly.

Volker Halle
Honored Contributor

Re: FTP service OPENVMS 8.4

So you're testing the FTP server from another node. How about first testing the FTP server on the V8.4 node itself ?

$ FTP localhost

Does the TCPIP name resolver work on the V8.4 node ? TCPIP SHOW HOST/ADDR=10.109.10.70 ? And also TCPIP SHOW HOST/ADDR=10.109.10.34 ?

Volker.

Steven Schweda
Honored Contributor

Re: FTP service OPENVMS 8.4

> HP TCP/IP Services for OpenVMS Alpha Version V5.7

   What's current?  I have V5.7 - ECO 5.

> Here, it stays forever.

   "forever" is a very long time.  More than, say, five minutes?

MoisesV
Occasional Advisor

Re: FTP service OPENVMS 8.4

Hi, the result is the same, I already tested on the same node and from another node, all to no avail.

 

Look,

>>

sh net

Product: DECNET Node: PSSRV2 Address(es): 1.1
Product: TCP/IP Node: pssrv2.previsul.com.br Address(es): 10.109.10.70
>>ftp 10.109.10.70
from this point it does not leave

 

MoisesV
Occasional Advisor

Re: FTP service OPENVMS 8.4

yes, from this point it does not leave, I've waited more than 10 minutes ..

MoisesV
Occasional Advisor

Re: FTP service OPENVMS 8.4

I think it's strange, in another node the service is active and the CPU time is insignificant, already in this node that the service is in trouble, the cpu time is quite different, see the examples below:

No ok

>>sh net

Product: DECNET Node: PSSRV4 Address(es): 3.45
Product: TCP/IP Node: PSSRV4.previsul.com.br Address(es): 10.109.10.34

>>show system /process = *ftp*/full
OpenVMS V7.3-2 on node PSSRV4 24-MAY-2018 10:43:59.24 Uptime 35 03:15:03
AlphaServer ES45
Pid Process Name State Pri I/O CPU Page flts Pages
0000043E TCPIP$FTP_1 LEF 10 59706 0 00:00:08.07 576 472 N
[TCPIP$AUX,TCPIP$FTP] 3776Kb

 

Node with problems!

>>sh net

Product: DECNET Node: PSSRV2 Address(es): 1.1
Product: TCP/IP Node: pssrv2.previsul.com.br Address(es): 10.109.10.70

>>show system /process = *ftp*/full
OpenVMS V8.4 on node PSSRV2 24-MAY-2018 10:43:22.38 Uptime 0 22:18:57
AlphaServer ES45
Pid Process Name State Pri I/O CPU Page flts Pages
00000291 TCPIP$FTP_1 CUR 1 8 456 0 20:04:13.22 743 514 N
[TCPIP$AUX,TCPIP$FTP] 4112Kb

Volker Halle
Honored Contributor

Re: FTP service OPENVMS 8.4

It's pretty obvious, that the FTP server process is looping. MONI PROC/TOPCPU would most likely show the TCPIP$FTP_1 process to be actively using one CPU ( > 90%) most of the time.

Try to configure SSH to get rid of the warning message in the TCPIP$FTP_RUN.LOG file. This may or may not help...

Or try to get and install the most recent TCPIP ECO kit

Volker.

 

MoisesV
Occasional Advisor

Re: FTP service OPENVMS 8.4

Actually, the CPU consumption was m 90%, I activated SSL, but nothing has changed!

Volker Halle
Honored Contributor

Re: FTP service OPENVMS 8.4

Did you restart the FTP service after configuring SSH ? You might need to manually STOP TCPIP$FTP_1. Or better reboot the ES45.

Volker.

MoisesV
Occasional Advisor

Re: FTP service OPENVMS 8.4

I performed your procedure, but it continues in the same scenario.