Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Fortran 90 on Itanium

James Trickey
Occasional Advisor

Fortran 90 on Itanium

We have just purchase 2 HP Integritys to upgrade from our Alphas.

We have found that the new Fortram 90 no longer will support a PARAMETER statement of the form PARAMETER c=1 (ie without the brackets). This is fine for our code, but for the include files from the system libraries it is not.
Specifically the $IODEF include file from the SYS$COMMON:[SYSLIB]FORSYSDEF.TLB library. Apparently it still uses the PARAMETER statements of the old form, so will not compile.
Is there a more up to date version of the library or some compiler switch that will allow the older form of the PARAMETER satement?

6 REPLIES
Hoff
Honored Contributor

Re: Fortran 90 on Itanium

Get HP support involved; this looks to be a bug in the Fortran environment.

Pending that, extract $IODEF out of the text library, fix it, and replace it.
Arch_Muthiah
Honored Contributor

Re: Fortran 90 on Itanium

James,

Try this compiler qualifier
/assum=noaltparam

/assume = altparam is deault. The alternate form has no parentheses.


Archunan
Regards
Archie
Brad McCusker
Respected Contributor

Re: Fortran 90 on Itanium

James,

I was unable to reproduce this. Could you possibly post a simple reproducer?

Brad

Software Concepts International
www.sciinc.com
Brad McCusker
Software Concepts International
James Trickey
Occasional Advisor

Re: Fortran 90 on Itanium

It appears to be the /assume=altparam. Even though the help says the default is altparam, it appears to be the opposite. We will have to add the parameter to our compile command.

As for an example, any fortran code containing; INCLUDE '($IODEF)' was enough.

Since the altparam is not supposed to standard for F90, HP should consider updating it's include file.
Brad McCusker
Respected Contributor

Re: Fortran 90 on Itanium

>It appears to be the /assume=altparam. Even
>though the help says the default is
>altparam, it appears to be the opposite.

Something seems strange to me. The behavior I see on my VMS 8.2-1/FOR V8.0 and VMS 8.3/FOR8.1 is that /assume=altparam is the default. I suspect you've got something, somewhere, adding to or changing your compile line that you are un aware of. If it were me, I'd want to track that down to avoid other suprises or unintended consequences.

Brad McCusker

Software Concepts International
www.sciinc.com
Brad McCusker
Software Concepts International
James Trickey
Occasional Advisor

Re: Fortran 90 on Itanium

You are correct. It would seem that since some distant time in the past, our standard compile command has bee define with /NOASSUME. We will have to change it for the new system.