Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

FreeAXP - Setup to display to X-Windows server on Windows Host

 
GuentherF
Trusted Contributor

FreeAXP - Setup to display to X-Windows server on Windows Host

I posted this over in the OpenVMS Hobbyist  Forum but I hope it has a better exposure here.

 

I need to display the output of an application on FreeAXP (build 307) to the host Windows system with eXcursion server running.

It did not work with just the local Ethernet controller:

X Toolkit Error: Can't Open display
%DWT-F-NOMSG, Message number 03AB8204

On OpenVMS I did:

$ SET DISPLAY/CREATE/TRANS=TCPIP/NODE=192.168.1.21

On the host Windows system I have enabled all access to the X-Windows server.

Works fine from a 'real' OpenVMS system

I heard rumours that you can do this through the "Loopback Adapter" on the Windows system. I named the loopback connection on Windows "FreeAXP" and added this to the FreeAXP configuration file after the real Ethernet controller connection:

pci11 = de500
{
adapter="Local Area Connection";
}

pci12 = de500
{
adapter="FreeAXP";
}

And I defined Interface WE1 in TCPIP$CONFIG:

1 - WE0 Menu (EWA0: TwistedPair 10mbps)
2 - 192.168.1.203/24 bugcel Configured,Active

3 - WE1 Menu (EWB0: TwistedPair 10mbps)
4 - 192.168.1.204/24 bugcel1 Configured,Active

The application (I use DECW$CLOCK for testing) hangs for quite some time and then returns the error above.

So, did someone succeed in doing this?

Thanks,
Guenther

5 REPLIES 5
Volker Halle
Honored Contributor

Re: FreeAXP - Setup to display to X-Windows server on Windows Host

Guenther,

 

this is a quite complex configuration, which makes troubleshooting a nightmare...

 

On your OpenVMS system, both TCPIP interfaces are in the SAME subnet, so TCPIP will decide by itself (round-robin) where to send the IP packets. This may be one reason for failure. Can you define another IP network segment address for the 'loopback connection' (both on OpenVMS and the Windows PC) ?

 

The 'Virtual Alpha User Guide' describes in chapter 9.2 Networking Avanti on a system with a single NIC

 

I normally use $ RUN DECW$EXAMPLES:ICO for testing, because it provides better error messages.

 

Can you PING from the OpenVMS system (running in FreeAXP) to the Windows host system ?

 

Volker.

Volker Halle
Honored Contributor

Re: FreeAXP - Setup to display to X-Windows server on Windows Host

Guenther,

 

I just re-tested a simple shared network card config with both FreeAXP (build 283) and PersonalAlpha (2.0.17) and the same OpenVMS V7.3-2 system disk (TCPIP address via DHCP) again on a Windows 7 Enterprise 64 bit notebook. And I can't ping the local Windows host from the OpenVMS system running in FreeAXP or PersonalAlpha and vice versa. I can ping to/from the OpenVMS system and the Windows notebook to some other Windows system in the local LAN.Windows and OpenVMS share the single Windows network card.

 

I know I had this working in the past (at least twice) on Windows XP systems with PersonalAlpha without any additional 'loop' tricks. So my conclusion is, that the shared network card config does not work with Windows 7 (64-bit ?) and/or the current network card(s)/driver(s) anymore.

 

Your approach should work, it you take into account the TCPIP configuration quirks.

 

Volker.

Duncan Morris
Honored Contributor

Re: FreeAXP - Setup to display to X-Windows server on Windows Host

Guenther,

 

using FreeAXP (V2 build 377) on Windows 7 32-bit professional, I have a single shared network card on the laptop

 

pci11 = de500
      {
        adapter = "Local Area Connection";

 

$ tcpip show inter we0
                                                           Packets
Interface   IP_Addr         Network mask          Receive          Send     MTU

 WE0        10.26.20.76     255.255.0.0            413441          6499    1500

$ tcpip show host duncanmpc

     LOCAL database

Host address    Host name

10.26.70.130    DUNCANMPC

$ set displ/crea/node=10.26.70.130/trans=tcpip

$ mc decw$puzzle
 (window appeared and ran correctly)

 

I am using eXcursion V7 on the laptop.

 

Duncan

GuentherF
Trusted Contributor

Re: FreeAXP - Setup to display to X-Windows server on Windows Host

Volker,

 

I gave up the approach with the Loopback Adapter. I can PING the PC from FreeAXP and vice versa. I can display the X-Windows output to another PC. Using DECW$PUZZLE I get:

 

XIO:  fatal IO error 65535 (connect to network object timed-out or failed) on X server "_WSA3:"
      after 0 requests (0 known processed) with 0 events remaining.
X Error of failed request:  BadConnection (fatal error on display connection)
  Major opcode of failed request:  1 (X_CreateWindow)
  Serial number of failed request:  0
  Current serial number in output stream:  0
%XLIB-E-ERROREVENT, error event received from server
Xlib: client uses different protocol version (11) than server (0)!
X Toolkit Error: Can't Open display
%DWT-F-NOMSG, Message number 03AB8204

 

Seems it connects to the eXcursion server on the PC if I can trust this output. Could also be fake if the application could not connect and hence had a protocol version = 0 still in its memory belly and output the misleading protocol version error...my guess.

 

I am using eXcursion 7.3.189.

 

Duncan,

 

I hoped to get it working with FreeAXP 377. But I had troubles to install 377 (see http://www.openvmshobbyist.com/forum/viewforum.php?forum_id=163).

 

You used a network mask of 255.255.0.0 means that both systems are in the same network. Did you define anything else for TCPIP setup on FreeAXP?

 

Thanks,

Guenther

Duncan Morris
Honored Contributor

Re: FreeAXP - Setup to display to X-Windows server on Windows Host

Guenther,

I cannot acccess the hobbyist forum from my current location, but will check it out later.

No special setups done on TCPIP.

I am using eXcursion 7.3.189 as well.

Duncan