cancel
Showing results for 
Search instead for 
Did you mean: 

GBL_DTSS1

 
Wim Van den Wyngaert
Honored Contributor

GBL_DTSS1

While debugging DNS I found that there is a name lookup for gbl_dtss1 EVERY 5 seconds.

This name is also mentioned in sys$manager:dtss$error.log :
E GetBindData: gethostbyname error: gbl_dtss1, errorno:50, vaxc$errno: 8340
E GetBindData: gethostbyname error: network is down

I found the occurence of gbl_dtss (without 1) in dtss#service.exe.

What is the purpose of this lookup ? How can I safely prevent this lookup ?

Wim
Wim
7 REPLIES 7
Wim Van den Wyngaert
Honored Contributor

Re: GBL_DTSS1

http://h71000.www7.hp.com/doc/82final/decnetplus/dts_mng.pdf and look for gbl_dtss.
So, it's looking for global servers. But how to disable it ?

Wim
Wim
Ian Miller.
Honored Contributor

Re: GBL_DTSS1

I think you have to set the dtss courier role to none

You can do this interactively and if ok alter the startup ncl
____________________
Purely Personal Opinion
Wim Van den Wyngaert
Honored Contributor

Re: GBL_DTSS1

Ian,

My node is a clerck. It has no courrier role.

I checked on a server node. This is a noncourier. And there seems to be no dns lookup on this node.

And every 5 seconds is not true. It's not that predictable. Keep it on several times per minute.

Wim
Wim
John Gillings
Honored Contributor

Re: GBL_DTSS1

Wim,

The lookup is required for DTSS to find the global server in order to synchronize time. That's it's job! If you prevent the lookup, you prevent DTSS from synchronizing your clock.

Is one DNS lookup every 5 seconds really worth your time to "optimize"?

If you don't like the lookup, disable DTSS.

(alternatively, maybe try defining gbl_dtss1 in the local DNS to point to your real global server)
A crucible of informative mistakes
Wim Van den Wyngaert
Honored Contributor

Re: GBL_DTSS1

John,

That's just the point : it's a clerck doing the lookup. As far as I remember, it's getting the list of time servers via DTIME protocol.

The servers themself are enabled by ncl dtss type server and ncl set dts decnet courier role noncourier. And these don't do the lookup.

Still find it strange that the global server is not enabled/disabled in ncl. But may be I should read the manual again.

Wim (having time)
Wim
Wim Van den Wyngaert
Honored Contributor

Re: GBL_DTSS1

Another thing : why is it using a TCP DNS ?
This should be decnet DNS (which we don't have).

Wim
Wim
John Gillings
Honored Contributor

Re: GBL_DTSS1

Wim,

I really don't understand what you're asking here. A component is doing what you asked. You don't like the way it's doing it? Then turn it off!

>Another thing : why is it using a TCP DNS ?
>This should be decnet DNS (which we don't
>have).

You've answered your own question. You don't have a DECnet DNS, so it obviously can't use that. You do have a TCPIP DNS, so it's using that instead. Software just doing its best to do what you've asked (regardless of if you know or understand what you've asked).

You have two choices here, either ignore the task and let it get on with doing its job, or turn it off.

A crucible of informative mistakes