HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Having trouble copying data from foreign tape format

 
Joe Profaizer
Super Advisor

Having trouble copying data from foreign tape format

I have a 3490E tape drive connected to my Alpha 4100 running OpenVMS 7.2-1. I'm trying to copy data from a 3480 tape, but cannot for the life of me do it.
I've tried:
$mount/foreign/nolabel $1$mua3:
$mount/over=id $1$mua3:
It mounts the tape, but I can't read/copy any data.

And a few other mount options, but when I try to copy from the media it will not work. Any other mount options or advice I can try?

Thanks,

..Joe
4 REPLIES
Huc_1
Honored Contributor

Re: Having trouble copying data from foreign tape format

Hello

After your mount/over=id $1$mua3
what does "show dev $1$mua3: /full" replies ?
and if you can try it on a other system, is there something on that tape ? ... perhaps its empty?

after it is mounted/over=id
try dump $1$mua3:

... any luck ?
does show error before and after mount increase

Please note I do not have a vms system in front of me, this is just the first thing that I can thing of, I realise you may have already tried all of this, but perhaps if you give us a littel more information someone (perhaps me) will be able to help you futher.

Whatever, enjoy life.
Smile I will feel the difference
Jeff Chisholm
Valued Contributor

Re: Having trouble copying data from foreign tape format

Joe,
When you say it will not work, what do you mean exactly?

I used to read tapes from ibm systems in a former life, but it's been a long time. In standard ANSI format, there's a tape label, tape marks, volume label, another tape mark, to get through before you get any data. Do you have a format of what the tape is supposed to look like?

Try mounting it /over=id, and then do about six reads into records, rec1, rec2, rec3, etc. Don't use on_error because that will be triggered by the tape marks.

Once you get past the header and volume info, rec6 should be data, can you try this out?
/jeff
le plus ca change...
Burkart Beat
Frequent Advisor

Re: Having trouble copying data from foreign tape format

Hi Joe

Do you have any idea about blocksize of that tape?

Maybe you should try the following:

$ mount/ov:id/block=512

512 Byte or any other value, depending of the true recordsize. I used to have tapes with 650 bytes fixed length years ago, from IBM hosts.

In addition to that, it was EBCDIC

To convert this, there is a system call:

lib$tra_ebc_asc(ebcdic value,ascii value)

There is also a nice tool called EXCHANGE

Do $ help exchange

This tool might help too

Best regards
Beat
Mac Lilley
Frequent Advisor

Re: Having trouble copying data from foreign tape format

Hello Joe
ETAPE on the OpenVMS Freeware cd may be useful to you. According to the abstract it will (amongst other things) read EBCDIC tapes.
Regards
ML