Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

How to avoid RWCSV?

 
joukj
Occasional Advisor

How to avoid RWCSV?

H All,

System : OpenVMS 8.4 AXP

Problem : when opening many decw$terminals  After some time it fails due to processes getting into RWCSV.

               After closing some terninals sometimes the problem is solved, but in other cases I have to reboot.

              (I use all these terminals to login to other members of the clusrter,other cluster or other machines, by

              DECNET or SSH.

I tried already to run autogen but it did not solve the problem. Are there any parametres I can set manual to avoid the problem?

 

                         Regrads

                                    Jouk

4 REPLIES 4
abrsvc
Respected Contributor

Re: How to avoid RWCSV?

The RWCSV state indicates waiting for the "other" cluster member to complete something, you must look at the other members.  Locate the resource or process that is handling your local request and resolve that problem.

From the internals book:

"A maximum number of outstanding transfer requests may be made from one VMScluster node to a remote node's cluster server process.   When this limit has been reached and a kernel thread requests a service that would initiate another such transfer,  the kernel thread is placed into RWCSV wait until transfer requests complete.  Also, when a kernel thread requests certain clusterwide process system services, it is placed into RMCSV until the request completes on the other node."

I hope thishelps,

Dan

joukj
Occasional Advisor

Re: How to avoid RWCSV?

Thanks for the answer. It set me up thinking on the problem in another way. I think I found the cause of the problem on my machine, but I do not like it at ll

I noticed that the ffirst ppcess to get into the RWCSV was the CLUSTER_SECURITY. . Combined with the fact that my cluster is always under attack by "script-kids" trying to find passworsds (mainly of the non existing "root") I thought that might be the problem. So I closed down the ssh-service on this cluster memeber. Since that time I did not see the RWCSV appear on any process.

 

I think I have to setup SSH-support for this cluster on another port than 22.

 

                                 Regards

                                          Jouk

Steven Schweda
Honored Contributor

Re: How to avoid RWCSV?

> I think I have to setup SSH-support for this cluster on another port
> than 22.

   Based on my experience, I'd expect that to make a huge difference.

   I keep all the local stuff on 22, but use port forwarding on my
router to displace the external port(s).  (Same for Telnet on 23.  One
rule for 22-23 can do both.)  All the SSH-related programs which I use
have a "-p <port>" option, so it's hardly even a minor inconvenience.

joukj
Occasional Advisor

Re: How to avoid RWCSV?

I have to do it slightly different, since my machines are in a university network. So I have to ask for a small change in the firewall-rules of the university (close 22 and open the port I use for incoming ssh-trafic).

 

                             Jouk