Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

How to change time interval for ARP to hold info in its cache?

 
SOLVED
Go to solution

How to change time interval for ARP to hold info in its cache?

Hi there,

Does someone know to set the time interval for ARP to hold info in its cache on a OpenVMS 7.3-2 system running TCPIP V5.4 ECO 6?

(well: RTFM is a possible answer :>P )

In the TCPIP-manual (Tuning and troubleshooting) in chapter 1.2.3 a command as
$ SET [CONFIG] PROTOCOL ARP is mentioned and referred to in the Command Reference.....

But neither the command reference nor DCL HELP recognizes this command.

Anybody a clue?

thnx in advance

Henk van Dorp
8 REPLIES 8
Wim Van den Wyngaert
Honored Contributor
Solution

Re: How to change time interval for ARP to hold info in its cache?

I agree that it's a mess.

Check the arp command (arp -?) and the unix doc.

Or use "sysconfig -q net" to see them.

arpkillc : sec after which a completed arp timeouts. Not sure that it's this but the value 1200 on my system is 20 minutes which is the default timeout.

Wim
Wim

Re: How to change time interval for ARP to hold info in its cache?

Wim,

thanks for your answer. It is what I've experienced to (20 minute to timeout).

with regards

Henk

Re: How to change time interval for ARP to hold info in its cache?

Wim,
your answer pointed me to the solution.
I pick it up from here. thanx

But....

after modifying the sysconfigtab with sysconfigdb, nothing changed in behaviour.

AX0172[DORPH]tcpip sysconfig -q net
net:
arpkillc = 30
arpkilli = 180
arprefresh = 120
arpunicast = 1
ifqmaxlen = 1024
lo_devs = 1
lo_def_ip_mtu = 4096
nslip = 0
ovms_unit_count = 27
ovms_unit_creates = 638
ovms_unit_fast_credel = 0
ovms_unit_limit = 9998
ovms_unit_minimum = 2
ovms_unit_maximum = 9999
ovms_unit_seed = 637

and:

AX0172[DORPH]typ tcpip$etc:sysconfigtab.dat
#
# TCP/IP Services for OpenVMS V5.1
# sysconfig parameter file
#
nfs:
tcp_threads=8
udp_threads=8

vfs:
vnode_age=120

inet:
tcp_keepalive_default=1
tcp_keepidle=150

net:
arpkillc=30

Restarting TCPIP didn't change the duration, nor did a reboot.

Do I forget something?

with regards

Henk
Wim Van den Wyngaert
Honored Contributor

Re: How to change time interval for ARP to hold info in its cache?

(but I was wrong on arp, that's the equiv of ucx sho arp)

Wim
Wim
Wim Van den Wyngaert
Honored Contributor

Re: How to change time interval for ARP to hold info in its cache?

With ucx sho arp you can see the timer associated with each arp entry. It seems indeed that it gets refreshed each time. Could it be that the refresh timer must be bigger than the killc ?

Found nothing with google !

Wim
Wim