Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

How to disable ethernet port on VMS Server

 
SOLVED
Go to solution
Toine_1
Regular Advisor

How to disable ethernet port on VMS Server

Hello,

 

I have a BL860c server with 4 network cards (EWA0, EWB0, EWC0 and EWD0).  Only three card are connected via a UTP cable to the LAN network. One cards EWB0 is not connected. I have upgraded my server to 8.4 but now the VMS server is incrementing the errors on this device (carrier check failures.). Can I disable this network port on my server and how?

 

P.S.
I didn't have this behaviour on VMS 8.3-1H1.

 

/Toine

9 REPLIES 9
Bob Blunt
Respected Contributor

Re: How to disable ethernet port on VMS Server

How you disable an Ethernet interface depends on the networking stacks you're using.  Is your system in a cluster?  What protocols/stacks are you using?  DECnet (and which flavor)?  Which TCPIP?  LAT?  There is a long list of possible networking protocols you might have but, in a nutshell, you have to shut them off using the particular tool that each uses to control the interfaces in use.  Because each individual ethernet device listed is a template device first you'll still see each EWxn but the number of non-zero devices usually indicates how many protocols you have running on each template device.

 

For DECnet Phase IV it would be NCP

For DECnet Phase V it would be NCL

For TCPIP services you might have to reinvoke SYS$STARTUP:TCPIP$CONFIG to change interfaces or there are commands you can manually issue from the TCPIP> prompt (IF you have explicit directions or have experience changing configured interfaces manually before)

Some other protocols can be managed using LANCP

For LAT you'd have to make changes to LAT device logical names or in LAT startup procs.

For "classic" Infoserver/ESS you'll have to change data in one of the ESS startup data files

 

bob

Steven Schweda
Honored Contributor

Re: How to disable ethernet port on VMS Server

   I don't know if it'd be a smart thing to do, but you might look at:

      sysman help IO SET EXCLUDE

If the device is not in the configuration, then you should, at the
least, get different complaints.

 

   For a hardware fix, buy a cheap network hub/switch, and connect the
unused port to the new (otherwise unused) hub/switch.

Volker Halle
Honored Contributor

Re: How to disable ethernet port on VMS Server

Toine,

 

start with ANALYZE/SYSTEM and SDA> SHOW LAN

 

This will list all the network protocols on all the LAN adapters in your system. Then look at the protocols, which are running on EWB0. For each protocol, there should be a method to prevent it from starting on this LAN adapter.

 

If you provide the output from the above command for EWB0, we can certainly help you disable all the protocols on that LAN adapter. If no protocols are active, no packets will be sent and no counters will be incremented.

 

Volker.

The Brit
Honored Contributor

Re: How to disable ethernet port on VMS Server

Hi Toine,

        I assume that what you really want is for EWB0 to stop racking up errors.     Since this is a bl860c, then it must be installed in a c3000 or c7000 blade enclosure, with Ethernet Interconnect modules installed in IC bay 1 (for c3000) or IC bays 1 & 2 (for c7000).      One solution would depend on the type of Interconnect modules you have installed in your enclosure.

 

     The connections between the blade LOM's (NICs) and the Interconnect bays are "hard wired", i.e. they exist no matter what.      So if your interconnects are either switches or Virtual Connect, then confirm that the device is correctly configured for speed/duplex/autoneg/etc in LANCP.   

 

      For VC, check the setup of the ethernet ports in the VC profile.     I have seen some strange combinations required to get the link up between blade and VC.   However, since by implication, EWD0 is working and EWB0 is not, check that they are set up identically in VC and LANCP, (EWB0 and EWD0 use the same IC Module).

 

     If your IC modules are Ethernet Switches then confirm the port settings etc, as you would for a normal Server -> Network connection.    

 

     Finally, if your IC modules are Pass-through's then you should consider Steven's option of making a connection to a dummy switch/hub (not a recommendation, just a probable solution.)

 

    If none of the above work, then go to the other suggestions above.

 

Hope this helps.

 

Dave

Toine_1
Regular Advisor

Re: How to disable ethernet port on VMS Server

Hi Again,

 

Below the ANA/SYS> SHOW LAN of the EWB0 device:

 

I already disable the card in DecNet via:


ncl> disable routing circuit csmacd-2

 

But this not enough what should I disable more?



                 -- EWB Device Summary 22-JUL-2011 14:32:52 --


LSB address  = EDC3A000
Device state = 00003003 RUN,INITED,FP_CPUAFF,AUTO_ENA

UCB      UCB Addr  Fmt   Value           Client     State
---      --------  ---   -----           ------  -----------
EWB0     B0ABA080
EWB4     B12DEC80  802E  08-00-2B-80-3C  DNAME   0017 STRTN,LEN,UNIQ,STRTD
EWB5     B12DF340  Eth   80-3C           DNAME   0017 STRTN,LEN,UNIQ,STRTD
EWB7     B13294C0  Eth   60-01           MOPDL   0017 STRTN,LEN,UNIQ,STRTD
EWB8     B1329D00  802E  08-00-2B-60-01  MOPDL   0017 STRTN,LEN,UNIQ,STRTD
EWB9     B132A740  Eth   60-02           MOPRC   0017 STRTN,LEN,UNIQ,STRTD
EWB10    B132B180  802E  08-00-2B-60-02  MOPRC   0017 STRTN,LEN,UNIQ,STRTD
EWB11    B132BBC0  Eth   90-00           LOOP    0015 STRTN,UNIQ,STRTD
EWB12    B132C600  802E  08-00-2B-90-00  LOOP    0017 STRTN,LEN,UNIQ,STRTD

 

/Toine

Volker Halle
Honored Contributor
Solution

Re: How to disable ethernet port on VMS Server

Toine,

 

please verify, that CSMACD-2 is really EWB0 ! Use $ MC NCL SHOW CSMA-CD STAT * COMM PORT

DECnet normally starts with CSMACD-0 on the first LAN adapter, i.e. EWA0, so CSMACD-2 is EWC0 by default, although you might have changed that in your DECnet configuration.

 

Then use $ MC NCL DISABLE MOP CIRCUIT CSMACD-2

 

to stop MOPDL, MOPRC und LOOP on EWB0:

 

To stop the DNAME protocol, you need to define a logical name in SYLOGICALS.COM (see DECnet release notes):

 

$ DEFINE/SYSTEM DNS$ETHERNET_DEVICE "Don't use _EWB0: "

 

After the next reboot, DNAME will not start on EWB0: anymore

 

Volker.

Toine_1
Regular Advisor

How to disable ethernet port on VMS Server

Hi,

 

Thank you all for the good and quick responses.

 

Regards,

 

/Toine

The Brit
Honored Contributor

Re: How to disable ethernet port on VMS Server

And the solution to your problem was....?

Toine_1
Regular Advisor

Re: How to disable ethernet port on VMS Server

Hello,

 

The solution for the problem was very simple.

Just disbale Auto-negotiation via LANCP on EWB0 device. Then the error count is not increasing on that device.

 

$ MC LANCP SET DEVICE EWB0/NOAUTO


Regards,

/Toine