HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

How to prevent a user from $ promt?

 
Mohammed Abdul Gafoor
Occasional Visitor

How to prevent a user from $ promt?

We are using VMS 6.2 on Alpha 100a using DSM 7.1.

I have created a new user (RAED1)his default dir is [SPOOL] to copy/trasfer files from Alpha using FTP software (KEA). This user can access $ promt. Then, I have tried to give him a new LGICMD to prevent him from $ prompt but FPT (KEA)doesn't work. It keeps reading LGICMD that consumes space and may hang the system. Please advise how to reslve this problem?

Username: RAED1
Default: LIVE_DISK:[SPOOL]
LGICMD: LIVE_DISK:[COM]RAED1_LOGIN
8 REPLIES
Ian Miller.
Honored Contributor

Re: How to prevent a user from $ promt?

If you only want the user to be able to do ftp then I enable network access only and these flaggs.

Flags: DefCLI LockPwd Restricted DisWelcome DisMail DisReport DisReconnect

I would set the default dir to another place and then have the LOGIN.COM change default to [SPOOL]

This way the files the user sends arrive in [SPOOL] but the ftp log files are in the users default directory.
____________________
Purely Personal Opinion
Mohammed Abdul Gafoor
Occasional Visitor

Re: How to prevent a user from $ promt?

Ian,

Thanks for the solution.

I have set the parameters as suggested, still user can access to $ promt. please see below the details of the useR.

Username: RAED1 Owner:
Account: UIC: [1000,263] ([RAED])
CLI: DCL Tables: DCLTABLES
Default: LIVE_DISK:[SPOOL]
LGICMD: LIVE_DISK:[SPOOL]LOGIN
Flags: DefCLI LockPwd Restricted DisReport DisReconnect
Primary days: Mon Tue Wed Thu Fri
Secondary days: Sat Sun
No access restrictions
Expiration: (none) Pwdminimum: 6 Login Fails: 0
Pwdlifetime: 90 00:00 Pwdchange: 1-NOV-2005 14:47
Last Login: 1-NOV-2005 16:09 (interactive), 1-NOV-2005 14:49 (non-interactive)
Maxjobs: 0 Fillm: 100 Bytlm: 64000
Maxacctjobs: 0 Shrfillm: 0 Pbytlm: 0
Maxdetach: 0 BIOlm: 150 JTquota: 4096
Prclm: 8 DIOlm: 150 WSdef: 2000
Prio: 4 ASTlm: 250 WSquo: 4000
Queprio: 0 TQElm: 10 WSextent: 16384
CPU: (none) Enqlm: 2000 Pgflquo: 50000
Authorized Privileges:
Default Privileges:
NETMBX TMPMBX


Peter Barkas
Regular Advisor

Re: How to prevent a user from $ promt?

It seems that you may not have set the access restrictions as suggested.
Willem Grooters
Honored Contributor

Re: How to prevent a user from $ promt?

Network only:

$ MCR AUTHORIZE
UAF> MOD RAED1 /NOINTERACTIVE/NOBATCH/NODIALIN
UAF EXIT

will allow only network access

Willem

Willem Grooters
OpenVMS Developer & System Manager
Mike Reznak
Trusted Contributor

Re: How to prevent a user from $ promt?

Hi,
this might be the right flag for you.

CAPTIVE Prevents the user from changing any defaults at
login, for example, /CLI or /LGICMD. It prevents
the user from escaping the captive login command
procedure specified by the /LGICMD qualifier and
gaining access to the DCL command level. Refer to
"Guidelines for Captive Command Procedures" in the
OpenVMS Guide to System Security.

The CAPTIVE flag also establishes an environment
where Ctrl/Y interrupts are initially turned off;
however, command procedures can still turn on Ctrl/Y
interrupts with the DCL command SET CONTROL=Y. By
default, an account is not captive (NOCAPTIVE).

Mike
...and I think to myself, what a wonderful world ;o)
Jiri_5
Frequent Advisor

Re: How to prevent a user from $ promt?

We use for FTP account this setting:

Default: DISK:[FTP]
LGICMD: NL:
Flags: Restricted
Primary days: Mon Tue Wed Thu Fri
Secondary days: Sat Sun
Primary 000000000011111111112222 Secondary 000000000011111111112222
Day Hours 012345678901234567890123 Day Hours 012345678901234567890123
Network: ##### Full access ###### ##### Full access ######
Batch: ----- No access ------ ----- No access ------
Local: ----- No access ------ ----- No access ------
Dialup: ----- No access ------ ----- No access ------
Remote: ----- No access ------ ----- No access -----
Mohammed Abdul Gafoor
Occasional Visitor

Re: How to prevent a user from $ promt?

It worked.

Thanks.
Ian Miller.
Honored Contributor

Re: How to prevent a user from $ promt?

http://forums1.itrc.hp.com/service/forums/helptips.do?#33
____________________
Purely Personal Opinion