Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Installation error of a kit (save sets) on Open VMS Itanium 8.3 1H1

 
ManajitHalder
Occasional Visitor

Installation error of a kit (save sets) on Open VMS Itanium 8.3 1H1

Hi,

I am getting virtual memory error while configuring Symantec ESM agent on vms (HP OpenVMS I64 OS,V8.3-1H1) with ESM manager on windows. Please look into the attatched error report file and help me to solve the error.

Thanks in Advance
Manajit.
9 REPLIES
Steven Schweda
Honored Contributor

Re: Installation error of a kit (save sets) on Open VMS Itanium 8.3 1H1

> [...] Symantec [...]

ACCVIO in the vendor's program? Ask the
vendor?
Hein van den Heuvel
Honored Contributor

Re: Installation error of a kit (save sets) on Open VMS Itanium 8.3 1H1

>> I am getting virtual memory error

Welcome to the OpenVMS forum. VMS folks typically talk about a virtual memory issue if there are problems allocating memory.

The application appears to have memory, but tries to access an invalid page (the null page) resulting in that Access Violation.

Seems to me the application overwrote stack space. Specifically the 'Process Status' was filled with a piece of string : "I64F"

Since the program area mentions _Unwind_Resume, it might be trying to recover from an error? Is that 'control file' accessible and of the right type?

>> 16.138.185.164

Are you with HP? Why don't you say so?
Use your internal support mechanisms, and as Hoff already wrote contact the vendor. Immediately, for the benefit of other customers as well as yourself.

hth,
Hein.


ManajitHalder
Occasional Visitor

Re: Installation error of a kit (save sets) on Open VMS Itanium 8.3 1H1

Thanks and Hoff,

Yes I am from HP. We have informed Symentec.

Thanks again for your suggestions.
Hein van den Heuvel
Honored Contributor

Re: Installation error of a kit (save sets) on Open VMS Itanium 8.3 1H1

>> Thanks and Hoff,

Oops, I write Hoff, but it was Steven. Sorry.

Hein van den Heuvel
Honored Contributor

Re: Installation error of a kit (save sets) on Open VMS Itanium 8.3 1H1

That prior reply went out too quick.

You may want to try to help the Symantec folks by giving more context.

I would try $SET WATCH FILE/CLASS=MAJOR
The will show which files it touches.

Or even $SET PROCESS/SSLOG

Hein.



John Gillings
Honored Contributor

Re: Installation error of a kit (save sets) on Open VMS Itanium 8.3 1H1

Odd!

I had a process fail a few weeks ago with:

%SYSTEM-F-ACCVIO, access violation, reason mask=04, virtual address=0000000000000000, PC=0000000000000001, PS=46343649
-SCAN-W-NOMSG, Message number 01317A48

Completely unrelated, except that it was written in C++, and running same OpenVMS version (SCAN-W is almost certainly bogus). Same signature in the PS??

I assumed stack corruption too, but maybe it's an artefact of C++ exception handling?
A crucible of informative mistakes
Hein van den Heuvel
Honored Contributor

Re: Installation error of a kit (save sets) on Open VMS Itanium 8.3 1H1

Good one John!

I searched strings from a bunch of RTLs (DECC$SHARE[P], LIBRTL, LIBOTS for I64F. No luck
Then ran a random C program and use ANAL/SYS from a different session search its memory.
Found two hits in nearby location like:

CTL$AG_CLIDATA+00420

That turned out to be in DCL recall buffers for the process. Duh! :-).

Hein.
John Gillings
Honored Contributor

Re: Installation error of a kit (save sets) on Open VMS Itanium 8.3 1H1

Hein,

Using your STRINGS utility, I found "I64FRGN" in SYS$SHARE:CXXL$LANGRTL, which is at the top of the stack dump. No sign of it in the image analysis.

Looking at the STRINGS output, it's in the same general area as other stuff that looks like error and exception handling.

That makes me think the ACCVIO may be spurious, possibly even a C++ bug in error handling. Maybe the signal array is misaligned (VA looks more like a PS)?

The ACCVIO seems to be coming from an image called REGISTER. Try working out exactly what command it's executing and get a process dump of the failure, independent of the installation attempt. This may give a better picture of what's really going on. Does a SET PROCESS/DUMP prior to executing the script generate a process dump?

That said... it's clearly a bug in the installation script, but if you can gather useful information for the developers, it will hopefully speed up the diagnosis and fix.
A crucible of informative mistakes
ManajitHalder
Occasional Visitor

Re: Installation error of a kit (save sets) on Open VMS Itanium 8.3 1H1

Thanks Steven, Hein and John

I have generated the core dump and send it to Symantec.

Thanks for your quick responses.