Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Invalid HWRPB Errors

 
Swain
Regular Advisor

Invalid HWRPB Errors

We have an Alphaserver 800 5/400 running open vms V6.2-1H3


When I try to boot it, I get

>>>sh boot
Use bootdef_dev instead.
>>>sh bootdef_dev
bootdef_dev dkc0.0.0.13.0
>>>boot dkc0
(boot dkc0.0.0.13.0 -flags 0)
block 0 of dkc0.0.0.13.0 is a valid boot block
reading 1013 blocks from dkc0.0.0.13.0
bootstrap code read in
base = 1d6000, image_start = 0, image_bytes = 7ea00
initializing HWRPB at 2000
initializing page table at 43fce000
initializing machine state
setting affinity to the primary CPU
jumping to bootstrap code
%APB-I-FILENOTLOC, Unable to locate SYSBOOT.EXE
%APB-I-LOADFAIL, Failed to load secondary bootstrap, status = 00000870

halted CPU 0

halt code = 5
HALT instruction executed
PC = 200039dc
warning -- HWRPB is invalid
>>>


I might be wrong, but As per my knowledge, We cannot boot off a VMS 6.2-1H3 CD bcoz it does not have the eco kit.
Should I have any particuler ECO installed on VMS 6.2-1H3 before I boot?

[P.S. I need this system to be DR server for another Alphaserver 1000A 5/400 running v6.2-1H3]

Thanks for your help..

Amaresh
25 REPLIES 25
The Brit
Honored Contributor

Re: Invalid HWRPB Errors

Just a wild suggestion, You could try

P00> boot dkc0 -fl 0,0

Dave
Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

now that you've solved the 'secure console' problem, we're back at the original problem:

A status of 00000870 means: end-of-file.

There seems to be something wrong with SYSBOOT.EXE on that disk.

Did you try to boot from an OpenVMS Operating System CD ? Maybe use a more recent one, if V6.2-1H3 fails...

Volker.
Hoff
Honored Contributor

Re: Invalid HWRPB Errors

OpenVMS Alpha V7.1 is minimally required for AlphaServer 800. There is no ECO. Upgrade. Or replace the box with a box that runs V6.2-1H3.

http://h71000.www7.hp.com/openvms/hw_supportchart.html


Andy Bustamante
Honored Contributor

Re: Invalid HWRPB Errors

A used 1000 is very affordable. Or you may consider an emulated system, http://www.stromasys.ch/products/.


If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
Swain
Regular Advisor

Re: Invalid HWRPB Errors

Hi Volker,

Will there be any inconvenience (in terms of data descrepancy or file systems)if I install v8.3 and make it the DR box for system running v6.2-1H3?

Thanks,
Amaresh
Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

OpenVMS always had a very high goal: upward compatibility !

Going from V6.2-1H3 to V8.3 is a big step. OpenVMS itself should be fine, although you can't upgrade directly and have to do a couple of upgrades inbetween. Or directly install V8.3.

Whether your applications and other layered products do run with V8.3 is something we can't know.

For a DR site, it would probably be wise to use the SAME OpenVMS version as on the primary site ! Just try to get an Alpha, which works with V6.2-1H3. The CHARON-AXP emulators may be a good choice...

Volker.

PS: Disclaimer: we are a CHARON reseller.
Swain
Regular Advisor

Re: Invalid HWRPB Errors

I am planning to make it v7.2

but, Is there any chance of getting v6.2-1H3 on the Alphaserver 800?

I booted the system from v6.2-1H3 CD and got the following

>>>boot dka400
(boot dka400.4.0.5.0 -flags 0)
block 0 of dka400.4.0.5.0 is a valid boot block
reading 1004 blocks from dka400.4.0.5.0
bootstrap code read in
base = 1d6000, image_start = 0, image_bytes = 7d800
initializing HWRPB at 2000
initializing page table at 43fce000
initializing machine state
setting affinity to the primary CPU
jumping to bootstrap code



OpenVMS (TM) Alpha Operating System, Version V6.2-1H3



Please enter date and time (DD-MMM-YYYY HH:MM)
Please enter date and time (DD-MMM-YYYY HH:MM) 29-JAN-2010 10:49

$! Copyright (c) 1995 Digital Equipment Corporation. All rights reserved.



Installing required known files...

Configuring devices...

[c 7 [255;255H [6n 8 >

****************************************************************

You can install or upgrade the OpenVMS Alpha operating system
or you can install or upgrade layered products that are included
on the OpenVMS Alpha operating system CD-ROM.

You can also execute DCL commands and procedures to perform
"standalone" tasks, such as backing up the system disk.

Please choose one of the following:

1) Install or upgrade OpenVMS Alpha Version V6.2-1H3
2) List layered product kits that this procedure can install
3) Install or upgrade layered product(s)
4) Execute DCL commands and procedures
5) Shut down this system

Enter CHOICE or ? to repeat menu: (1/2/3/4/5/?) 4



WARNING --

The normal VMS startup procedure has not executed.
Some commands and utilities will not work as documented.


Enter DCL commands -- Enter "LOGOUT" when done.
When you enter "LOGOUT" a message will be displayed saying
"Process SA_STARTUP_DCL logged out at
Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

the fact, that you can boot the OpenVMS V6.2-1H3 CD on your AlphaServer 800 5/400 does not imply, that it's supported, but that it should at least also boot from your DKC0 disk !

Can you MOUNT/OVER=ID/NOWRITE DKC0: when booted from CD and just try an ANAL/DISK DKC0: ?

Then maybe a DIR DKC0:[*...]SYSBOOT.EXE/FULL ?

Volker.
Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

this may explain it all:

http://h71000.www7.hp.com/wizard/wiz_1502.html

Volker.
Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

it may be a question of the SCSI adapter configuration. There have been AlphaServers 800 around, which did work with V6.2-1H3.

If you have an integrated UltraSCSI controller, then you may need V7.1-1H1 or ALPSCSI patches for V6.2-1H3.

Volker.
Swain
Regular Advisor

Re: Invalid HWRPB Errors

$$$ MOUNT/OVER=ID/NOWRITE DKC0:
$$$ sh dev dkc0
Device Device Error Volume Free Trans Mnt

Name Status Count Label Blocks Count Cnt

DKC0: Mounted alloc 0 ALPHAVMS015 6965775 1 1

$$$ ANAL/DISK DKC0:

Analyze/Disk_Structure for _DKC0: started on 29-JAN-2010 12:07:41.50

%ANALDISK-I-OPENQUOTA, error opening QUOTA.SYS
-SYSTEM-W-NOSUCHFILE, no such file
%ANALDISK-W-BADHEADER, file (6,7,1)
invalid file header
-ANALDISK-I-FIDNUM_ZERO, file number zero but not a valid deleted header
-ANALDISK-I-INVHEADER_BUSY, invalid file header marked "busy"
in index file bitmap
%ANALDISK-W-BADDIRENT, invalid file identification in directory entry
[SYS0.SYSCOMMON.SYSMGR]AMARESHS.DIR;1
-ANALDISK-I-BAD_DIRHEADER, no valid file header for directory
%ANALDISK-W-BADDIRENT, invalid file identification in directory entry
[SYS0.SYSCOMMON.SYSMGR]AMS$RESULT.CFG;1
.
.
.
.
$$$ DIR DKC0:[*...]SYSBOOT.EXE/FULL

Directory DKC0:[SYS0.SYSCOMMON.SYSEXE]

SYSBOOT.EXE;1 File ID: (14671,131,0)
Size: 647/648 Owner: [1,4]
Created: 26-APR-1996 12:45:10.64
Revised: 14-MAY-1996 14:16:58.56 (15)
Expires:
Backup:
Effective:
Recording:
File organization: Sequential
Shelved state: Online
File attributes: Allocation: 648, Extend: 0, Global buffer count: 0
No version limit, Contiguous best try, MoveFile disabled
Record format: Fixed length 512 byte records
Record attributes: None
RMS attributes: None
Journaling enabled: None
File protection: System:RWED, Owner:RWED, Group:RE, World:RE
Access Cntrl List: None

Total of 1 file, 647/648 blocks.

Directory DKC0:[VMS$COMMON.SYSEXE]

SYSBOOT.EXE;1 File ID: (14671,131,0)
Size: 647/648 Owner: [1,4]
Created: 26-APR-1996 12:45:10.64
Revised: 14-MAY-1996 14:16:58.56 (15)
Expires:
Backup:
Effective:
Recording:
File organization: Sequential
Shelved state: Online
File attributes: Allocation: 648, Extend: 0, Global buffer count: 0
No version limit, Contiguous best try, MoveFile disabled
Record format: Fixed length 512 byte records
Record attributes: None
RMS attributes: None
Journaling enabled: None
File protection: System:RWED, Owner:RWED, Group:RE, World:RE
Access Cntrl List: None

Total of 1 file, 647/648 blocks.

Grand total of 2 directories, 2 files, 1294/1296 blocks.
$$$

Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

try a diagnostic boot and capture the output:

>>> b -fl 0,30000 DKC0

This should give very detailled information about the disk IOs of APB (Alpha Primary Bootstrap) trying to load SYSBOOT.EXE...

Volker.
Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

please find attached the full diagnostic boot output from an OpenVMS V6.2-1H3 successful load of SYSBOOT.EXE

Use it for reference to compare it with your failing boot.

Volker.
Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

please also note:

%ANALDISK-W-BADHEADER, file (6,7,1)
invalid file header

This is a very disturbing message ! FID (6,6,0) should be the File ID of VOLSET.SYS and it should NEVER change. Could this disk have been mounted into some volume set by operator error ?

Volker.
Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

I've analyzed the sequence of Boot QIOs when loading SYSBOOT.EXE. This will allow you to immediately diagnose, which boot QIO fails and which file or file hdr is corrupted:

%APB-I-BOOTVOL, Mounting boot volume
Boot QIO: LEN=0200 LBN=00000001 ! Home block
Boot QIO: LEN=0200 LBN=00049430 ! INDEXF.SYS File Hdr
Boot QIO: LEN=0200 LBN=00049433 ! 000000.DIR File Hdr
Boot QIO: LEN=2800 LBN=00000006 ! 000000.DIR contents
%APB-I-SYSROOT, System root is [SYS0.]
Boot QIO: LEN=0200 LBN=0004943A ! [000000]SYS0.DIR File Hdr
Boot QIO: LEN=0200 LBN=0004943A ! [000000]SYS0.DIR File Hdr
Boot QIO: LEN=0200 LBN=00064B30 ! [000000]SYS0.DIR contents
Boot QIO: LEN=0200 LBN=00049C81 ! [SYS0]SYSEXE.DIR File Hdr
Boot QIO: LEN=0200 LBN=00029610 ! [SYS0]SYSEXE.DIR contents
Boot QIO: LEN=0200 LBN=0004943B ! [SYS0]SYSCOMMON.DIR File Hdr
Boot QIO: LEN=0400 LBN=00064B42 ! [SYS0]SYSCOMMON.DIR contents
Boot QIO: LEN=0200 LBN=000495BE ! [SYS0.SYSCOMMON]SYSEXE.DIR File Hdr
Boot QIO: LEN=01E00 LBN=0006CEC4 ! [SYS0.SYSCOMMON]SYSEXE.DIR Contents
Boot QIO: LEN=0200 LBN=00049671 ! [SYS0.SYSCOMMON.SYSEXE]SYSBOOT.EXE File Hdr
%APB-I-LOADFILE, Loading [SYS0.SYSCOMMON.SYSEXE]SYSBOOT.EXE;1
Boot QIO: LEN=0200 LBN=000790A4 ! [SYS0.SYSCOMMON.SYSEXE]SYSBOOT.EXE Image Hdr
Boot QIO: LEN=50A00 LBN=000790A6 ! [SYS0.SYSCOMMON.SYSEXE]SYSBOOT.EXE contents
%APB-I-SECBOOT, Transferring to secondary bootstrap

Volker.
Swain
Regular Advisor

Re: Invalid HWRPB Errors

Hi,

what is the feasibility of building a DR on Charon-AXp?

Thanks,
Amaresh
Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

using a CHARON-AXP for the DR site may work well. The CPU performance will even be better than with the older Alphas (e.g. AlphaServer 800 5/400). V6.2-1H3 is supported. You just need to check, if there are any 'unusual' interface cards in the existing Alpha - this would be unusual, but should be checked.

Volker.

Disclaimer: Invenate is a CHARON reseller.
Steve Reece_3
Trusted Contributor

Re: Invalid HWRPB Errors

If this is a DR system, preumably the live system (the 1000A 5/400) has the UltraSCSI patch installed on it? If this is the case, why not restore the system disk off the live box onto the DR, then rename the system to have the identity and update the licenses so that they reflect the DR system?

For the restore, it won't matter what version of VMS you run the restore with as long as the system is supported by it.

Steps for renaming the system will be found in the VMS FAQ which I'm sure is on Hoff's website. Disabling the live system's licenses is a case of running the LICENSE utility, same for reloading the DR system's own licenses.

If this doesn't work then the AlphaServer 800 really doesn't fulfil the needs of a DR system...

Steve
Swain
Regular Advisor

Re: Invalid HWRPB Errors

Volker,

Charon option looks convincing.

Steve,

>>UltraSCSI patch installed on it?

How can I get details of patch?

Thanks,
Amaresh

Bill Hall
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

The ECOs for VMS 6.2 were VMSINSTAL kits and the installation was logged in SYS$UPDATE:VMSINSTAL.HISTORY. A quick search of the file will find installed SCSI ECOs, if any.

$search sys$update:vmsinstal.history ALPSCSI,6.2/match=and

I don't know which specific SCSI ECO Steve was referring to, but you should be able to at least find the lastest ECOs at the following url:

ftp://ftp.itrc.hp.com/openvms_patches/alpha/V6.2X

Bill
Bill Hall
Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

you could boot from the OpenVMS V6.2-1H3 CD, mount the DKC0 disk and you could then run ANAL/DISK DKC0: - this proves, that you're NOT having an Ultra SCSI adapter, which could only be supported via an ALPSCSI patch. You could not have a patch installed on the OpenVMS V6.2-1H3 CD (assuming it's the original CD).

Please provide the boot -fl 0,30000 console output as previously requested. This should allow further analysis of the boot failure.

You can find the list of installed patches on DKC0:[VMS$COMMON.SYSUPD]VMSINSTAL.HISTORY - a text file.

Volker.
Swain
Regular Advisor

Re: Invalid HWRPB Errors

Thanks, Bill,Volker!

$ search sys$update:vmsinstal.history ALPSCSI,6.2/match=and
%SEARCH-I-NOMATCHES, no strings matched

This is a critical production server and I need some approval to get the boot sequence. It'll take time.

Thanks,
Amaresh
Volker Halle
Honored Contributor

Re: Invalid HWRPB Errors

Amaresh,

$ search sys$update:vmsinstal.history ALPSCSI,6.2/match=and
%SEARCH-I-NOMATCHES, no strings matched

WHERE did you LOOK ???

With this command, you can only have looked for this patch on a running system - not on the non-bootable DKC0 disk of your AlphaServer 800.

Volker.
Swain
Regular Advisor

Re: Invalid HWRPB Errors

Hi Volker,
Yes, I checked on running system.

If I go for CHARON, which link I can look for price options and compatibility?

Thanks,
Amaresh