Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Issues with showing/deleting name_tables in lnm$cluster

SOLVED
Go to solution
Chris D Cook
Occasional Advisor

Issues with showing/deleting name_tables in lnm$cluster

I am working with logicals on a 2-node cluster, and I need both nodes to be able to have access to the logical.

To share them, they have to be added to the lnm$cluster table (this is the only way, correct???). The issue is that things are not working with lnm$cluster the same as they are with other tables:


This works:

NODE1>create/name_table/parent_table=lnm$process_directory proc_table1
NODE1>show log/table=lnm$process_directory proc_table1
"PROC_TABLE1" [table] = "" (LNM$PROCESS_DIRECTORY)
NODE1>define/table=proc_table1 logical1 "value1"
NODE1>show log/table=proc_table1 logical1
"LOGICAL1" = "value1" (PROC_TABLE1)
NODE1>deassign /table=proc_table1 logical1
NODE1>deassign /table=lnm$process_directory proc_table1


This does not:

NODE1>create/name_table/parent_table=lnm$cluster clus_table1
NODE1>show log/table=lnm$cluster clus_table1
%SHOW-S-NOTRAN, no translation for logical name CLUS_TABLE1
NODE1>define/table=clus_table1 logical1 "value1"
NODE1>show log/table=clus_table1 logical1
"LOGICAL1" = "value1" (CLUS_TABLE1)
NODE1>deassign /table=clus_table1 logical1
NODE1>deassign /table=lnm$cluster clus_table1
%SYSTEM-F-NOLOGNAM, no logical name match
NODE1>create/name_table/parent_table=lnm$cluster clus_table1
%DCL-I-TABEXIST, CLUS_TABLE1 already exists - not superseded


This may be a hint: If I do the same thing with lnm$process, I get the same error. I have to use lnm$process_directory (which points to same table as lnm$process) in order to do the deassign. However, I have not had success using lnm$cluster_directory (I don't think this is defined by the system.)

Thanks in Advance,
Chris
7 REPLIES
Robert Brooks_1
Honored Contributor

Re: Issues with showing/deleting name_tables in lnm$cluster

What version of VMS? V8.2 introduced the /CLUSTER_SYSTEM qualifier for both the DEFINE and DEASSIGN verbs.

-- Rob
Chris D Cook
Occasional Advisor

Re: Issues with showing/deleting name_tables in lnm$cluster

V7.3-2
Chris D Cook
Occasional Advisor

Re: Issues with showing/deleting name_tables in lnm$cluster

Sorry Robert, intended to give you points for that. Thanks for the tip about VMS version. Post again and I'll get your points to you.
Robert Brooks_1
Honored Contributor

Re: Issues with showing/deleting name_tables in lnm$cluster

I would use LNM$SYSCLUSTER as the parent table, not LNM$CLUSTER.

I'm not too concerned about the points; I won't
clutter this otherwise useful board with annoying posts about the failure to assign points.

-- Rob
Chris D Cook
Occasional Advisor

Re: Issues with showing/deleting name_tables in lnm$cluster

Unfortunately, that did not do the trick. lnm$cluster and lnm$syscluster apparently point to the same table since I get an error when trying to create a table in lnm$syscluster that I already created in lnm$cluster.

I also tried lnm$syscluster_table and lnm$syscluster_directory to no avail.
Jim_McKinney
Honored Contributor
Solution

Re: Issues with showing/deleting name_tables in lnm$cluster

$ create/name_table/parent_table=lnm$cluster clus_table1
$ show log/table=lnm$system_directory CLUS_TABLE1
"CLUS_TABLE1" [table] = "" (LNM$SYSTEM_DIRECTORY)
$ define/table=clus_table1 logical1 "value1"
$ show log/table=clus_table1 logical1
"LOGICAL1" = "value1" (CLUS_TABLE1)
$ deassign /table=clus_table1 logical1
$ deassign/table=lnm$system_directory CLUS_TABLE1
$ create/name_table/parent_table=lnm$cluster clus_table1
Chris D Cook
Occasional Advisor

Re: Issues with showing/deleting name_tables in lnm$cluster

Works perfectly.

Thanks Jim, Robert