HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

 
SOLVED
Go to solution

It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

One would think that the person who sold us the license would also sell us the software if it is required.

What I have read of the online documentation so far is that there is a D W MOTIF V1.2-5 CD ROM. I assume that I should get this? How do I get it?

It seemed mysterious to me when I was upgrading from one version of OpenVMS to another version that all I had to do was to type in some information from an official license document. But it worked. And then when I was going from one version of MOTIF to another -- or some simular process -- all I had to do was to also type in some information. But now I see that this does not work the same way.

(see www.gelsana.com/huh.htm )
34 REPLIES
Robert Gezelter
Honored Contributor

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

Bill,

What version of OpenVMS are you dealing with on this machine. On all the recent versions that I can recall, MOTIF was packaged, along with the networking products and some others, on the Base OpenVMS CDROM, not a separate CDROM.

- Bob Gezelter, http://www.rlgsc.com

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

OpenVMS7.2-1

---------

Here is how I conclude that I do not have MOTIF.

A GUI product by a third party looks for DECW$TERMINALSHR12.EXE and cannot find it:

%DCL-W-ACTIMAGE, error activating image DECW$TERMINALSHR12

-CLI-E-IMAGEFNF, image file not found AS800$DKA0:[SYS0.SYSCOMMON.][SYSLIB]DECW$TERMINALSHR12.EXE;

Now, the OpenVMS online document for MOTIF mentions this file, DECW$TERMINALSHR12.EXE. There is also mention of an installation process on http://h71000.www7.hp.com/doc/732final/documentation/pdf/dw_v131_instal_gd.PDF

Just to be sure, I did a system search for DECW$TERMINALSHR12.EXE and I came up empty:

$ dir [...]decw$terminal*.*
%DIRECT-W-NOFILES, no files found
$
$ dir [...]decw$term*.*
%DIRECT-W-NOFILES, no files found
$ show def
SYS$SYSDEVICE:[000000]
$
Eberhard Wacker
Valued Contributor

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

If the system was never installed/upgraded with a YES to the Motif question, then the files are not on the system disk.

One link to the Compaq Manual with installation instructions of these old version of Motif V1.2-5 under VMS V7.2-1:
http://tigger.stcloudstate.edu/~tigger/openvms/72final/6538/6538pro_002.html#pcsi_install
Maybe also on the HP web, I did not look .

And keep in mind: the only actual supported VMS 7 version is OpenVMS V7.3-2 (the prior version support of V7.2-2 has ended 1 year ago) !!!

Cheers,
EW
Eberhard Wacker
Valued Contributor

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

Motif versions:
1.2-6, valid for VMS V7.2-*
1.3 starts with VMS V7.3-1
1.3-1 starts with VMS V7.3-2
http://h71000.www7.hp.com/doc/732final/6434/6434_PROfile.HTML
1.5 starts with VMS V8.2

Eberhard Wacker
Valued Contributor

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

Hi Bill,
now back to the "how to get" theme of your entry:
1) all of your statements look very curious for me !
2) is your contractor a legally HP one ?
If so why he can give you not the source media ?!!

Now the things as they are as far as I'm aware of them:
if you buy an OS or a layered product at HP (formerly Compaq, formerly DEC) then you have bought the right to use a special version on a special hardware size. If you want to participate in future updates then you have to pay for a service contract.

If you do have a valid service contract (with HP itself or one if its legalized partners) then this all should be no problem: there are several ways to get the software and you even get the password for a web side to download the software (as long as you have no firewall preventing this as it is at my side).

Cheers,
EW
Veli Körkkö
Trusted Contributor

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

How about

$ set terminal/width=132
$ product show product /full
$ type sys$update:vmsinstal.history

so we could check whether you have the software or not. The referenced files does appear to exist on pretty all my various installations
where I do have motif installed

_veli
Robert Gezelter
Honored Contributor

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

Bill,

As Eberhard Wacker pointed out, while MOTIF is physically included on the CDROM, it is an optional component.

Presuming that your system is a server, as opposed to a workstation, it is not uncommon to find MOTIF not installed, although I have not chosen that option for many years, since disk sizes started dramatically exanding.

If this is so, you can install MOTIF by mounting the CDROM, locating the kit, and doing a product installation of the kit, per the release notes.

- Bob Gezelter, http://www.rlgsc.com

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

For Eberhard: I assure you, I have a legal copy of all the software. As Robert Gezelter has pointed, I must not have installed MOTIF when I first installed / upgraded the OS.

I will be doing this now as the documentation CD insturcts.

I must have forgotten that I decided not to included MOTIF and had thought at that time that I would do it later when it was needed. My excuse for not remembering it now is lack of sleep and making a simple human mistake.



For Veli Körkkö:
$ set terminal/width=132
$ product show product /full
----------------------------------- ----------- ------------ ----------------------------------- -----------------------------------
PRODUCT KIT TYPE STATE MAINTENANCE REFERENCED BY
----------------------------------- ----------- ------------ ----------------------------------- -----------------------------------
DEC AXPVMS DECNET_OSI V7.2-1 Full LP Installed DEC AXPVMS OPENVMS V7.2-1
DEC AXPVMS OPENVMS V7.2-1 Platform Installed
DEC AXPVMS TCPIP V5.0-10 Full LP Installed DEC AXPVMS TCPIP_ECO V5.0-113 DEC AXPVMS OPENVMS V7.2-1
DEC AXPVMS VMS V7.2-1 Oper System Installed DEC AXPVMS DECNET_OSI V7.2-1
DEC AXPVMS OPENVMS V7.2-1
DEC AXPVMS TCPIP V5.0-10
DEC AXPVMS TCPIP_ECO V5.0-113
TERADYNE AXPVMS AX202 V1.0 Full LP Installed
----------------------------------- ----------- ------------ ----------------------------------- -----------------------------------

5 items found

VMSINSTAL history file DISK$ALPHASYS:[VMS$COMMON.][SYSUPD]VMSINSTAL.HISTORY;1 contains additional information
$ type sys$update:vmsinstal.history
VMSINSTAL Product Installation History File

S = Success F = Failure NA = Not Applicable

------------------------------------------------------------------------------------------------------------------------
Product Information | Installation Information
------------------------------------------------------------|-----------------------------------------------------------
Name | Mnemonic | Version | Date | Status| IVP | Node | Installer
------------------------------------------------------------|-----------------------------------------------------------
| SUP | 18.0 | 29-JUN-2005 | F | NA | AS800 | SYSTEM
| SUP | 18.0 | 29-JUN-2005 | S | NA | AS800 | SYSTEM
$


Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

I have been trying to use install MOTIF by using the system disk I have for OpenVMS V7.2-1.

According to the accompanying documentation (and my interpretation of this documentation), this should be done by typing :

$ @SYS$UPDATE:VMSINSTAL DWMOTIFVAXU5012 AS800$DKA400 -
_$ OPTIONS N, AWD=DKA0

VMSINSTAL started but it soon returned this error:

* Are you satisfied with the backup of your system disk [YES]?

%VMSINSTAL-E-NOPRODS, None of the specified products were found.

So I did a searh on the CDROM for any MOTIF installation system:

$ SET DEF AS800$DKA400:[000000]
$ DIR [...]DWMOTIF*.*

Directory AS800$DKA400:[000000]

DWMOTIF_ALPHA125.DIR;1

Total of 1 file.

Directory AS800$DKA400:[KITS]

DWMOTIF_ALPHA125_KIT.DIR;1

Total of 1 file.

Grand total of 2 directories, 2 files.

But when I try dwmotif_alpha125 instead, I get the same results:

$ set def sys$sysdevice
$
$ @SYS$UPDATE:VMSINSTAL DWMOTIF_ALPHA125 AS800$DKA400 OPTIONS N, AWD=DKA0

OpenVMS AXP Software Product Installation Procedure V7.2-1


It is 15-AUG-2005 at 15:18.

Enter a question mark (?) at any time for help.

* Are you satisfied with the backup of your system disk [YES]?

%VMSINSTAL-E-NOPRODS, None of the specified products were found.


VMSINSTAL procedure done at 15:18


$
I have tried a number of variations but no success so far.
Ian Miller.
Honored Contributor

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

Try specifying the directoring containing the .A, .B etc files and replace xxx by the filename of the .A file (without the .A)
$ @SYS$UPDATE:VMSINSTAL xxxxx AS800$DKA400:[DWMOTIF_ALPHA125_KIT] OPTIONS N, AWD=DKA0

____________________
Purely Personal Opinion

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

I have been trying a few variations based on that last suggestion for "xxxx" but nothing has worked so far. Here is the contents of the directory, in case this might help in suggesting an option:

Directory AS800$DKA400:[000000.KITS.DWMOTIF_ALPHA125_KIT]

$WORK.DIR;1 CDA$LIBRARY.DIR;1 CDE$DEFAULTS.DIR;1 DEC-AXPVMS-DWMOTIF-V0102-5-1.PCSI$DESCRIPTION;1
DEC-AXPVMS-DWMOTIF-V0102-5-1.PCSI$TLB;1 DECW$BOOK.DIR;1 DECW$DEFAULTS.DIR;1
DECW$INCLUDE.DIR;1 SYSCBI.DIR;1 SYSEXE.DIR;1 SYSHLP.DIR;1
SYSLIB.DIR;1 SYSMGR.DIR;1 SYSMSG.DIR;1 SYSTEST.DIR;1
SYSUPD.DIR;1 VUE$LIBRARY.DIR;1 XDPS$INCLUDE.DIR;1



--------------

$ @SYS$UPDATE:VMSINSTAL DWMOTIF_ALPHA125 as800$DKA400:[kits.dWmotif_alpha125_KIT] OPTIONS N, AWD=DKA0

OpenVMS AXP Software Product Installation Procedure V7.2-1


It is 15-AUG-2005 at 17:50.

Enter a question mark (?) at any time for help.

* Are you satisfied with the backup of your system disk [YES]?

%VMSINSTAL-E-NOPRODS, None of the specified products were found.

-----------------

$ @SYS$UPDATE:VMSINSTAL DEC-AXPVMS-DWMOTIF-V0102-5-1 as800$DKA400:[kits.dWmotif_alpha125_KIT] OPTIONS N, AWD=DKA0

OpenVMS AXP Software Product Installation Procedure V7.2-1


It is 15-AUG-2005 at 17:53.

Enter a question mark (?) at any time for help.

* Are you satisfied with the backup of your system disk [YES]?

%VMSINSTAL-E-NOPRODS, None of the specified products were found.
Martin Vorlaender
Honored Contributor

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

Bill,

it'd seem to me that installing DWMOTIF_VAX_U5012 on your AlphaServer is the wrong way to go.

Re: the CD disk structure: for every layered product, there is a top level directory (i.e. [DWMOTIF_ALPHA125]) and an alias directory entry in [KITS] named *_KIT - but they're really the same directory.

I, too, am a little confused by the directory's contents. Normally, it should contain .A, .B ... (usable with SYS$UPDATE:VMSINSTAL.COM) or DEC-AXPVMS--*.PCSI (usable with the PRODUCT command) files. This seems to be not the case with DECwindows in OpenVMS V7.2-1.

The file [DWMOTIF_ALPHA125.DOCUMENTATION]DW_V125_INSTAL_GD.TXT contains an installation guide. After describing all the requirements to be met, it says the installation commands are

$ DEFINE PCSI$SOURCE DKA400:[DWMOTIF_ALPHA125] ! wrong in the docs !
$ PRODUCT INSTALL DWMOTIF

HTH,
Martin
Ian Miller.
Honored Contributor
Solution

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

that directory appears to contain a PCSI kit in reference format so
$ PRODUCT INSTALL DWMOTIF/SOURCE=as800$DKA400:[kits.dWmotif_alpha125_KIT]
____________________
Purely Personal Opinion

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

Execution phase starting ...

The following product will be installed to destination:
DEC AXPVMS DWMOTIF V1.2-5 DISK$ALPHASYS:[VMS$COMMON.]

Portion done: 0%...10%...20%

(so far)

I am writing now to give thanks.

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

Oh no.
I spoke too soon:

Portion done: 0%...10%...20%...30%...40%...50%...60%...70%
%PCSI-E-READERR, error reading AS800$DKA400:[KITS.DWMOTIF_ALPHA125_KIT.][SYSHLP.EXAMPLES.DECW]XMLIST.EXE;1
-SYSTEM-F-PARITY, parity error
-SYSTEM-W-PARITY, parity error
Portion done: 80%

It is still moving along. But is this something I need to do somethig about?

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

The following product has been installed:
DEC AXPVMS DWMOTIF V1.2-5 Layered Product

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

How do I test to see if it works?
Martin Vorlaender
Honored Contributor

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

>>>
How do I test to see if it works?
<<<

If you have a graphics card in your system, there should be a process named DECW$SERVER_0. An attached monitor should show the login screen.

Otherwise, you should be able to redirect X to some system running an X server (e.g. a VMS with DECwindows, Linux, Windows with Refelction or Exceed). If you need help with this one, please ask specifically.

cu,
Martin
Ian Miller.
Honored Contributor

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

that error appears to indicate it failed to copy a program from the examples area due to a parity error - this may be due to bad media.
As the kit is in reference format then you can do a ANAL/RMS on that file in the kit or a ANAL/DISK/READ on the whole CD or live without that example program.
____________________
Purely Personal Opinion

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

Well, rebooting the system seemed to be the next required step.

But now, after the system ran through a few processes, I have a blank screen.

I have rebooted several times in the past with no problems. This is the first time something like this has happened.

Help, anyone?
Ian Miller.
Honored Contributor

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

Do a conversational boot and set the system parameter WINDOW_SYSTEM to 0 to prevent startup of DW then you should be able to get in.
____________________
Purely Personal Opinion

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

In ths spirit of "There are No Stupid Questions" let me ask: How do I do that? How do I perform a conversational boot and how do I set the system parameter, WINDOW_SYSTEM to zero?

I gave it a shot with this:

>>> set WINDOW_SYSTEM 0
environment variable WINDOW_SYSTEM created
>>> set system parameter WINDOW_SYSTEM 0
envoronment variable system created
>>>B DKA0

but I still eventually came to a blank screen.

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

is it:
>>>boot /window_system:0
?

Re: It appears that, although I have the LICENSE for MOTIF V1.2-5, I don't actually have the software.

OpenVMS FAQ is a useful document and I have gotten a little closer now to fixing the problem.

On Page 5-6 the Emergency (Convesational) System Startup procedure is described.

At the console prompt (the three chevrons) I have typed:
b -flags 0,1
and this has successfully brought me to the SYSBOOT prompt.

Following the FAQ documentation further, I typed:
SET/STARTUP OPA0:
SET WINDOW_SYSTEM 0
SET WRITESYSPARAMS 0
CONTINUE

And then at the $ prompt I typed the following two DCL commands:
$ SPAWN
$ @SYS$SYSTEM:STARTUP

I have been able to edit the DECW$STARTUP.COM
file and put an
$ EXIT
at the beginning of the file by typing:

$ SET DEF SYS$STARTUP
$ EDIT/EDT DECW$STARTUP.COM

*INSERT
$EXIT

*EXIT

And now I am at a dollar prompt. I will stop now while I am ahead...