Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Java 1.4.1/1.4.2 problems

Cliff McKeithan
Occasional Visitor

Java 1.4.1/1.4.2 problems

Anytime I attempt to run a Java program that uses the AWT, it immediately fails with a subscript out of range (-1) exception. The problem only exists using 1.4.1 and 1.4.2 - if I run the exact same program with 1.3 or earlier, it runs just fine.

I am using OpenVMS 7.3-1, with all the required patches per the installation instructions for 1.4.1 and 1.4.2.

Thanks for the help!
Cliff
5 REPLIES
Martin P.J. Zinser
Honored Contributor

Re: Java 1.4.1/1.4.2 problems

Hello Cliff,

just installed 1.4.2-1 on my 7.3-2 system. Fired up a Java program with graphics (see
http://zinser.no-ip.info/vms/sw/logo.htmlx), works without any problem. Might be a problem with your application. Does the same happen with a "Hello World" type of AWT program?

Greetings, Martin
Cliff McKeithan
Occasional Visitor

Re: Java 1.4.1/1.4.2 problems

Martin,
The problem is there for even the smallest HelloWorld app. I can't even run any of the example AWT programs fielded with Java.
Cliff
Martin P.J. Zinser
Honored Contributor

Re: Java 1.4.1/1.4.2 problems

Hello Cliff,

in that case it looks like your Java installation is broken. Two possibilities: The actual on-disk installation is broken (pcsi remove followed by a pcsi install should take care of this), or your setup somehow got messed. Check the output of sh log *java* and sh sym j* for any occurances of Java components not pointing to the 141 or 142 installation directories.

Greetings, Martin
Infrastructure Midrange
Occasional Advisor

Re: Java 1.4.1/1.4.2 problems

Hello Cliff,

have a close look on your process parameter (UAF settings). I've had also problems which al releid on those settings. (I don't know exactly anymore but there must be a statement in the release notes about this...)

Kind regards, Luitzen
Willem Grooters
Honored Contributor

Re: Java 1.4.1/1.4.2 problems

Cliff,
It may not cause your porblem but just in case: are you sure _all_ files in the JAVA 1.4.x environment are STREAM_LF?
Willem Grooters
OpenVMS Developer & System Manager