HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

Java 6 update patch for OpenVMS when ?

 
SOLVED
Go to solution
Toine_1
Regular Advisor

Java 6 update patch for OpenVMS when ?

Hi,

Does anyone know when HP will release a new patch/ECO for JAVA 6 on OpenVMS?

Oracle/Sun release often bug fixes.
I also would like to see that theses fixes are also implemented on the Java 6 on OpenVMS when applicable of course.

/Toine
13 REPLIES
Rick Retterer
Respected Contributor

Re: Java 6 update patch for OpenVMS when ?

Toine,
The OpenVMS Java Team do release updates to the Java 6 version at semi-regular intervals, however just not as frequent as what Sun/Oracle does.

Is there a specific fix or a specific problem that you are concerned about that you are looking to have fixed?

If so, have you logged a Software Support Case with the OpenVMS Java Support team yet?

I'd like to suggest, that if you have concerns about specific bug fixes for Java, your quickest way to get a response is to log a Software Support Case with the OpenVMS Java Support team. That way you will be given a software support case number that you can use to track the issue you are concerned about, until it gets addressed, or at least until you get a response from Java Support as to when your specific issue will be addressed.

Cheers,
Rick Retterer


- Rick Retterer



Toine_1
Regular Advisor

Re: Java 6 update patch for OpenVMS when ?

Thanks for th einfo.
I have logged a call at HP for the problem

(See attachment:)


#
# An unexpected error has been detected by Java Runtime Environment:
#
# Internal Error (JR:[hotspot.src.share.vm.runtime]safepoint.cpp;1, 701), pid=1376308035, tid=114815488
#
# Java VM: Java HotSpot(TM) Server VM (1.6.0-1 11/09/2009-17:30 IA64 (c2) mixed mode)
#
# Error: Illegal threadstate encountered: 4
# An error report file with more information is saved as hs_err_pid1376308035.log
#
# Please report this error to HP customer support.
#

/Toine
Rick Retterer
Respected Contributor

Re: Java 6 update patch for OpenVMS when ?

Toine,
Perfect. This way the problem you are encountering will get individual attention.

Hang on to the caseid that they gave to you, so that you can keep track of what is going on with the case as it progresses throughout the system.

Also, thanks for sharing the problem information with us. Looks to be a very interesting problem.

Cheers,
Rick Retterer

- Rick Retterer



Rick Retterer
Respected Contributor

Re: Java 6 update patch for OpenVMS when ?

Toine,
Ask and you shall receive...

A new version of Java has just been released last night to the OpenVMS community.

REF: http://h18012.www1.hp.com/java/documentation/1.6.0/ivms/docs/release_notes.html#intro

I do not know if it addresses the issues you have outlined yet or not. However, the person working your case at the customer support center will be able to advise you on this.

Cheers,
Rick
- Rick Retterer



Toine_1
Regular Advisor

Re: Java 6 update patch for OpenVMS when ?

Hi,

According to HP this is a Rdb problem.
Well I will try Oracle to get this solved.

Regards,

Toine
Rick Retterer
Respected Contributor

Re: Java 6 update patch for OpenVMS when ?

Toine,
Ok. Thank you for the follow-up. I'm glad that you were able to get your case logged in with HP Support and they were able to get you a timely response.

This forum is great for things like programming issues, and general questions, but for the problem you were having, and the level of information you were seeking, it's best to take advantage of your support contract with HP and log a call with the Java support team. You might say that I know them personally, and they are a great group of folks who are dedicated to helping folks like yourself with your Java issues.

Take Care, and thanks again for the follow-up.

Rick
- Rick Retterer



Toine_1
Regular Advisor

Re: Java 6 update patch for OpenVMS when ?



I have upgraded to JAVA 6.0-2But now I get this error in my application does anyone knows what this means.

java.lang.UnsatisfiedLinkError: /java$fontmanager_shr: Last error code from dlsym was: 1278162
%LIB-E-ACTIMAGE, error activating image DSA240:[SYS0.SYSCOMMON.][SYSLIB]DECW$XEXTLIBSHR.EXE
-LOADER-E-BADSVINDX, symbol vector index is too large

Thanks

/Toine
Steven Schweda
Honored Contributor

Re: Java 6 update patch for OpenVMS when ?

> [...] does anyone knows what this means.

I'll assume that that's a question?

help /mess BADSVINDX

I know nothing, but it sounds as if you're
mixing together incompatible pieces.
Mario Dhaenens
Frequent Advisor

Re: Java 6 update patch for OpenVMS when ?

Hello,

It looks like the JVM 6.0-2 is not build correctly.
My guess is that it is built on VMS 8.4 and backwards compatible.

/Toine

Ph Vouters
Valued Contributor

Re: Java 6 update patch for OpenVMS when ?

Dear Toine,

I still have a pending issue on Java V6.0 dealing with lib$signal(SS$_DEBUG) called from within a JNI. This is described at http://vouters.dyndns.org/tima/OpenVMS-Java-V6.0-A_user_experience_with_OpenVMS_IA64_Java_V6.0.html

Neither with JNA nor JNI tests did I suffer using Java/VMS/IA64 from the symptom you describe.

Would you be possible you send me a reproducer to my email account you own ? I then shall be able to do tests and attempt find if not a solution hopefully at least a temporary workaround.

Note that I intend to test using both Java and C. With C, I'll use direct calls dlopen/dlsym/dlclose which are the underneath Java/VMS/IA64 calls.

Best regards,
Philippe
Rick Retterer
Respected Contributor
Solution

Re: Java 6 update patch for OpenVMS when ?

Toine,
Are you using the java command line argument "-Djava.awt.headless=" on your java command-line?

If so I have a workaround...

As a workaround, try doing this:

1) $ set process/parse=extend

2) $ Rename SYS$COMMON:[JAVA$60.JRE.LIB.IA64.HEADLESS]JAVA$MAWT_SHR.EXE;1 -
_$ SYS$COMMON:[JAVA$60.JRE.LIB.IA64.HEADLESS] java$mawt_shr.exe ??!<<Ã -------same image name, but lowercase

Rename the file JAVA$MAWT_SHR.EXE from uppercase to lowercase characters and then test your application again.

Engineering is aware of this issue, and are working to fix it as quickly as possible.

Let us know the results of your test.

Rick


- Rick Retterer



Toine_1
Regular Advisor

Re: Java 6 update patch for OpenVMS when ?

Hi Rick,

I renamed the file below and now my java application is working OK.

$ Rename SYS$COMMON:[JAVA$60.JRE.LIB.IA64.HEADLESS]JAVA$MAWT_SHR.EXE;1 -
_$ SYS$COMMON:[JAVA$60.JRE.LIB.IA64.HEADLESS] java$mawt_shr.exe

Thanks,

Toine
Rick Retterer
Respected Contributor

Re: Java 6 update patch for OpenVMS when ?

Toine,
Thanks for the update. Glad to hear that it's working now.

This issue will be fixed in a future release of Java. Keep monitoring the OpenVMS Java website periodically...

When it's fixed, the Java release notes will outline it and announce that it has been fixed.

Engineering is trying to get it into the next kit, but it has not been confirmed. It may be a couple of versions out before it gets fixed but the workaround will get you past it for now.

Cheers,
Rick
- Rick Retterer