Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

LANCP connects, then fails

 

LANCP connects, then fails

After using DECnet (phase IV) MOP successfully for decades, I want to move to LANCP now for a couple of trusty old DECservers. I think I have everything set up properly for DLL and console connections, but I have only partial success:

LANCP> conn node tshn01/dev=ewa0
Connecting to 08-00-2B-05-9D-6A via EWA0 ....
MOP V3 format selected (1534 cmd size), type Control-D to disconnect
#
DECserver 200 Terminal Server V3.3A (BL40) - LAT V5.1
Raum ARES XMZ W251

Please type HELP if you need assistance

Enter username>
%LANCP-E-NORSP, No response from target node, device EWA0
LANCP> Fr
%CLI-W-IVVERB, unrecognized command verb - check validity and spelling
\FR\
LANCP>

As you can see, the DECserver greets and prompts me for a username, so there IS a connection. However, while I try to enter "Fr" as the username, the connection fails, and the input goes to LANCP's command processor instead.

This happens with OpenVMS V8.3 on a DS20E and is reproducible except for a slight variation in timing: sometimes, the connection drops before I can enter the terminal server's access password in response to the "#" prompt, sometimes it lasts a little longer, but I have not yet been able to issue any DECserver commands before I got disconnected.

I tried another DECserver with the same result.

I installed patch VMS83A_LAN-V0300, which -- according to its release notes -- is supposed to improve robustness of LANCP CONNECTs, but the symptoms remain the same.

Unfortunately, neither HELP/MESSAGE nor Google turned up any information about the %LANCP-E-NORSP message, so I could use some hints on how to proceed with troubleshooting.

Does it mean anything if MCR NCP CON VIA EWA-0 PHY ADDR... still delivers a reliable connection? (DECnet MOP is turned off if SHOW CIRC EWA-0 CHAR says "Service = disabled", correct?)

Thanks in advance for any and all help!
Andreas
14 REPLIES 14
Hoff
Honored Contributor

Re: LANCP connects, then fails

Try turning off DECnet MOP service; I'd expect that only one stack can have MOP lit up at a time.

Re: LANCP connects, then fails

Hoff,

Thanks for the hint. I'd agree there may be interference if MOP is on in both LANCP and NCP at the same time, but doesn't this "Service = disabled" mean that it's off here?

NCP>sh ci ewa-0 c


Circuit Volatile Characteristics as of 11-MAR-2009 18:20:41

Circuit = EWA-0

State = on
Service = disabled
Designated router = 1.244 (R1HNEQ)
Cost = 4
Maximum routers allowed = 33
Router priority = 64
Hello timer = 15
Type = Ethernet
Adjacent node = 1.244 (R1HNEQ)
Listen timer = 45


NCP>

Regards,
Andreas
Hoff
Honored Contributor

Re: LANCP connects, then fails

I don't see a reason for the connect to fail.

DECnet MOP service is correctly disabled in Phase IV here, yes.

There's a replacement LANCP image in various of the V8.3 UPDATE kits. Are you current on your (other) ECO kits?

That # is reminiscent of the server password knob.

Here's the template of what I usually use:

http://64.223.189.234/node/233
Richard Stockdale
Frequent Advisor

Re: LANCP connects, then fails

Not much has been done with LANCP CONNECT in recent years, until a few months ago, when some recent support for LANCP CONNECT/INPUT=file had some problems. So a lot of work was put into LANCP CONNECT over the last few months and the new image might resolve your problem. This will be in the next VMS83*LAN patch kits, which should be out in a few months. If you can escalate the problem you can get a new LANCP much sooner.

- Dick
Wim Van den Wyngaert
Honored Contributor

Re: LANCP connects, then fails

Long time ago I had simular problems. The MOP of DECnet and LANCP are not the same.
They react differently on transmission problems. In my case, the download of the image failed partly(not always). The decserver had a full duplex line instead of a half duplex. Solved that and both mops where working fine.

Wim
Wim