Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

LAT port error %REM-E-PORTRXERR

Julian Mathews
Occasional Contributor

LAT port error %REM-E-PORTRXERR

I'm a LAT newbie and have a problem getting data from a DecServer90M terminal server port using LAT. Seem to be connecting okay via the lat port but get the following errors every time I'm expecting data.

%REM-E-PORTRXERR, port receive error
-SYSTEM-F-PARITY, parity error

I guess the parity error is a give away. The current setup on the decserver is:

Port 2: (Remote)

Character Size: 7
Input Speed: 4800
Flow Control: XON
Output Speed: 4800
Parity: Even
Signal Control: Disabled
Stop Bits: Dynamic

Access: Remote
Local Switch: None
Backwards Switch: None Name: PORT_2
Break: Local Session Limit: 4
Forwards Switch: None Type: Ansi
Default Protocol: LAT

Preferred Service: None

Authorized Groups: 0
(Current) Groups: 0

Enabled Characteristics:
Autoprompt, Failover, Input Flow Control, Lock, Loss Notification,
Message Codes, Output Flow Control, Verification

Is this a problem with the LAT port or the term server? Any help would be greatly appreciated.
Julian
6 REPLIES
Jan van den Ende
Honored Contributor

Re: LAT port error %REM-E-PORTRXERR

Hi Julian,

What is this particlar port used for?
Is it to connect a terminal (or -emulator) to VMS to enable login?
Then, CHANGE access to LOCAL.

The setting REMOTE _is_ OK if your host is accessing the device via this port ( eg., a printer, or any other periferal)
In that case, you should check that the device port speed under VMS that accesses this port, AND the speed of the connected device, AND the terminal server port setting, all agree.

If this does not help, supply us with more info on the way this port IS used.


hth


Jan
Don't rust yours pelled jacker to fine doll missed aches.
Antoniov.
Honored Contributor

Re: LAT port error %REM-E-PORTRXERR

Hi Julian,
readeing you data, I guess this port is used by a predefined port, such as a printer. However I hint you set frame to 8 bits (character size 7->8) and disbale parity even if you are using some old printer.
I already used 90M with LG31 printer and when I set 7 bit parity even I received PARITY ERROR; after I set 8 bit, no parity, printer worked fine.
Also you could set hard type port instead ansi port; if you don't use PPL2 printers (Digital printers) you can find some problem in this feature.
Have a great day
@Antoniov
Antonio Maria Vigliotti
Steve Reece
Advisor

Re: LAT port error %REM-E-PORTRXERR

Have you managed to sort this out Julian? If not, an explanation of what you're trying to do and how you get the parity error might help.

Steve
"Try not! Do, or Do not. There is no try!"
Martin P.J. Zinser
Honored Contributor

Re: LAT port error %REM-E-PORTRXERR

Hello Julian,

also the speed of 4800 seems a bit odd, it is a long time since I have seen anything that can not at the very least handle 9600. If you would give us some more information on what you want to do with this port, we might be able to help you better in the forum here.

Greetings, Martin
Galen Tackett
Valued Contributor

Re: LAT port error %REM-E-PORTRXERR

The port counters on the terminal server would be a quick way to rule out the LAT side of things

To reset the port counters to zero, use the command:

Local> ZERO PORT nnn COUNTERS

where nnn of course represents the port number.

As soon as you get the parity error, check the counters with

Local> SHOW PORT nnn COUNTERS

(Alternatively you can say MONITOR PORT nnn COUNTERS and just watch the counters update dynamically.)

If you see the port counters increasing when you get the parity error, then you can be pretty confident that LAT is not itself the source of the problem. Then you can focus on baud rate, stop bits, parity settings, etc. If all those are correct then you may have a problem with the cable or with the terminal server's (physical) port.

See the terminal server's help on TEST PORT for some information on doing loopback tests which could help you isolate between cable problems and port problems.
Julian Mathews
Occasional Contributor

Re: LAT port error %REM-E-PORTRXERR

Hi all,

Thanks for the replies, much appreciated. This problem turned out to be due to a change of equipment at the other end of the LAT circuit with subsequent changes to the port settings rendering it unusable. I'm sure no one here will be surprised that there was no fault found with the VMS component.

regards, Julian