Operating System - OpenVMS
cancel
Showing results for 
Search instead for 
Did you mean: 

LPD jobs going to wrong printers

 
SOLVED
Go to solution
John Welsh_2
Regular Advisor

LPD jobs going to wrong printers

Hi,
I have a problem with VMS UCX LPD print queues.
Occasionally a job will print out on the wrong printer and also some print jobs will have data from a different print job. As per the attached, there are Generic print queues then relay queues using telnetsym to point to the LPD queues. I have checked the printcap files on each node and can't see any problems.
The queue config has been running for years without any problems and now has developed this situation. The systems are a VMS cluster running V7.1. Any help would be appreciated. Thanks.
8 REPLIES 8
Joseph Huber_1
Honored Contributor

Re: LPD jobs going to wrong printers

If I see it right, both LPD queues point to the same printer in printcap:

:rm=EB01:\
:rp=L1:\

http://www.mpp.mpg.de/~huber
John Welsh_2
Regular Advisor

Re: LPD jobs going to wrong printers

Hi Joseph, yes thats correct, I believe two requests to the same printer should be handled by the internal LPD queue within the printer.
Regards,
John W.
Joseph Huber_1
Honored Contributor

Re: LPD jobs going to wrong printers

So both queues target to printer L1 at the same printserver, but they sometimes print on a different printer not in the printcap file ?

Could it be a IP address or domain name translation problem ? The 'other" printer using the same address, or the DNS server having both at the same address ?
http://www.mpp.mpg.de/~huber
Hoff
Honored Contributor
Solution

Re: LPD jobs going to wrong printers

Here is a text conversion of the Microsoft Office .doc attachment from the original post.

There is not yet a clear trigger here.

Yes, check your IP addressing and you network.

Any patterns to the misprinted jobs?

Particular printer(s) involved? Include printers that have shown the misprinting in your IP-level checks and your investigations.

Intermingled data does definitely point to a network-level error in either the host (possible, this is old software), the network (most likely) or in the printer (less likely).

Intermingled or misrouted data can also point to a failed or severely overloaded and buggy network switch or router.

Also check for and apply the ECO kits for your TCP/IP Services V4.2 software (you're at ECO 4) and any firmware for whichever printer(s) are involved here.
John Welsh_2
Regular Advisor

Re: LPD jobs going to wrong printers

Thanks guys. This gives me something to work on. I will investigate further, especially DNS/network problems. I appreciate your help.
I will post any updates. Regards, JohnW.
Andy Bustamante
Honored Contributor

Re: LPD jobs going to wrong printers

>>>The queue config has been running for years without any problems and now has developed this situation.

Has anything in the network, printers or systems changed recently?

I had an interesting issue recently where a large report failed to print, printed the same page over and over again and eventually stalled on a system that had been in place for years. This report was the only failure reported. Turned out the switching had been upgraded, the old printer was configured at 10 mb half duplex and the new switch was set to auto negotiate. A large job would fail, one or two pages print without issue.

If you don't have time to do it right, when will you have time to do it over? Reach me at first_name + "." + last_name at sysmanager net
John Welsh_2
Regular Advisor

Re: LPD jobs going to wrong printers

Hi guys,
Thought I had better close this. I am still investigating the network for causes for this problem. Thanks for the help.
John Welsh_2
Regular Advisor

Re: LPD jobs going to wrong printers

As above